aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-16 06:17:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-16 06:17:25 +0000
commit865872ac50d3083e80b7c87cbeeea2df3d9c920c (patch)
tree52eb4b62c77db764fa9cdd0473e366ac2de37751 /astro/celestia
parent3d110446093937ba865ef4c6d7222c84592b27b4 (diff)
downloadports-865872ac50d3083e80b7c87cbeeea2df3d9c920c.tar.gz
ports-865872ac50d3083e80b7c87cbeeea2df3d9c920c.zip
Notes
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile52
-rw-r--r--astro/celestia/distinfo6
-rw-r--r--astro/celestia/files/patch-config.h.in30
-rw-r--r--astro/celestia/files/patch-src_celengine_command.h11
-rw-r--r--astro/celestia/files/patch-src_celengine_star.h11
-rw-r--r--astro/celestia/files/patch-src_celutil_util.h10
-rw-r--r--astro/celestia/pkg-plist272
7 files changed, 262 insertions, 130 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 495142620a05..f0cd9a29983d 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= celestia
-PORTVERSION= 1.4.1
-PORTREVISION= 9
+PORTVERSION= 1.6.0
CATEGORIES= astro
MASTER_SITES= SF
PKGNAMESUFFIX= -${CELESTIA_UI}
@@ -25,14 +24,12 @@ USE_XORG= x11 xt xext xmu xi
USE_GETTEXT= yes
WANT_GNOME= yes
-CONFIGURE_ARGS= --program-prefix=""
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
-CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|} # lol
+CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
.if ${CELESTIA_UI} == "glut"
CONFIGURE_ARGS+= --with-glut
@@ -45,58 +42,47 @@ CONFIGURE_ARGS+= --with-gnome
USE_GNOME+= libgnomeui
GCONF_SCHEMAS= celestia.schemas
.else
-IGNORE= invalid CELESTIA_UI value "${CELESTIA_UI}" -- valid values are ${UI_LIST}
+IGNORE= requires one of the <${UI_LIST}> values for CELESTIA_UI
.endif
.if ${CELESTIA_UI} == "gtk" || ${CELESTIA_UI} == "gnome"
USE_GNOME+= gnomehack
-LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext \
+ theora.0:${PORTSDIR}/multimedia/libtheora
STARTUP_NOTIFY= true
PLIST_FILES+= share/celestia/celestia-logo.png share/celestia/celestiaui.xml
.else
STARTUP_NOTIFY= false
.endif
-PORTDOCS= AUTHORS CelestiaKeyAssignments.txt ChangeLog \
- KbdMouseJoyControls.txt README TODO TRANSLATORS \
- coding-standards.html devguide.txt
+PORTDOCS= AUTHORS ChangeLog README
DESKTOP_ENTRIES="Celestia" \
"Explore space" \
"celestia.png" \
"celestia" \
- "Application;Astronomy;Science;Education;" \
+ "Application;Astronomy;Education;Science;" \
${STARTUP_NOTIFY}
-OPTIONS= LUA "Lua support" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LUA)
-USE_LUA= 5.0
-CONFIGURE_ARGS+= --with-lua
-CPPFLAGS+= -I${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
-.endif
+USE_LUA= 5.0+
+CONFIGURE_ARGS+= --with-lua LUA_CFLAGS=-I${LUA_INCDIR} \
+ LUA_LIBS=-L${LUA_LIBDIR} LUALIB_LIBS=-llua
pre-patch:
-.for o in -O2 -Wall -ffast-math -fexpensive-optimizations -fomit-frame-pointer
- @${REINPLACE_CMD} -e 's|${o}||g' ${WRKSRC}/configure
+.for o in O2 ffast-math fexpensive-optimizations fomit-frame-pointer
+ @${REINPLACE_CMD} -e 's|-${o}||g' ${WRKSRC}/configure
.endfor
+# Inhibit installation of copies of GPL (lots of them!)
@${REINPLACE_CMD} -e 's|COPYING||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|=.*COPYING_\*)|=| ; \
+ /KDE_DIST/s|COPYING_[^ ]* ||g' ${WRKSRC}/locale/Makefile.in
post-install:
- ${MKDIR} ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKSRC}/src/celestia/gtk/data/celestia.png \
${PREFIX}/share/pixmaps
-.for m in apollo cassini galileo gemini hubble iss marsglobalsurvr \
- marsodyssey mercury7 mir skylab
- ${INSTALL_DATA} ${WRKSRC}/models/${m}.3ds \
- ${PREFIX}/share/celestia/models
-.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/astro/celestia/distinfo b/astro/celestia/distinfo
index 9d54c550d7cd..40e66549f13b 100644
--- a/astro/celestia/distinfo
+++ b/astro/celestia/distinfo
@@ -1,3 +1,3 @@
-MD5 (celestia-1.4.1.tar.gz) = be1d36fc97a13b9a276249dbc0efac41
-SHA256 (celestia-1.4.1.tar.gz) = f9dc34dbc0d53e98534000545802b5ab4a471c3cb3fa08a9c958cbbbeb28d8b5
-SIZE (celestia-1.4.1.tar.gz) = 23966886
+MD5 (celestia-1.6.0.tar.gz) = 9b96a8e7666ab5a26f032b9d605e023d
+SHA256 (celestia-1.6.0.tar.gz) = 9d9785b651cb42b890765f97234eaed3b03bf5e07dfb1be4f123a27260cdbbd4
+SIZE (celestia-1.6.0.tar.gz) = 51848015
diff --git a/astro/celestia/files/patch-config.h.in b/astro/celestia/files/patch-config.h.in
deleted file mode 100644
index ea51cc9317cf..000000000000
--- a/astro/celestia/files/patch-config.h.in
+++ /dev/null
@@ -1,30 +0,0 @@
---- config.h.in.orig Thu May 4 11:37:39 2006
-+++ config.h.in Thu May 4 11:37:52 2006
-@@ -248,27 +248,6 @@
-
-
-
--#if !defined(HAVE_STRLCAT_PROTO)
--#ifdef __cplusplus
--extern "C" {
--#endif
--unsigned long strlcat(char*, const char*, unsigned long);
--#ifdef __cplusplus
--}
--#endif
--#endif
--
--
--
--#if !defined(HAVE_STRLCPY_PROTO)
--#ifdef __cplusplus
--extern "C" {
--#endif
--unsigned long strlcpy(char*, const char*, unsigned long);
--#ifdef __cplusplus
--}
--#endif
--#endif
-
-
-
diff --git a/astro/celestia/files/patch-src_celengine_command.h b/astro/celestia/files/patch-src_celengine_command.h
deleted file mode 100644
index 23e551db6216..000000000000
--- a/astro/celestia/files/patch-src_celengine_command.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/celengine/command.h.orig Tue May 22 13:29:01 2007
-+++ src/celengine/command.h Tue May 22 13:29:30 2007
-@@ -94,7 +94,7 @@
- class CommandGotoLongLat : public InstantaneousCommand
- {
- public:
-- CommandGotoLongLat::CommandGotoLongLat(double t,
-+ CommandGotoLongLat(double t,
- double dist,
- float _longitude, float _latitude,
- Vec3f _up);
diff --git a/astro/celestia/files/patch-src_celengine_star.h b/astro/celestia/files/patch-src_celengine_star.h
deleted file mode 100644
index 776398ccfe9b..000000000000
--- a/astro/celestia/files/patch-src_celengine_star.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/celengine/star.h.orig Tue May 22 12:51:07 2007
-+++ src/celengine/star.h Tue May 22 12:51:22 2007
-@@ -30,7 +30,7 @@
- // orbits and StarDetails objects. Currently, it's assumed that they
- // have lifetimes that continue until program termination.
- public:
-- StarDetails::StarDetails();
-+ StarDetails();
-
- inline float getRadius() const;
- inline float getTemperature() const;
diff --git a/astro/celestia/files/patch-src_celutil_util.h b/astro/celestia/files/patch-src_celutil_util.h
deleted file mode 100644
index 793e804b7e90..000000000000
--- a/astro/celestia/files/patch-src_celutil_util.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/celutil/util.h.orig Thu May 4 11:51:00 2006
-+++ src/celutil/util.h Thu May 4 11:51:12 2006
-@@ -28,6 +28,7 @@
- #ifdef _WIN32
- #define _(s) s
- #else
-+#include <libintl.h>
- #define _(s) gettext(s)
- #endif
-
diff --git a/astro/celestia/pkg-plist b/astro/celestia/pkg-plist
index 911ac39d9010..e33005d7e9c4 100644
--- a/astro/celestia/pkg-plist
+++ b/astro/celestia/pkg-plist
@@ -1,35 +1,51 @@
bin/celestia
share/celestia/celestia.cfg
share/celestia/controls.txt
+share/celestia/controls_bg.txt
+share/celestia/controls_de.txt
+share/celestia/controls_es.txt
+share/celestia/controls_fr.txt
+share/celestia/controls_it.txt
+share/celestia/controls_ja.txt
+share/celestia/controls_ko.txt
+share/celestia/controls_nl.txt
+share/celestia/controls_pl.txt
+share/celestia/controls_pt.txt
+share/celestia/controls_pt_BR.txt
+share/celestia/controls_ru.txt
+share/celestia/controls_sv.txt
+share/celestia/controls_uk.txt
+share/celestia/controls_zh_CN.txt
share/celestia/data/asterisms.dat
share/celestia/data/asteroids.ssc
share/celestia/data/boundaries.dat
-share/celestia/data/cassini.xyz
+share/celestia/data/charm2.stc
share/celestia/data/comets.ssc
-share/celestia/data/deepsky.dsc
share/celestia/data/earth_locs.ssc
share/celestia/data/eros_locs.ssc
share/celestia/data/extrasolar.ssc
share/celestia/data/extrasolar.stc
-share/celestia/data/galileo.xyz
+share/celestia/data/galaxies.dsc
share/celestia/data/gaspra_locs.ssc
+share/celestia/data/globulars.dsc
share/celestia/data/hdxindex.dat
-share/celestia/data/huygens.xyz
share/celestia/data/ida_locs.ssc
+share/celestia/data/itokawa_locs.ssc
share/celestia/data/jupitermoons_locs.ssc
share/celestia/data/mars_locs.ssc
share/celestia/data/marsmoons_locs.ssc
share/celestia/data/merc_locs.ssc
+share/celestia/data/minormoons.ssc
share/celestia/data/moon_locs.ssc
share/celestia/data/nearstars.stc
share/celestia/data/neptunemoons_locs.ssc
+share/celestia/data/numberedmoons.ssc
share/celestia/data/outersys.ssc
share/celestia/data/revised.stc
share/celestia/data/ring_locs.ssc
share/celestia/data/saoxindex.dat
share/celestia/data/saturnmoons_locs.ssc
share/celestia/data/solarsys.ssc
-share/celestia/data/spacecraft.ssc
share/celestia/data/spectbins.stc
share/celestia/data/starnames.dat
share/celestia/data/stars.dat
@@ -38,10 +54,73 @@ share/celestia/data/venus_locs.ssc
share/celestia/data/visualbins.stc
share/celestia/data/world-capitals.ssc
share/celestia/demo.cel
+share/celestia/demo_de.cel
+share/celestia/demo_es.cel
+share/celestia/demo_fr.cel
+share/celestia/demo_it.cel
+share/celestia/demo_ja.cel
+share/celestia/demo_ko.cel
+share/celestia/demo_lt.cel
+share/celestia/demo_lv.cel
+share/celestia/demo_nl.cel
+share/celestia/demo_pl.cel
+share/celestia/demo_pt.cel
+share/celestia/demo_pt_BR.cel
+share/celestia/demo_ru.cel
+share/celestia/demo_sv.cel
+share/celestia/demo_tr.cel
+share/celestia/demo_uk.cel
+share/celestia/demo_zh_CN.cel
+share/celestia/extras-standard/cassini/cassini.ssc
+share/celestia/extras-standard/cassini/data/cassini-cruise.xyzv
+share/celestia/extras-standard/cassini/data/cassini-orbit.xyzv
+share/celestia/extras-standard/cassini/models/cassini.3ds
+share/celestia/extras-standard/cassini/models/huygens.3ds
+share/celestia/extras-standard/galileo/galileo.ssc
+share/celestia/extras-standard/galileo/models/galileo.3ds
+share/celestia/extras-standard/hubble/hubble.ssc
+share/celestia/extras-standard/hubble/models/hubble.cmod
+share/celestia/extras-standard/iss/iss.ssc
+share/celestia/extras-standard/iss/models/iss.cmod
+share/celestia/extras-standard/iss/textures/medres/d_ring.jpg
+share/celestia/extras-standard/iss/textures/medres/graple.jpg
+share/celestia/extras-standard/iss/textures/medres/iss_dc.jpg
+share/celestia/extras-standard/iss/textures/medres/iss_dcs.jpg
+share/celestia/extras-standard/iss/textures/medres/iss_un.jpg
+share/celestia/extras-standard/iss/textures/medres/issb.jpg
+share/celestia/extras-standard/iss/textures/medres/issb2.jpg
+share/celestia/extras-standard/iss/textures/medres/issb3.jpg
+share/celestia/extras-standard/iss/textures/medres/issb4.jpg
+share/celestia/extras-standard/iss/textures/medres/issbs.jpg
+share/celestia/extras-standard/iss/textures/medres/issbso.jpg
+share/celestia/extras-standard/iss/textures/medres/issbso2.jpg
+share/celestia/extras-standard/iss/textures/medres/isscov2.jpg
+share/celestia/extras-standard/iss/textures/medres/isscover.jpg
+share/celestia/extras-standard/iss/textures/medres/isscup.jpg
+share/celestia/extras-standard/iss/textures/medres/issdish.jpg
+share/celestia/extras-standard/iss/textures/medres/issdot.jpg
+share/celestia/extras-standard/iss/textures/medres/issesa.jpg
+share/celestia/extras-standard/iss/textures/medres/isshand.jpg
+share/celestia/extras-standard/iss/textures/medres/issins.jpg
+share/celestia/extras-standard/iss/textures/medres/issku.jpg
+share/celestia/extras-standard/iss/textures/medres/issku1.jpg
+share/celestia/extras-standard/iss/textures/medres/issku2.jpg
+share/celestia/extras-standard/iss/textures/medres/issmb.jpg
+share/celestia/extras-standard/iss/textures/medres/issmod.jpg
+share/celestia/extras-standard/iss/textures/medres/issp2.jpg
+share/celestia/extras-standard/iss/textures/medres/isspanel.jpg
+share/celestia/extras-standard/iss/textures/medres/issrad.jpg
+share/celestia/extras-standard/iss/textures/medres/issred.jpg
+share/celestia/extras-standard/iss/textures/medres/isssolar.jpg
+share/celestia/extras-standard/iss/textures/medres/issusa.jpg
+share/celestia/extras-standard/iss/textures/medres/issusaf.jpg
+share/celestia/extras-standard/iss/textures/medres/isszmod.jpg
+share/celestia/extras-standard/iss/textures/medres/metalcon.jpg
+share/celestia/extras-standard/iss/textures/medres/nasda.jpg
+share/celestia/extras-standard/iss/textures/medres/questcov.jpg
+share/celestia/extras-standard/mir/mir.ssc
+share/celestia/extras-standard/mir/models/mir.3ds
share/celestia/extras/apollo.ssc
-share/celestia/extras/comets.ssc
-share/celestia/extras/minormoons.ssc
-share/celestia/extras/numberedmoons.ssc
share/celestia/extras/shroxclassic.ssc
share/celestia/extras/shroxmars.ssc
share/celestia/extras/skylab.ssc
@@ -59,65 +138,126 @@ share/celestia/fonts/helvbold18.txf
share/celestia/fonts/helvbold24.txf
share/celestia/fonts/sans10.txf
share/celestia/fonts/sans12.txf
+share/celestia/fonts/sans12_bg.txf
+share/celestia/fonts/sans12_ja.txf
+share/celestia/fonts/sans12_ko.txf
+share/celestia/fonts/sans12_ru.txf
+share/celestia/fonts/sans12_uk.txf
+share/celestia/fonts/sans12_zh_CN.txf
share/celestia/fonts/sans14.txf
+share/celestia/fonts/sans14_ja.txf
+share/celestia/fonts/sans14_ko.txf
+share/celestia/fonts/sans14_ru.txf
+share/celestia/fonts/sans14_uk.txf
+share/celestia/fonts/sans14_zh_CN.txf
share/celestia/fonts/sans20.txf
share/celestia/fonts/sansbold10.txf
share/celestia/fonts/sansbold12.txf
share/celestia/fonts/sansbold14.txf
share/celestia/fonts/sansbold20.txf
+share/celestia/fonts/sansbold20_bg.txf
+share/celestia/fonts/sansbold20_ja.txf
+share/celestia/fonts/sansbold20_ko.txf
+share/celestia/fonts/sansbold20_ru.txf
+share/celestia/fonts/sansbold20_uk.txf
+share/celestia/fonts/sansbold20_zh_CN.txf
share/celestia/guide.cel
-share/celestia/models/S0.pts
-share/celestia/models/SBa.pts
-share/celestia/models/SBb.pts
-share/celestia/models/SBc.pts
-share/celestia/models/Sa.pts
-share/celestia/models/Sb.pts
-share/celestia/models/Sc.pts
+share/celestia/guide_bg.cel
+share/celestia/guide_de.cel
+share/celestia/guide_es.cel
+share/celestia/guide_fr.cel
+share/celestia/guide_it.cel
+share/celestia/guide_ja.cel
+share/celestia/guide_ko.cel
+share/celestia/guide_lt.cel
+share/celestia/guide_nl.cel
+share/celestia/guide_pl.cel
+share/celestia/guide_pt.cel
+share/celestia/guide_pt_BR.cel
+share/celestia/guide_ru.cel
+share/celestia/guide_sv.cel
+share/celestia/guide_uk.cel
+share/celestia/guide_zh_CN.cel
+share/celestia/models/E0.png
+share/celestia/models/MilkyWay.png
+share/celestia/models/S0.png
+share/celestia/models/SBa.png
+share/celestia/models/SBb.png
+share/celestia/models/SBc.png
+share/celestia/models/Sa.png
+share/celestia/models/Sb.png
+share/celestia/models/Sc.png
+share/celestia/models/amalthea.3ds
share/celestia/models/amalthea.cmod
share/celestia/models/apollo.3ds
share/celestia/models/asteroid.cms
+share/celestia/models/bacchus.3ds
share/celestia/models/bacchus.cmod
share/celestia/models/borrelly.cms
-share/celestia/models/cassini.3ds
+share/celestia/models/castalia.3ds
share/celestia/models/castalia.cmod
+share/celestia/models/deimos.3ds
share/celestia/models/deimos.cmod
+share/celestia/models/epimetheus.3ds
share/celestia/models/epimetheus.cmod
+share/celestia/models/eros.3ds
share/celestia/models/eros.cmod
share/celestia/models/eros.cms
-share/celestia/models/galileo.3ds
+share/celestia/models/gaspra.3ds
share/celestia/models/gaspra.cmod
share/celestia/models/gemini.3ds
+share/celestia/models/geographos.3ds
share/celestia/models/geographos.cmod
+share/celestia/models/golevka.3ds
share/celestia/models/golevka.cmod
+share/celestia/models/halley.3ds
share/celestia/models/halley.cmod
-share/celestia/models/hubble.3ds
+share/celestia/models/hyperion.3ds
share/celestia/models/hyperion.cmod
share/celestia/models/hyperion.cms
+share/celestia/models/ida.3ds
share/celestia/models/ida.cmod
-share/celestia/models/iss.3ds
+share/celestia/models/itokawa.cmod
+share/celestia/models/janus.3ds
share/celestia/models/janus.cmod
+share/celestia/models/kleopatra.3ds
share/celestia/models/kleopatra.cmod
+share/celestia/models/ky26.3ds
share/celestia/models/ky26.cmod
+share/celestia/models/larissa.3ds
share/celestia/models/larissa.cmod
share/celestia/models/marsglobalsurvr.3ds
share/celestia/models/marsodyssey.3ds
share/celestia/models/mercury7.3ds
-share/celestia/models/mir.3ds
+share/celestia/models/pandora.3ds
share/celestia/models/pandora.cmod
+share/celestia/models/phobos.3ds
share/celestia/models/phobos.cmod
+share/celestia/models/phoebe.3ds
share/celestia/models/phoebe.cmod
+share/celestia/models/prometheus.3ds
share/celestia/models/prometheus.cmod
+share/celestia/models/proteus.3ds
share/celestia/models/proteus.cmod
share/celestia/models/proteus.cms
share/celestia/models/roughsphere.cms
share/celestia/models/skylab.3ds
+share/celestia/models/toutatis.3ds
share/celestia/models/toutatis.cmod
+share/celestia/models/vesta.3ds
share/celestia/models/vesta.cmod
+share/celestia/scripts/eclipticgrid.celx
+share/celestia/scripts/galacticgrid.celx
+share/celestia/scripts/horizontalgrid.celx
+share/celestia/scripts/mark-lg.celx
+share/celestia/scripts/z-dist.celx
share/celestia/shaders/bumpdiffuse.vp
share/celestia/shaders/bumpdiffuse_arb.vp
+share/celestia/shaders/bumpdiffuse_arb_hdr.vp
share/celestia/shaders/bumpdiffuse_nv.fp
share/celestia/shaders/bumphaze.vp
share/celestia/shaders/bumphaze_arb.vp
+share/celestia/shaders/bumphaze_arb_hdr.vp
share/celestia/shaders/diffuse.vp
share/celestia/shaders/diffuse2_arb.vp
share/celestia/shaders/diffuse_arb.vp
@@ -135,7 +275,9 @@ share/celestia/shaders/haze_arb.vp
share/celestia/shaders/multishadow_arb.vp
share/celestia/shaders/night.vp
share/celestia/shaders/night2_arb.vp
+share/celestia/shaders/night2_arb_hdr.vp
share/celestia/shaders/night_arb.vp
+share/celestia/shaders/night_arb_hdr.vp
share/celestia/shaders/rings.vp
share/celestia/shaders/rings_arb.vp
share/celestia/shaders/ringshadow.vp
@@ -155,7 +297,36 @@ share/celestia/shaders/texphong_arb.vp
share/celestia/shaders/texphong_nv.fp
share/celestia/splash/splash.png
share/celestia/start.cel
+share/celestia/start_bg.cel
+share/celestia/start_de.cel
+share/celestia/start_es.cel
+share/celestia/start_fr.cel
+share/celestia/start_hu.cel
+share/celestia/start_it.cel
+share/celestia/start_ja.cel
+share/celestia/start_ko.cel
+share/celestia/start_lt.cel
+share/celestia/start_lv.cel
+share/celestia/start_nl.cel
+share/celestia/start_pl.cel
+share/celestia/start_pt.cel
+share/celestia/start_pt_BR.cel
+share/celestia/start_ru.cel
+share/celestia/start_sv.cel
+share/celestia/start_uk.cel
+share/celestia/start_zh_CN.cel
share/celestia/textures/flare.jpg
+share/celestia/textures/hires/dione.jpg
+share/celestia/textures/hires/enceladus.jpg
+share/celestia/textures/hires/iapetus.jpg
+share/celestia/textures/hires/mercury.jpg
+share/celestia/textures/hires/mimas.jpg
+share/celestia/textures/hires/moon.jpg
+share/celestia/textures/hires/moonbump.jpg
+share/celestia/textures/hires/phoebe.jpg
+share/celestia/textures/hires/rhea.jpg
+share/celestia/textures/hires/tethys.jpg
+share/celestia/textures/hires/titan.jpg
share/celestia/textures/logo.png
share/celestia/textures/lores/amalthea.jpg
share/celestia/textures/lores/ariel-lok-mask.png
@@ -201,9 +372,7 @@ share/celestia/textures/lores/janus.jpg
share/celestia/textures/lores/jupiter.jpg
share/celestia/textures/lores/mars.jpg
share/celestia/textures/lores/marsbump.jpg
-share/celestia/textures/lores/mercury-lok-mask.png
share/celestia/textures/lores/mercury.jpg
-share/celestia/textures/lores/mimas-lok-mask.png
share/celestia/textures/lores/mimas.jpg
share/celestia/textures/lores/miranda-lok-mask.png
share/celestia/textures/lores/miranda.jpg
@@ -272,10 +441,6 @@ share/celestia/textures/medres/hyperion.jpg
share/celestia/textures/medres/iapetus.jpg
share/celestia/textures/medres/idamosaic.jpg
share/celestia/textures/medres/io.jpg
-share/celestia/textures/medres/iss-cap1.jpg
-share/celestia/textures/medres/iss-mc1.jpg
-share/celestia/textures/medres/iss-mc31.jpg
-share/celestia/textures/medres/iss-sol1.jpg
share/celestia/textures/medres/janus.jpg
share/celestia/textures/medres/jupiter.jpg
share/celestia/textures/medres/mars.jpg
@@ -306,30 +471,73 @@ share/celestia/textures/medres/venus.jpg
share/celestia/textures/medres/venuslike.jpg
share/celestia/textures/medres/venuslikenight.jpg
share/celestia/textures/medres/venussurface.jpg
+share/locale/ar/LC_MESSAGES/celestia.mo
+share/locale/ar/LC_MESSAGES/celestia_constellations.mo
+share/locale/bg/LC_MESSAGES/celestia.mo
+share/locale/bg/LC_MESSAGES/celestia_constellations.mo
share/locale/de/LC_MESSAGES/celestia.mo
+share/locale/de/LC_MESSAGES/celestia_constellations.mo
share/locale/el/LC_MESSAGES/celestia.mo
-share/locale/en/LC_MESSAGES/celestia.mo
+share/locale/el/LC_MESSAGES/celestia_constellations.mo
+share/locale/en/LC_MESSAGES/celestia_constellations.mo
share/locale/es/LC_MESSAGES/celestia.mo
+share/locale/es/LC_MESSAGES/celestia_constellations.mo
share/locale/fr/LC_MESSAGES/celestia.mo
-share/locale/gl/LC_MESSAGES/celestia.mo
+share/locale/fr/LC_MESSAGES/celestia_constellations.mo
share/locale/hu/LC_MESSAGES/celestia.mo
+share/locale/hu/LC_MESSAGES/celestia_constellations.mo
share/locale/it/LC_MESSAGES/celestia.mo
+share/locale/it/LC_MESSAGES/celestia_constellations.mo
+share/locale/ja/LC_MESSAGES/celestia.mo
+share/locale/ja/LC_MESSAGES/celestia_constellations.mo
+share/locale/ko/LC_MESSAGES/celestia.mo
+share/locale/ko/LC_MESSAGES/celestia_constellations.mo
+share/locale/lt/LC_MESSAGES/celestia.mo
+share/locale/lt/LC_MESSAGES/celestia_constellations.mo
+share/locale/lv/LC_MESSAGES/celestia.mo
+share/locale/lv/LC_MESSAGES/celestia_constellations.mo
share/locale/nl/LC_MESSAGES/celestia.mo
+share/locale/nl/LC_MESSAGES/celestia_constellations.mo
+share/locale/pl/LC_MESSAGES/celestia.mo
+share/locale/pl/LC_MESSAGES/celestia_constellations.mo
share/locale/pt/LC_MESSAGES/celestia.mo
-share/locale/pt_br/LC_MESSAGES/celestia.mo
+share/locale/pt/LC_MESSAGES/celestia_constellations.mo
+share/locale/pt_BR/LC_MESSAGES/celestia.mo
+share/locale/pt_BR/LC_MESSAGES/celestia_constellations.mo
+share/locale/ro/LC_MESSAGES/celestia.mo
+share/locale/ro/LC_MESSAGES/celestia_constellations.mo
share/locale/ru/LC_MESSAGES/celestia.mo
+share/locale/ru/LC_MESSAGES/celestia_constellations.mo
+share/locale/sv/LC_MESSAGES/celestia.mo
+share/locale/sv/LC_MESSAGES/celestia_constellations.mo
+share/locale/uk/LC_MESSAGES/celestia.mo
+share/locale/uk/LC_MESSAGES/celestia_constellations.mo
+share/locale/zh_CN/LC_MESSAGES/celestia.mo
+share/locale/zh_CN/LC_MESSAGES/celestia_constellations.mo
share/pixmaps/celestia.png
-@exec mkdir -p %D/share/celestia/textures/hires
@dirrm share/celestia/textures/medres
@dirrm share/celestia/textures/lores
@dirrm share/celestia/textures/hires
@dirrm share/celestia/textures
@dirrm share/celestia/splash
@dirrm share/celestia/shaders
+@dirrm share/celestia/scripts
@dirrm share/celestia/models
@dirrm share/celestia/fonts
+@dirrm share/celestia/extras-standard/mir/models
+@dirrm share/celestia/extras-standard/mir
+@dirrm share/celestia/extras-standard/iss/textures/medres
+@dirrm share/celestia/extras-standard/iss/textures
+@dirrm share/celestia/extras-standard/iss/models
+@dirrm share/celestia/extras-standard/iss
+@dirrm share/celestia/extras-standard/hubble/models
+@dirrm share/celestia/extras-standard/hubble
+@dirrm share/celestia/extras-standard/galileo/models
+@dirrm share/celestia/extras-standard/galileo
+@dirrm share/celestia/extras-standard/cassini/models
+@dirrm share/celestia/extras-standard/cassini/data
+@dirrm share/celestia/extras-standard/cassini
+@dirrm share/celestia/extras-standard
@dirrm share/celestia/extras
@dirrm share/celestia/data
@dirrm share/celestia
-@dirrmtry share/locale/pt_br/LC_MESSAGES
-@dirrmtry share/locale/pt_br