aboutsummaryrefslogtreecommitdiff
path: root/astro/cfitsio
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-08 03:03:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-08 03:03:38 +0000
commit8c80e22b4e4bcfdf78749d5154aa871bd04ab307 (patch)
treed93e97617a06866d1b761f6f7b7eb55e00edb02c /astro/cfitsio
parent7a50ada0deeb08cbc0833dfbf0d1166bc9592db3 (diff)
downloadports-8c80e22b4e4bcfdf78749d5154aa871bd04ab307.tar.gz
ports-8c80e22b4e4bcfdf78749d5154aa871bd04ab307.zip
Notes
Diffstat (limited to 'astro/cfitsio')
-rw-r--r--astro/cfitsio/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index cae05751d050..15972fbdf882 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfitsio
PORTVERSION= 3.360
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -22,8 +23,9 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= libcfitsio.a shared
CFLAGS+= -I${INCLUDEDIR}
-CONFIGURE_ARGS= ZLIB_SOURCES="" ac_cv_prog_FC=f2c
+CONFIGURE_ARGS= ac_cv_prog_FC=f2c
GNU_CONFIGURE= yes
+MAKE_ARGS= ZLIB_SOURCES="zlib/zcompress.c zlib/zuncompress.c"
LDFLAGS+= -L${LIBDIR} -lz
USE_LDCONFIG= yes
USES= pkgconfig
@@ -36,9 +38,6 @@ PORTDOCS= *
SHLIB_MAJOR_VER=2
SHLIB_MINOR_VER=${PORTVERSION:S/0$//}
-post-patch:
- @${REINPLACE_CMD} -e 's|$${ZLIB_SOURCES[:=a-z\.]*}||' ${WRKSRC}/Makefile.in
-
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
cd ${WRKSRC}/ && ${INSTALL_LIB} libcfitsio.a libcfitsio.so.${SHLIB_MAJOR_VER}.${SHLIB_MINOR_VER} ${STAGEDIR}${PREFIX}/lib/