aboutsummaryrefslogtreecommitdiff
path: root/astro/gkrellsun/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-15 14:12:03 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-15 14:12:03 +0000
commit149a7996679463769934346d5e54850dcb81cf7e (patch)
tree1fac2ef0f9fc17fbe2526a2042188dbf792697b9 /astro/gkrellsun/Makefile
parent521432de4f8a147ff5b3ca9e97d825607a42e314 (diff)
downloadports-149a7996679463769934346d5e54850dcb81cf7e.tar.gz
ports-149a7996679463769934346d5e54850dcb81cf7e.zip
Notes
Diffstat (limited to 'astro/gkrellsun/Makefile')
-rw-r--r--astro/gkrellsun/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/astro/gkrellsun/Makefile b/astro/gkrellsun/Makefile
new file mode 100644
index 000000000000..22bfec320175
--- /dev/null
+++ b/astro/gkrellsun/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gkrellsun
+# Date Created: 14.August 2002
+# Whom: Steffen Vogelreuter
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellsun
+PORTVERSION= 0.2
+CATEGORIES= astro
+MASTER_SITES= http://nwalsh.com/hacks/gkrellsun/
+
+MAINTAINER= steffen@vogelreuter.de
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gkrellsun.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+
+.include <bsd.port.mk>