aboutsummaryrefslogtreecommitdiff
path: root/astro/glunarclock/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:32:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:32:05 +0000
commit7895aa80d2534ce1c1070ec2b5879b9a4b364085 (patch)
treeb6af59b8b1a56f5738cd3f9778eab3043d8e985f /astro/glunarclock/Makefile
parent30962671e356a0cfba86a10ed2ddc8eb844adb82 (diff)
downloadports-7895aa80d2534ce1c1070ec2b5879b9a4b364085.tar.gz
ports-7895aa80d2534ce1c1070ec2b5879b9a4b364085.zip
Notes
Diffstat (limited to 'astro/glunarclock/Makefile')
-rw-r--r--astro/glunarclock/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 49c380f833f8..6115f762a40f 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= glunarclock
-PORTVERSION= 0.30.3
-PORTREVISION= 5
-CATEGORIES= astro
+PORTVERSION= 0.32.1
+CATEGORIES= astro gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,9 +15,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME applet that displays the current phase of the Moon
USE_X_PREFIX= yes
+USE_GNOME= gail gnomehack gnomepanel gnomeprefix gnometarget
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= gnomepanel gail gnomehack gnomeprefix
-USE_LIBTOOL_VER= 13
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_OMF= yes
+
+PLIST_SUB= VERSION="${PORTVERSION:R}"
+
+GCONF_SCHEMAS= glunarclock.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${prefix}/share|$${datadir}|g' ${WRKSRC}/configure
.include <bsd.port.mk>