aboutsummaryrefslogtreecommitdiff
path: root/astro/gpscorrelate
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-07 20:18:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-07 20:18:17 +0000
commited1faa1acbae4112135d7110ac0450d84b65bd40 (patch)
treebe7a5019d3ba2dc3c61524b8a27c597824b363a0 /astro/gpscorrelate
parent523e2ae6534a8dab031902a5771ae89bad47ef6a (diff)
downloadports-ed1faa1acbae4112135d7110ac0450d84b65bd40.tar.gz
ports-ed1faa1acbae4112135d7110ac0450d84b65bd40.zip
Notes
Diffstat (limited to 'astro/gpscorrelate')
-rw-r--r--astro/gpscorrelate/Makefile36
-rw-r--r--astro/gpscorrelate/distinfo3
-rw-r--r--astro/gpscorrelate/files/gpscorrelate-gui.1115
-rw-r--r--astro/gpscorrelate/files/gpscorrelate.1115
-rw-r--r--astro/gpscorrelate/files/patch-unixtime.h10
-rw-r--r--astro/gpscorrelate/pkg-descr4
-rw-r--r--astro/gpscorrelate/pkg-plist13
7 files changed, 296 insertions, 0 deletions
diff --git a/astro/gpscorrelate/Makefile b/astro/gpscorrelate/Makefile
new file mode 100644
index 000000000000..e7b182ad7e84
--- /dev/null
+++ b/astro/gpscorrelate/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gpscorrelate
+# Date created: Feb 2008
+# Whom: Lukas Maly
+#
+# $FreeBSD$
+
+PORTNAME= gpscorrelate
+PORTVERSION= 1.5.6
+CATEGORIES= astro geography
+MASTER_SITES= http://freefoote.dview.net/linux/
+
+MAINTAINER= Iam@LukasMaly.NET
+COMMENT= A gps file gpx correlate exif tag in photos
+
+LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
+ gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+
+MAN1= gpscorrelate.1 gpscorrelate-gui.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-I/usr/include|-I${LOCALBASE}/include|" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/gpscorrelate-gui ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/gpscorrelate* ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/gpscorrelate
+ ${MKDIR} ${PREFIX}/share/gpscorrelate
+ ${MKDIR} ${PREFIX}/share/doc/gpscorrelate/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/gpscorrelate/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${PREFIX}/share/doc/gpscorrelate/html
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${PREFIX}/share/gpscorrelate/
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/gpscorrelate/
+ ${INSTALL_DATA} ${WRKSRC}/RELEASES ${PREFIX}/share/gpscorrelate/
+
+.include <bsd.port.mk>
diff --git a/astro/gpscorrelate/distinfo b/astro/gpscorrelate/distinfo
new file mode 100644
index 000000000000..954ded2be6af
--- /dev/null
+++ b/astro/gpscorrelate/distinfo
@@ -0,0 +1,3 @@
+MD5 (gpscorrelate-1.5.6.tar.gz) = a76ee92d6f37c7d7d3a3c36dcd07ba62
+SHA256 (gpscorrelate-1.5.6.tar.gz) = cbd75278f8707b63c135af5ec83b4323b17313b23cdd0b29fcb1d786c50e1a2e
+SIZE (gpscorrelate-1.5.6.tar.gz) = 130623
diff --git a/astro/gpscorrelate/files/gpscorrelate-gui.1 b/astro/gpscorrelate/files/gpscorrelate-gui.1
new file mode 100644
index 000000000000..52e9b505d83e
--- /dev/null
+++ b/astro/gpscorrelate/files/gpscorrelate-gui.1
@@ -0,0 +1,115 @@
+.\" Title: GPSCORRELATE
+.\" Author: Stefano Zacchiroli
+.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
+.\" Date: 08 Sep 2006
+.\" Manual:
+.\" Source:
+.\"
+.TH "GPSCORRELATE" "1" "08 Sep 2006" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+gpscorrelate \- correlates digital photos with GPS data filling EXIF fields
+.SH "SYNOPSIS"
+.HP 13
+\fBgpscorrelate\fR [\fB\-g\ \fR\fB\fIfile.gpx\fR\fR] [\fIoption\fR...]
+.HP 17
+\fBgpscorrelate\-gui\fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBgpscorrelate\fR
+and
+\fBgpscorrelate\-gui\fR
+commands.
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original programs do not have a manual page. Instead, they have documentation in HTML format; see below.
+.PP
+\fBgpscorrelate\fR
+is a program that acts on digital photo in JPEG format filling EXIF (Exchangeable Image File Format) fields related to GPS (Global Positioning System) information. Source for the GPS data is a record of GPS information encoded in GPX (GPS Exchange Format) Format. The act of filling those fields is referred to as
+\fIcorrelation\fR.
+.PP
+If GPS data are available at the precise moment the photo was taken (with a 1\-second granularity) the GPS data are stored unmodified in EXIF fields. If they are not linear interpolation of GPS data available at moments before and after the photo was taken can be used.
+.PP
+\fBgpscorrelate\fR
+is a command line tool implementing correlation whereas
+\fBgpscorrelate\-gui\fR
+is the corresponding GTK+ graphical user interface.
+.SH "OPTIONS"
+.PP
+These programs follow the usual
+GNU
+command line syntax, with long options starting with two dashes (`\-'). A summary of options is included below. For a complete description, see the HTML documentation.
+.TP 3n
+\fB\-g\fR, \fB\-\-gps\fR
+required, specifies GPX file with GPS data
+.TP 3n
+\fB\-z\fR, \fB\-\-timeadd\fR \fB+/\-\fR\fIXX\fR[\fB:\fR\fIXX\fR]
+time to add to GPS data to make it match photos. GPS data is in UTC; photos are not likely to be in UTC. Enter the timezone used when taking the photos: eg,
+\fB+8\fR
+for Perth
+.TP 3n
+\fB\-i\fR, \fB\-\-no\-interpolation\fR
+disable interpolation between points. Interpolation is linear, points are rounded if disabled
+.TP 3n
+\fB\-v\fR, \fB\-\-verbose\fR
+show what has been selected
+.TP 3n
+\fB\-d\fR, \fB\-\-datum\fR \fIdatum\fR
+specify measurement datum. If not set, WGS\-84 used
+.TP 3n
+\fB\-n\fR, \fB\-\-no\-write\fR
+do not write the exif data. Useful with
+\fB\-\-show\fR
+.TP 3n
+\fB\-m\fR, \fB\-\-max\-dist\fR \fItime\fR
+max time outside points that photo will be matched. Time is in seconds
+.TP 3n
+\fB\-s\fR, \fB\-\-show\fR
+Just show the GPS data from the given files, if it exists
+.TP 3n
+\fB\-o\fR, \fB\-\-machine\fR
+Just show the GPS data from the given files, machine readable output
+.TP 3n
+\fB\-r\fR, \fB\-\-remove\fR
+Strip GPS tags from the given files, and then quit
+.TP 3n
+\fB\-t\fR, \fB\-\-ignore\-tracksegs\fR
+Interpolate between track segments too
+.TP 3n
+\fB\-M\fR, \fB\-\-no\-mtime\fR
+Do not change mtime of modified files
+.TP 3n
+\fB\-h\fR, \fB\-\-help\fR
+Show summary of options.
+.SH "SEE ALSO"
+.PP
+gpsd (1), gpsbabel (1), gpxlogger (1), cgpxlogger (1).
+.PP
+The documentation of gpscorrelate and gpscorrelate\-gui in HTML format are available on the filesystem at
+\fI/usr/local/share/doc/gpscorrelate/html/\fR.
+.SH "AUTHOR"
+.PP
+This manual page was written by Stefano Zacchiroli
+<zack@debian.org>
+for the
+Debian(TM)
+system (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL.
+.SH "AUTHOR"
+.PP
+\fBStefano\fR \fBZacchiroli\fR
+.sp -1n
+.IP "" 3n
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2006 Stefano Zacchiroli <zack@debian.org>
+.br
+
diff --git a/astro/gpscorrelate/files/gpscorrelate.1 b/astro/gpscorrelate/files/gpscorrelate.1
new file mode 100644
index 000000000000..52e9b505d83e
--- /dev/null
+++ b/astro/gpscorrelate/files/gpscorrelate.1
@@ -0,0 +1,115 @@
+.\" Title: GPSCORRELATE
+.\" Author: Stefano Zacchiroli
+.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
+.\" Date: 08 Sep 2006
+.\" Manual:
+.\" Source:
+.\"
+.TH "GPSCORRELATE" "1" "08 Sep 2006" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+gpscorrelate \- correlates digital photos with GPS data filling EXIF fields
+.SH "SYNOPSIS"
+.HP 13
+\fBgpscorrelate\fR [\fB\-g\ \fR\fB\fIfile.gpx\fR\fR] [\fIoption\fR...]
+.HP 17
+\fBgpscorrelate\-gui\fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBgpscorrelate\fR
+and
+\fBgpscorrelate\-gui\fR
+commands.
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original programs do not have a manual page. Instead, they have documentation in HTML format; see below.
+.PP
+\fBgpscorrelate\fR
+is a program that acts on digital photo in JPEG format filling EXIF (Exchangeable Image File Format) fields related to GPS (Global Positioning System) information. Source for the GPS data is a record of GPS information encoded in GPX (GPS Exchange Format) Format. The act of filling those fields is referred to as
+\fIcorrelation\fR.
+.PP
+If GPS data are available at the precise moment the photo was taken (with a 1\-second granularity) the GPS data are stored unmodified in EXIF fields. If they are not linear interpolation of GPS data available at moments before and after the photo was taken can be used.
+.PP
+\fBgpscorrelate\fR
+is a command line tool implementing correlation whereas
+\fBgpscorrelate\-gui\fR
+is the corresponding GTK+ graphical user interface.
+.SH "OPTIONS"
+.PP
+These programs follow the usual
+GNU
+command line syntax, with long options starting with two dashes (`\-'). A summary of options is included below. For a complete description, see the HTML documentation.
+.TP 3n
+\fB\-g\fR, \fB\-\-gps\fR
+required, specifies GPX file with GPS data
+.TP 3n
+\fB\-z\fR, \fB\-\-timeadd\fR \fB+/\-\fR\fIXX\fR[\fB:\fR\fIXX\fR]
+time to add to GPS data to make it match photos. GPS data is in UTC; photos are not likely to be in UTC. Enter the timezone used when taking the photos: eg,
+\fB+8\fR
+for Perth
+.TP 3n
+\fB\-i\fR, \fB\-\-no\-interpolation\fR
+disable interpolation between points. Interpolation is linear, points are rounded if disabled
+.TP 3n
+\fB\-v\fR, \fB\-\-verbose\fR
+show what has been selected
+.TP 3n
+\fB\-d\fR, \fB\-\-datum\fR \fIdatum\fR
+specify measurement datum. If not set, WGS\-84 used
+.TP 3n
+\fB\-n\fR, \fB\-\-no\-write\fR
+do not write the exif data. Useful with
+\fB\-\-show\fR
+.TP 3n
+\fB\-m\fR, \fB\-\-max\-dist\fR \fItime\fR
+max time outside points that photo will be matched. Time is in seconds
+.TP 3n
+\fB\-s\fR, \fB\-\-show\fR
+Just show the GPS data from the given files, if it exists
+.TP 3n
+\fB\-o\fR, \fB\-\-machine\fR
+Just show the GPS data from the given files, machine readable output
+.TP 3n
+\fB\-r\fR, \fB\-\-remove\fR
+Strip GPS tags from the given files, and then quit
+.TP 3n
+\fB\-t\fR, \fB\-\-ignore\-tracksegs\fR
+Interpolate between track segments too
+.TP 3n
+\fB\-M\fR, \fB\-\-no\-mtime\fR
+Do not change mtime of modified files
+.TP 3n
+\fB\-h\fR, \fB\-\-help\fR
+Show summary of options.
+.SH "SEE ALSO"
+.PP
+gpsd (1), gpsbabel (1), gpxlogger (1), cgpxlogger (1).
+.PP
+The documentation of gpscorrelate and gpscorrelate\-gui in HTML format are available on the filesystem at
+\fI/usr/local/share/doc/gpscorrelate/html/\fR.
+.SH "AUTHOR"
+.PP
+This manual page was written by Stefano Zacchiroli
+<zack@debian.org>
+for the
+Debian(TM)
+system (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL.
+.SH "AUTHOR"
+.PP
+\fBStefano\fR \fBZacchiroli\fR
+.sp -1n
+.IP "" 3n
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2006 Stefano Zacchiroli <zack@debian.org>
+.br
+
diff --git a/astro/gpscorrelate/files/patch-unixtime.h b/astro/gpscorrelate/files/patch-unixtime.h
new file mode 100644
index 000000000000..6e7267c97724
--- /dev/null
+++ b/astro/gpscorrelate/files/patch-unixtime.h
@@ -0,0 +1,10 @@
+--- unixtime.h.orig 2008-02-18 12:50:16.000000000 +0100
++++ unixtime.h 2008-02-18 12:50:41.000000000 +0100
+@@ -27,6 +27,7 @@
+
+ #define EXIF_DATE_FORMAT "%d:%d:%d %d:%d:%d"
+ #define GPX_DATE_FORMAT "%d-%d-%dT%d:%d:%dZ"
++#include <sys/types.h>
+
+ time_t ConvertToUnixTime(char* StringTime, char* Format,
+ int TZOffsetHours, int TZOffsetMinutes);
diff --git a/astro/gpscorrelate/pkg-descr b/astro/gpscorrelate/pkg-descr
new file mode 100644
index 000000000000..1549875fe9ce
--- /dev/null
+++ b/astro/gpscorrelate/pkg-descr
@@ -0,0 +1,4 @@
+A tool to "stamp" photos taken with digital camera with a location, where they
+were taken. It uses the GPS coordinates saved in GPX format.
+
+WWW: http://freefoote.dview.net/linux_gpscorr.html
diff --git a/astro/gpscorrelate/pkg-plist b/astro/gpscorrelate/pkg-plist
new file mode 100644
index 000000000000..1b9c7fef3521
--- /dev/null
+++ b/astro/gpscorrelate/pkg-plist
@@ -0,0 +1,13 @@
+bin/gpscorrelate
+bin/gpscorrelate-gui
+share/gpscorrelate/README
+share/gpscorrelate/RELEASES
+share/gpscorrelate/command-line-options.txt
+share/doc/gpscorrelate/html/command.html
+share/doc/gpscorrelate/html/concepts.html
+share/doc/gpscorrelate/html/corr.png
+share/doc/gpscorrelate/html/gui.html
+share/doc/gpscorrelate/html/index.html
+@dirrm share/doc/gpscorrelate/html
+@dirrm share/doc/gpscorrelate
+@dirrm share/gpscorrelate