aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsd/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-20 16:41:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-20 16:41:06 +0000
commitff777799b6fe04f5c9ec60f535210fd1528e889f (patch)
treeb0b07458d584f1bc0e438c4227c02ee9138c0a20 /astro/gpsd/Makefile
parent88e7ff1c094b53e048583a096c2ec0b10a681437 (diff)
downloadports-ff777799b6fe04f5c9ec60f535210fd1528e889f.tar.gz
ports-ff777799b6fe04f5c9ec60f535210fd1528e889f.zip
Notes
Diffstat (limited to 'astro/gpsd/Makefile')
-rw-r--r--astro/gpsd/Makefile30
1 files changed, 8 insertions, 22 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index a9aab4af1354..da3e0b3c2c35 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -12,25 +12,13 @@ COMMENT= Daemon that monitors one or more GPSes attached to a host computer
BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
xsltproc:${PORTSDIR}/textproc/libxslt
-NO_STAGE= yes
-USES= pathfix pkgconfig
-USE_SCONS= yes
+USES= pathfix pkgconfig scons
USE_RC_SUBR= gpsd
USE_PYTHON= yes
-INSTALLS_EGGINFO= yes
-PYDISTUTILS_EGGINFO= gps-${PORTVERSION}.egg-info
-SCONS_BUILDENV= CC=${CC}
-SCONS_ARGS= prefix="${PREFIX}" mandir="man" pkgconfig="libdata/pkgconfig" \
+MAKE_ARGS= prefix="${PREFIX}" mandir="man" pkgconfig="libdata/pkgconfig" \
chrpath=no
-
-MAN1= cgps.1 gegps.1 gps.1 gpscat.1 gpsctl.1 gpsdecode.1 \
- gpsfake.1 gpspipe.1 gpsprof.1 xgps.1 xgpsspeed.1 \
- gpsmon.1 lcdgps.1
-MAN3= libgps.3 libgpsd.3 libgpsmm.3 libQgpsmm.3
-MAN5= srec.5 gpsd_json.5
-MAN8= gpsd.8 gpsdctl.8 gpsinit.8
-MANCOMPRESSED= no
+MAKE_ENV= DESTDIR="${STAGEDIR}"
OPTIONS_DEFINE= AIVDM ASHTECH CPPBIND DBUS EARTHMATE EVERMORE FV18 GARMIN GARMINTXT \
GEOSTAR GPSCLOCK GTK2 IPV6 ITRAX MTK NAVCOM NETFEED NMEA NTPSHM NTRIP \
@@ -262,12 +250,10 @@ SCONS_ARGS+= profiling=yes
# if that's not done, ${PYTHON_SITELIBDIR}/gps will be polluted
# with these files when module is imported from root user
post-install:
- @${FIND} ${PYTHON_SITELIBDIR:C/^${LOCALBASE}/${PREFIX}/}/gps \
- -name "*.py" -exec \
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py {} \;
- @${SETENV} PYTHONOPTIMIZE=yes \
- ${FIND} ${PYTHON_SITELIBDIR:C/^${LOCALBASE}/${PREFIX}/}/gps \
- -name "*.py" -exec \
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py {} \;
+ (cd ${STAGEDIR}${PREFIX} && \
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;} && \
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
.include <bsd.port.mk>