aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-04-27 15:00:49 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-04-27 15:00:49 +0000
commita83ffa13e8621fb2a4a0f9c6ab7794e41b91ff13 (patch)
tree9f283f730c7e06b4de9d96674176f1a220f6c395 /astro/gpsdrive/Makefile
parentb027a476cf144641ae72e64f69de70a7f74e8a5a (diff)
downloadports-a83ffa13e8621fb2a4a0f9c6ab7794e41b91ff13.tar.gz
ports-a83ffa13e8621fb2a4a0f9c6ab7794e41b91ff13.zip
Notes
Diffstat (limited to 'astro/gpsdrive/Makefile')
-rw-r--r--astro/gpsdrive/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 66be3574d898..757143a9ce94 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -20,21 +20,34 @@ COMMENT= A GPS navigation system
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GETOPT_LONG=yes
-USE_GETTEXT= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_INC_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 15
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-garmin
INSTALLS_SHLIB= yes
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
MAN1= gpsdrive.1
MANLANG= "" de es
+post-patch:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} 's|SUBDIRS = src po man|SUBDIRS = src man|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}