aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-09-07 10:38:47 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-09-07 10:38:47 +0000
commitf8df20da12606a90d2bf75caa74c1c6a26508ade (patch)
tree2bac2b1d0149bbd56dede68ea51bfc888daf9d79 /astro/gpsdrive
parent66eb802bc38e1af460018e9fdf08ec3b7ecfcb07 (diff)
downloadports-f8df20da12606a90d2bf75caa74c1c6a26508ade.tar.gz
ports-f8df20da12606a90d2bf75caa74c1c6a26508ade.zip
Notes
Diffstat (limited to 'astro/gpsdrive')
-rw-r--r--astro/gpsdrive/Makefile1
-rw-r--r--astro/gpsdrive/files/patch-src::gpsserial.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 886f6c3148f5..b8a385d2aee9 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpsdrive
PORTVERSION= 2.09
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://www.gpsdrive.cc/ \
http://www.gpsdrive.oc512.us/ \
diff --git a/astro/gpsdrive/files/patch-src::gpsserial.c b/astro/gpsdrive/files/patch-src::gpsserial.c
new file mode 100644
index 000000000000..b6dc660603d8
--- /dev/null
+++ b/astro/gpsdrive/files/patch-src::gpsserial.c
@@ -0,0 +1,13 @@
+--- src/gpsserial.c.orig Thu Feb 12 18:42:53 2004
++++ src/gpsserial.c Mon Sep 6 00:44:34 2004
+@@ -178,7 +178,9 @@
+ CLOCAL : local connection, no modem contol
+ CREAD : enable receiving characters
+ */
+- newtio.c_cflag = (11 + serialspeed) | CS8 | CLOCAL | CREAD;
++ int t[] = { 2400, 4800, 9600, 19200, 38400 };
++ newtio.c_ispeed = newtio.c_ospeed = t[serialspeed];
++ newtio.c_cflag = CS8 | CLOCAL | CREAD;
+ newtio.c_cflag &= ~(PARENB | CRTSCTS);
+ /*
+ IGNPAR : ignore bytes with parity errors