aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsman/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-26 08:32:31 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-26 08:32:31 +0000
commit1b2fa9b423028ce641eddf788e3c093d829f41b4 (patch)
tree360d67f7d93bc4e584280ee8c6235d746585e2dc /astro/gpsman/Makefile
parent8af12956e5b514a6a4732f83e91e421cf1b88082 (diff)
Notes
Diffstat (limited to 'astro/gpsman/Makefile')
-rw-r--r--astro/gpsman/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index 62b4ad0f67ae..7ab1ce0dfea0 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gpsman
-PORTVERSION= 6.3
+PORTVERSION= 6.3.1
CATEGORIES= astro tk84
MASTER_SITES= http://www.ncc.up.pt/gpsman/gpsmanhtml/
MASTER_SITE_SUBDIR= science/cartography
@@ -15,7 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= david@catwhisker.org
COMMENT= A Tcl/Tk-based GPS management utility
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+#RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+USE_TK= 84
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
@@ -23,6 +24,14 @@ NO_BUILD= yes
# MAN1= gpsman.1
# MANCOMPRESSED= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+GPSMAN_DEFAULT_PORT?= /dev/cuaa0
+.else
+GPSMAN_DEFAULT_PORT?= /dev/cuad0
+.endif
+
post-patch:
@(cd ${WRKSRC} && ${REINPLACE_CMD} "s|/dev/ttyS0|${GPSMAN_DEFAULT_PORT}|" \
util/exerciser.tcl manual/html/info/l_realtime.doc.txt gpsman.tcl)
@@ -58,10 +67,4 @@ do-install:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" pkg-message
.endif
-.include <bsd.port.mk>
-
-.if ${OSVERSION} < 600000
-GPSMAN_DEFAULT_PORT?= /dev/cuaa0
-.else
-GPSMAN_DEFAULT_PORT?= /dev/cuad0
-.endif
+.include <bsd.port.post.mk>