aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsman/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-05-11 16:45:18 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-05-11 16:45:18 +0000
commit8715466ba5a397ae565f3bd2e7f59323a5196325 (patch)
tree0e9c98a7a532b9b7c40c2d8a3467fe2994aa1fad /astro/gpsman/Makefile
parentb755f5de7ba8cea729d65893fe05f6e084a3c33f (diff)
Notes
Diffstat (limited to 'astro/gpsman/Makefile')
-rw-r--r--astro/gpsman/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index e23d11ebbc21..62b4ad0f67ae 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gpsman
-PORTVERSION= 6.2.1
+PORTVERSION= 6.3
CATEGORIES= astro tk84
MASTER_SITES= http://www.ncc.up.pt/gpsman/gpsmanhtml/
MASTER_SITE_SUBDIR= science/cartography
@@ -23,6 +23,10 @@ NO_BUILD= yes
# MAN1= gpsman.1
# MANCOMPRESSED= yes
+post-patch:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} "s|/dev/ttyS0|${GPSMAN_DEFAULT_PORT}|" \
+ util/exerciser.tcl manual/html/info/l_realtime.doc.txt gpsman.tcl)
+
pre-install:
@${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/gpsman.tcl
@@ -55,3 +59,9 @@ do-install:
.endif
.include <bsd.port.mk>
+
+.if ${OSVERSION} < 600000
+GPSMAN_DEFAULT_PORT?= /dev/cuaa0
+.else
+GPSMAN_DEFAULT_PORT?= /dev/cuad0
+.endif