aboutsummaryrefslogtreecommitdiff
path: root/astro/libkgeomap/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-08 17:21:34 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-08 17:21:34 +0000
commit95ac09da88b347276c0794d7add352149d7f5bd3 (patch)
tree2a95349f8ea007815ae206fc5ae456e437027034 /astro/libkgeomap/Makefile
parentf88b0bf40887fddb7bf22bdcaf23ab537cbd82a6 (diff)
downloadports-95ac09da88b347276c0794d7add352149d7f5bd3.tar.gz
ports-95ac09da88b347276c0794d7add352149d7f5bd3.zip
Notes
Diffstat (limited to 'astro/libkgeomap/Makefile')
-rw-r--r--astro/libkgeomap/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/astro/libkgeomap/Makefile b/astro/libkgeomap/Makefile
new file mode 100644
index 000000000000..a90127857084
--- /dev/null
+++ b/astro/libkgeomap/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= libkgeomap
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= astro kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE library for browsing photos on a map
+
+LICENSE= GPLv2+ LGPL20+
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs
+LIB_DEPENDS= libopencv_legacy.so:graphics/opencv
+
+USES= cmake:outsource gettext kde:5 pkgconfig tar:xz
+USE_KDE= config coreaddons ecm i18n kio marble service textwidgets
+USE_QT5= concurrent core gui network webkit widgets xml \
+ buildtools_build qmake_build
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>