aboutsummaryrefslogtreecommitdiff
path: root/astro/libroadnav
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-11 01:34:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-11 01:34:03 +0000
commit2e48ccd270c7d7e513f373b26c1064f5af424537 (patch)
treec8dd49b34cbeeca3e1200d308f4d9618570052c1 /astro/libroadnav
parent12a874c6447da931922ce5fa560e4269ad4c1617 (diff)
Notes
Diffstat (limited to 'astro/libroadnav')
-rw-r--r--astro/libroadnav/Makefile34
-rw-r--r--astro/libroadnav/distinfo3
-rw-r--r--astro/libroadnav/files/patch-src-Makefile.in11
-rw-r--r--astro/libroadnav/pkg-descr13
-rw-r--r--astro/libroadnav/pkg-plist50
5 files changed, 111 insertions, 0 deletions
diff --git a/astro/libroadnav/Makefile b/astro/libroadnav/Makefile
new file mode 100644
index 000000000000..011026ca12f5
--- /dev/null
+++ b/astro/libroadnav/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: roadnav
+# Date created: 28 July 2008
+# Whom: stevef
+#
+# $FreeBSD$
+#
+
+PORTNAME= libroadnav
+PORTVERSION= 0.19
+CATEGORIES= astro geography
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=roadnav
+
+MAINTAINER= stevefranks@ieee.org
+COMMENT= Helper library for Roadnav: A 3D GPS Mapping program
+
+USE_WX= 2.6+
+WX_COMPS= wx contrib
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= *
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libroadnavdocDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/libroadnav/distinfo b/astro/libroadnav/distinfo
new file mode 100644
index 000000000000..c9c897e93d3b
--- /dev/null
+++ b/astro/libroadnav/distinfo
@@ -0,0 +1,3 @@
+MD5 (libroadnav-0.19.tar.gz) = 02d90e3fa415955432538c4294e7debe
+SHA256 (libroadnav-0.19.tar.gz) = 3aa4c1d951f8149ee0df3a67eb709fce5c379a9ffe8acc7141f87b4841baea0f
+SIZE (libroadnav-0.19.tar.gz) = 835616
diff --git a/astro/libroadnav/files/patch-src-Makefile.in b/astro/libroadnav/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..da748ec93792
--- /dev/null
+++ b/astro/libroadnav/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2007-10-09 05:44:26.000000000 +0400
++++ src/Makefile.in 2008-08-02 23:28:08.000000000 +0400
+@@ -354,8 +354,6 @@
+ @list='$(lib_LIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ p=$(am__strip_dir) \
+- echo " $(RANLIB) '$(DESTDIR)$(libdir)/$$p'"; \
+- $(RANLIB) "$(DESTDIR)$(libdir)/$$p"; \
+ else :; fi; \
+ done
+
diff --git a/astro/libroadnav/pkg-descr b/astro/libroadnav/pkg-descr
new file mode 100644
index 000000000000..71155ea3a406
--- /dev/null
+++ b/astro/libroadnav/pkg-descr
@@ -0,0 +1,13 @@
+Roadnav is an open source street navigation solution capable of running on a
+variety of operating systems. It can obtain your position from a GPS unit,
+plot a map of your area, and provide directions to locations in the USA. It
+can also verbalize directions using Microsoft SAPI 5.1, Festival, flite, and
+OS X's built in text to speech engine.
+
+Roadnav uses the free TIGER/Line (Topologically Integrated Geographic
+Encoding and Referencing) files from the US Census Bureau to build the maps,
+along with the GNIS state and topical gazetteer data from the USGS to identify
+locations. It has experimental support for scripting, LCDproc, importing
+OpenStreetMap data, and importing GPX waypoints and tracks.
+
+WWW: http://roadnav.sourceforge.net/
diff --git a/astro/libroadnav/pkg-plist b/astro/libroadnav/pkg-plist
new file mode 100644
index 000000000000..423f1cce81bd
--- /dev/null
+++ b/astro/libroadnav/pkg-plist
@@ -0,0 +1,50 @@
+include/libroadnav/Address.h
+include/libroadnav/Angle.h
+include/libroadnav/AutoComplete.h
+include/libroadnav/Constants.h
+include/libroadnav/Debug.h
+include/libroadnav/DetailSettings.h
+include/libroadnav/Direction.h
+include/libroadnav/DownloadFiles.h
+include/libroadnav/DownloadThread.h
+include/libroadnav/Map.h
+include/libroadnav/MapAbbreviations.h
+include/libroadnav/MapAppearanceSettings.h
+include/libroadnav/MapControl.h
+include/libroadnav/MapControlData.h
+include/libroadnav/MapControlDataEntry.h
+include/libroadnav/MapControlDataEntry_Std.h
+include/libroadnav/MapControlDataImporter.h
+include/libroadnav/MapControlDataImporter_CountyBoundaries.h
+include/libroadnav/MapControlDataImporter_GNIS.h
+include/libroadnav/MapControlDataImporter_GNISDECI.h
+include/libroadnav/MapControlDataImporter_GPX.h
+include/libroadnav/MapControlDataImporter_OSM.h
+include/libroadnav/MapControlDataImporter_StateBoundaries.h
+include/libroadnav/MapControlDataImporter_TigerLine.h
+include/libroadnav/MapControlData_Foundation.h
+include/libroadnav/MapControlData_Tiles.h
+include/libroadnav/MapCounty.h
+include/libroadnav/MapDrawing.h
+include/libroadnav/MapLookup.h
+include/libroadnav/MapMarker.h
+include/libroadnav/MapPolygon.h
+include/libroadnav/MapRepresentations.h
+include/libroadnav/MapState.h
+include/libroadnav/MapSupport.h
+include/libroadnav/MapTrack.h
+include/libroadnav/MapZip.h
+include/libroadnav/Point.h
+include/libroadnav/ProgressDialog.h
+include/libroadnav/Serialization.h
+include/libroadnav/StringTable.h
+include/libroadnav/Terraserver.h
+include/libroadnav/URLs.h
+include/libroadnav/UTM.h
+include/libroadnav/UniqueID.h
+include/libroadnav/UniqueIDGenerator.h
+include/libroadnav/UnitConversion.h
+include/libroadnav/Zip.h
+include/libroadnav/wxAntiAliasedDC.h
+lib/libroadnav.a
+@dirrm include/libroadnav