aboutsummaryrefslogtreecommitdiff
path: root/astro/marble
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-05 17:44:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-05 17:44:17 +0000
commitfd6c454324feec491cb56aebc321d03207858f48 (patch)
tree51203a4767159a514e3f6e7169e79dc70a6ed37a /astro/marble
parentc35dd7a24bbd692ff0fbde406b924f1904986cc4 (diff)
downloadports-fd6c454324feec491cb56aebc321d03207858f48.tar.gz
ports-fd6c454324feec491cb56aebc321d03207858f48.zip
Notes
Diffstat (limited to 'astro/marble')
-rw-r--r--astro/marble/files/patch-marble__Findlibgps.cmake27
-rw-r--r--astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt16
-rw-r--r--astro/marble/files/patch-marble__src__plugins__positionprovider__gpsd__CMakeLists.txt19
3 files changed, 0 insertions, 62 deletions
diff --git a/astro/marble/files/patch-marble__Findlibgps.cmake b/astro/marble/files/patch-marble__Findlibgps.cmake
deleted file mode 100644
index e66bc87e03f0..000000000000
--- a/astro/marble/files/patch-marble__Findlibgps.cmake
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./marble/Findlibgps.cmake.orig 2009-05-06 14:13:59.000000000 +0400
-+++ ./marble/Findlibgps.cmake 2010-03-14 00:08:03.860024388 +0300
-@@ -1,10 +1,16 @@
--# - Find Gpsd libs - gps daemon library
--#
--# This module finds if Gpsd is installed.
--#
--# Copyright (c) 2006, Andrew Manson, <g.real.ate@gmail.com>
--#
-+# LIBGPS_FOUND - system has the LIBGPS library
-+# LIBGPS_INCLUDE_DIR - the LIBGPS include directory
-+# LIBGPS_LIBRARIES - The libraries needed to use LIBGPS
-
--include(FindPkgConfig)
-+if(LIBGPS_INCLUDE_DIR AND LIBGPS_LIBRARIES)
-+ set(LIBGPS_FOUND TRUE)
-+else(LIBGPS_INCLUDE_DIR AND LIBGPS_LIBRARIES)
-
--pkg_check_modules(libgps libgps>=2.35)
-+ find_path(LIBGPS_INCLUDE_DIR NAMES gps.h)
-+ find_library(LIBGPS_LIBRARIES NAMES gps)
-+
-+ include(FindPackageHandleStandardArgs)
-+ find_package_handle_standard_args(libgps DEFAULT_MSG LIBGPS_INCLUDE_DIR LIBGPS_LIBRARIES)
-+
-+ mark_as_advanced(LIBGPS_INCLUDE_DIR LIBGPS_LIBRARIES)
-+endif(LIBGPS_INCLUDE_DIR AND LIBGPS_LIBRARIES)
diff --git a/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt b/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt
deleted file mode 100644
index 05847c758ce4..000000000000
--- a/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./marble/src/plugins/positionprovider/CMakeLists.txt.orig 2010-06-08 14:10:42.000000000 +0400
-+++ ./marble/src/plugins/positionprovider/CMakeLists.txt 2010-06-29 22:11:59.372315881 +0400
-@@ -1,10 +1,10 @@
- find_package(libgps)
--if(libgps_FOUND)
-+if(LIBGPS_FOUND)
- message( STATUS "Building with gpsd position provider")
- add_subdirectory( gpsd )
--else(libgps_FOUND)
-+else(LIBGPS_FOUND)
- message( STATUS "Not building with gpsd position provider")
--endif(libgps_FOUND)
-+endif(LIBGPS_FOUND)
-
- find_package(liblocation)
- if(liblocation_FOUND)
diff --git a/astro/marble/files/patch-marble__src__plugins__positionprovider__gpsd__CMakeLists.txt b/astro/marble/files/patch-marble__src__plugins__positionprovider__gpsd__CMakeLists.txt
deleted file mode 100644
index dfce3fe9e317..000000000000
--- a/astro/marble/files/patch-marble__src__plugins__positionprovider__gpsd__CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./marble/src/plugins/positionprovider/gpsd/CMakeLists.txt.orig 2009-05-27 23:53:49.000000000 +0400
-+++ ./marble/src/plugins/positionprovider/gpsd/CMakeLists.txt 2010-03-14 00:08:03.862036116 +0300
-@@ -4,7 +4,7 @@
- ${CMAKE_CURRENT_SOURCE_DIR}/src/plugins/positionprovider/gpsd
- ${CMAKE_BINARY_DIR}/src/plugins/positionprovider/gpsd
- ${QT_INCLUDE_DIR}
-- ${libgps_INCLUDE_DIRS}
-+ ${LIBGPS_INCLUDE_DIR}
- )
-
- include(${QT_USE_FILE})
-@@ -15,6 +15,6 @@
- GpsdThread.cpp
- )
-
--set( GpsdPositionProviderPlugin_LIBS ${libgps_LIBRARIES} )
-+set( GpsdPositionProviderPlugin_LIBS ${LIBGPS_LIBRARIES} )
-
- marble_add_plugin( GpsdPositionProviderPlugin ${gpsd_SRCS} )