aboutsummaryrefslogtreecommitdiff
path: root/astro/nightfall
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-12 08:03:14 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-12 08:03:14 +0000
commitfe42c0ccc97b988d2ccc3911f2390faf1db7199c (patch)
tree1fe11396f8ec24c38ae8bb1b83aaf60677f3d389 /astro/nightfall
parentec0b57ecc207f3e9e690a03a61ef283353a9bc1a (diff)
downloadports-fe42c0ccc97b988d2ccc3911f2390faf1db7199c.tar.gz
ports-fe42c0ccc97b988d2ccc3911f2390faf1db7199c.zip
- Fix build with clang34 (unrecognized option -fforce-addr)
- Use options helpers and subs - Set correct plist subs for GNOME option
Notes
Notes: svn path=/head/; revision=351076
Diffstat (limited to 'astro/nightfall')
-rw-r--r--astro/nightfall/Makefile55
-rw-r--r--astro/nightfall/pkg-plist16
2 files changed, 35 insertions, 36 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index f5a88e812973..09ee64dc954c 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -10,48 +10,47 @@ MASTER_SITES= http://www.la-samhna.de/nightfall/
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive binary star application
-OPTIONS_DEFINE= GNOME PGPLOT OPENGL
-OPTIONS_DEFAULT= PGPLOT OPENGL
-PGPLOT_DESC= Enable PGPLOT support
-
-USES= gmake pathfix gettext perl5
+USES= compiler gettext gmake pathfix perl5 pkgconfig
USE_GNOME= gnomehier gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= GNOME PGPLOT OPENGL
+OPTIONS_DEFAULT= PGPLOT OPENGL
+OPTIONS_SUB= yes
+
+GNOME_CONFIGURE_ON= --with-gnomedoc-prefix=${PREFIX}/share
+GNOME_CONFIGURE_OFF= --disable-gnome
+GNOME_USE= GNOME=gnomeprefix,libgnomeui
+
+OPENGL_CONFIGURE_ON= --with-lib-GL
+OPENGL_CONFIGURE_OFF= --disable-opengl
+OPENGL_LIB_DEPENDS= libgtkgl-2.0.so:${PORTSDIR}/x11-toolkits/gtkglarea2
+OPENGL_USE= GL=glut
+
+PGPLOT_DESC= PGPLOT support
+PGPLOT_CONFIGURE_ON= --with-pgplot-include=${LOCALBASE}/include \
+ --with-pgplot-lib=${LOCALBASE}/lib
+PGPLOT_CONFIGURE_OFF= --with-gnuplot
+PGPLOT_LIB_DEPENDS= libpgplot.so:${PORTSDIR}/graphics/pgplot
+PGPLOT_USES= fortran
+
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGNOMEUI}
-USE_GNOME+= gnomeprefix libgnomeui
-CONFIGURE_ARGS+= --with-gnomedoc-prefix=${PREFIX}/share
INSTALLS_OMF= yes
-PLIST_SUB+= GNOMEUI=""
-.else
-CONFIGURE_ARGS+= --disable-gnome
-PLIST_SUB+= GNOMEUI="@comment "
.endif
-.if ${PORT_OPTIONS:MPGPLOT}
-LIB_DEPENDS+= libpgplot.so:${PORTSDIR}/graphics/pgplot
-USES+= fortran
-CONFIGURE_ARGS+= --with-pgplot-include=${LOCALBASE}/include \
- --with-pgplot-lib=${LOCALBASE}/lib
-.else
+.if ! ${PORT_OPTIONS:MPGPLOT}
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
-CONFIGURE_ARGS+= --with-gnuplot
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
-LIB_DEPENDS+= libgtkgl-2.0.so:${PORTSDIR}/x11-toolkits/gtkglarea2
-USE_GL= glut
-CONFIGURE_ARGS+= --with-lib-GL
-.else
-CONFIGURE_ARGS+= --disable-opengl
.endif
post-patch:
+.if ${COMPILER_TYPE} == clang
+ @${REINPLACE_CMD} -e 's|-fforce-addr||' ${WRKSRC}/configure
+.endif
@${REINPLACE_CMD} -e 's|CFLAGS -O3|CFLAGS|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^Icon=gnome|Icon=${DATADIR}/pixmaps|g' \
${WRKSRC}/nightfall.desktop
@@ -60,4 +59,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/nightfall.desktop \
${STAGEDIR}${PREFIX}/share/applications
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/astro/nightfall/pkg-plist b/astro/nightfall/pkg-plist
index 8019e721a9e7..6654bbe42802 100644
--- a/astro/nightfall/pkg-plist
+++ b/astro/nightfall/pkg-plist
@@ -1,8 +1,8 @@
bin/nightfall
man/man1/nightfall.1.gz
share/applications/nightfall.desktop
-%%GNOMEUI%%share/gnome/help/nightfall/C/nightfall.xml
-%%GNOMEUI%%share/gnome/help/nightfall/de/nightfall.xml
+%%GNOME%%share/gnome/help/nightfall/C/nightfall.xml
+%%GNOME%%share/gnome/help/nightfall/de/nightfall.xml
share/locale/de/LC_MESSAGES/nightfall.mo
share/locale/it/LC_MESSAGES/nightfall.mo
%%DATADIR%%/cfg/51_peg.cfg
@@ -90,9 +90,9 @@ share/locale/it/LC_MESSAGES/nightfall.mo
%%DATADIR%%/pixmaps/starp_256.jpg
%%DATADIR%%/pixmaps/stars_128.jpg
%%DATADIR%%/pixmaps/stars_256.jpg
-%%GNOMEUI%%share/omf/nightfall/nightfall-C.omf
-%%GNOMEUI%%share/omf/nightfall/nightfall-de.omf
-%%GNOMEUI%%@dirrm share/omf/nightfall
+%%GNOME%%share/omf/nightfall/nightfall-C.omf
+%%GNOME%%share/omf/nightfall/nightfall-de.omf
+%%GNOME%%@dirrm share/omf/nightfall
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/doc/de/edu
@dirrm %%DATADIR%%/doc/de
@@ -102,6 +102,6 @@ share/locale/it/LC_MESSAGES/nightfall.mo
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%/cfg
@dirrm %%DATADIR%%
-%%GNOMEUI%%@dirrm share/gnome/help/nightfall/de
-%%GNOMEUI%%@dirrm share/gnome/help/nightfall/C
-%%GNOMEUI%%@dirrm share/gnome/help/nightfall
+%%GNOME%%@dirrm share/gnome/help/nightfall/de
+%%GNOME%%@dirrm share/gnome/help/nightfall/C
+%%GNOME%%@dirrm share/gnome/help/nightfall