aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-Catalog/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 07:18:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 07:18:23 +0000
commita94279b1a014968dcc42bf1336319dc36056a245 (patch)
treee8c80904ed921028ba37fd97d32402bb48922fdf /astro/p5-Astro-Catalog/Makefile
parent7cdbec9cd65a97cbea0e0d719f920cf93341b206 (diff)
downloadports-a94279b1a014968dcc42bf1336319dc36056a245.tar.gz
ports-a94279b1a014968dcc42bf1336319dc36056a245.zip
Notes
Diffstat (limited to 'astro/p5-Astro-Catalog/Makefile')
-rw-r--r--astro/p5-Astro-Catalog/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
new file mode 100644
index 000000000000..d9af90790d87
--- /dev/null
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: Astro-Catalog
+# Date created: Oct 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-Catalog
+PORTVERSION= 1.8.1
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.astro.ex.ac.uk/estar/software/
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Astro::Catalog.3 \
+ Astro::Catalog::GSC::Query.3 \
+ Astro::Catalog::Star.3 \
+ Astro::Catalog::USNOA2::Query.3
+
+.include <bsd.port.mk>