aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-FITS-CFITSIO/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-01-06 00:36:56 +0000
committerWen Heping <wen@FreeBSD.org>2011-01-06 00:36:56 +0000
commit821a876f05c6b0bb9c87565625afa13843d52108 (patch)
treea8bb3a9529dce7c203b6d37c05e95391f658b9b2 /astro/p5-Astro-FITS-CFITSIO/Makefile
parent5d5fd5bc3acc39a9f17bafac679081d81064b4ea (diff)
Notes
Diffstat (limited to 'astro/p5-Astro-FITS-CFITSIO/Makefile')
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
new file mode 100644
index 000000000000..d145a6463251
--- /dev/null
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: Astro-FITS-CFITSIO
+# Date created: Jan 6, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-FITS-CFITSIO
+PORTVERSION= 1.05
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl extension for using the cfitsio library
+
+LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio
+
+PERL_CONFIGURE= yes
+
+MAN3= Astro::FITS::CFITSIO.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>