aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Geo-METAR
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-01-04 14:02:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-01-04 14:02:25 +0000
commit231a7291ae061427a367cb400805ce9f3e49d9e7 (patch)
treed1b12fefd9a2c3d1c5139d6d163f74cfd8e0a88c /astro/p5-Geo-METAR
parentc4a730df0d82db2aecb7932bc84c2730496b222a (diff)
downloadports-231a7291ae061427a367cb400805ce9f3e49d9e7.tar.gz
ports-231a7291ae061427a367cb400805ce9f3e49d9e7.zip
Notes
Diffstat (limited to 'astro/p5-Geo-METAR')
-rw-r--r--astro/p5-Geo-METAR/Makefile5
-rw-r--r--astro/p5-Geo-METAR/distinfo6
-rw-r--r--astro/p5-Geo-METAR/files/patch-METAR.pm180
3 files changed, 5 insertions, 186 deletions
diff --git a/astro/p5-Geo-METAR/Makefile b/astro/p5-Geo-METAR/Makefile
index 2b1042139107..4d332e436bb9 100644
--- a/astro/p5-Geo-METAR/Makefile
+++ b/astro/p5-Geo-METAR/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= Geo-METAR
-PORTVERSION= 1.14
-PORTREVISION= 1
+PORTVERSION= 1.15
CATEGORIES= astro geography
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Geo
PKGNAMEPREFIX= p5-
-MAINTAINER= arved@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A perl module that processes METAR information from NOAA sources
PERL_CONFIGURE= yes
diff --git a/astro/p5-Geo-METAR/distinfo b/astro/p5-Geo-METAR/distinfo
index 0b553a126667..4bafe8a8346f 100644
--- a/astro/p5-Geo-METAR/distinfo
+++ b/astro/p5-Geo-METAR/distinfo
@@ -1,3 +1,3 @@
-MD5 (Geo-METAR-1.14.tar.gz) = 82be0189d58cc0099ec649addde7f6f4
-SHA256 (Geo-METAR-1.14.tar.gz) = 200cddda40f51b58405aadf8fa69d259d8fe0651831ac0b63706db1174b12701
-SIZE (Geo-METAR-1.14.tar.gz) = 12375
+MD5 (Geo-METAR-1.15.tar.gz) = 6cb92c3c3ce094f1517b601f5e22d0d1
+SHA256 (Geo-METAR-1.15.tar.gz) = c73ab84b9af41295d5d226660fba3bfd6da3472060cd63457bcffce50893e536
+SIZE (Geo-METAR-1.15.tar.gz) = 16002
diff --git a/astro/p5-Geo-METAR/files/patch-METAR.pm b/astro/p5-Geo-METAR/files/patch-METAR.pm
deleted file mode 100644
index 2dc232bf33c2..000000000000
--- a/astro/p5-Geo-METAR/files/patch-METAR.pm
+++ /dev/null
@@ -1,180 +0,0 @@
---- METAR.pm.orig Sat Nov 25 01:07:51 2000
-+++ METAR.pm Fri Sep 3 20:33:01 2004
-@@ -95,9 +95,13 @@
-
- # PRESSURE
- #
-+# USA and Canada:
- # The pressure, or altimeter setting, at the reporting site recorded in
- # inches of mercury (Hg) minus the decimal point. It should always look
- # like (A\d\d\d\d).
-+# Rest of the World:
-+# The pressure, or altimeter setting, at the reporting site recorded in
-+# hectopascals(hPa). It should always look like (Q\d\d\d\d).
-
- # REMARKS
- #
-@@ -164,6 +168,7 @@
- my %_sky_types = (
- SKC => "Sky Clear",
- CLR => "Sky Clear",
-+ CAVOK => "Sky Clear",
- SCT => "Scattered",
- BKN => "Broken",
- FEW => "Few",
-@@ -366,52 +371,87 @@
- $self->{type} = "METAR";
- $self->{TYPE} = "Routine Weather Report";
-
-- while (defined($tok = shift(@toks))) ## as long as there are tokens
-+ $tok = shift(@toks);
-+ print "trying to match [$tok]\n" if $self->{debug};
-+
-+ ##
-+ ## is it a report type?
-+ ##
-+
-+ if (($tok =~ /METAR/i) or ($tok =~ /SPECI/i))
- {
-+ $self->{type} = $tok;
-+
-+ if ($self->{type} eq "METAR")
-+ {
-+ $self->{TYPE} = "Routine Weather Report";
-+ }
-+ elsif ($self->{type} eq "SPECI")
-+ {
-+ $self->{TYPE} = "Special Weather Report";
-+ }
-+ print "[$tok] is a report type.\n" if $self->{debug};
-+
-+ $tok = shift(@toks);
- print "trying to match [$tok]\n" if $self->{debug};
-
- ##
-- ## is it a report type?
-+ ## is it a site ID?
- ##
-
-- if (($tok =~ /METAR/i) or ($tok =~ /SPECI/i))
-+ if ($tok =~ /[A-Z]{4,4}/)
- {
-- $self->{type} = $tok;
--
-- if ($self->{type} eq "METAR")
-- {
-- $self->{TYPE} = "Routine Weather Report";
-- }
-- elsif ($self->{type} eq "SPECI")
-- {
-- $self->{TYPE} = "Special Weather Report";
-- }
-- print "[$tok] is a report type.\n" if $self->{debug};
-- next;
-+ $self->{site} = $tok;
-+ print "[$tok] is a site ID.\n" if $self->{debug};
- }
-
- ##
-- ## is is a site ID?
-+ ## Most likely something is wrong, but to be sure put the token back
-+ ## on the stack
- ##
-
-- elsif ($tok =~ /K[A-Z]{3,3}/)
-+ else
- {
-- $self->{site} = $tok;
-- print "[$tok] is a site ID.\n" if $self->{debug};
-- next;
-+ unshift(@toks,$tok);
- }
-
-+ }
-+
-+ ##
-+ ## is it a site ID?
-+ ##
-+
-+ elsif ($tok =~ /[A-Z]{4,4}/)
-+ {
-+ $self->{site} = $tok;
-+ print "[$tok] is a site ID.\n" if $self->{debug};
-+ }
-+
-+ ##
-+ ## Most likely something is wrong, but to be sure put the token back
-+ ## on the stack
-+ ##
-+
-+ else
-+ {
-+ unshift(@toks,$tok);
-+ }
-+
-+ # The order of the remaining stack is not defined, so do a patternmatching loop
-+
-+ while (defined($tok = shift(@toks))) ## as long as there are tokens
-+ {
-+ print "trying to match [$tok]\n" if $self->{debug};
-+
- ##
- ## is it a date/time?
- ##
-
-- elsif ($tok =~ /\d{6,6}Z/i)
-+ if ($tok =~ /\d{6,6}Z/i)
- {
- $self->{date_time} = $tok;
- print "[$tok] is a date/time.\n" if $self->{debug};
- next;
--
--
- }
-
- ##
-@@ -447,6 +487,14 @@
- next;
- }
-
-+ ## 9999 == visibility is better than 10 km
-+ elsif ($tok eq "9999")
-+ {
-+ $self->{visibility} = $tok;
-+ print "[$tok] is visibility information.\n" if $self->{debug};
-+ next;
-+ }
-+
- ##
- ## is it visibility information with a leading digit?
- ##
-@@ -526,7 +574,7 @@
- ## is it sky conditions (clear)?
- ##
-
-- elsif ( $tok eq "SKC" || $tok eq "CLR" )
-+ elsif ( $tok eq "SKC" || $tok eq "CLR" || $tok eq "CAVOK")
- {
- push(@{$self->{sky}},$tok);
- push(@{$self->{SKY}}, "Sky Clear");
-@@ -588,10 +636,20 @@
- ## is it an altimeter setting?
- ##
-
-+ ## Northamerican setting in inches
- elsif (!$in_remarks && $tok =~ /^A(\d\d)(\d\d)$/i)
- {
- $self->{alt} = $tok;
- $self->{ALT} = "$1.$2";
-+ print "[$tok] is an altimeter setting.\n" if $self->{debug};
-+ next;
-+ }
-+
-+ ## setting in hectopascals (hPa)
-+ elsif (!$in_remarks && $tok =~ /^Q(\d\d)(\d\d)$/i)
-+ {
-+ $self->{alt} = $tok;
-+ $self->{ALT} = "$1$2";
- print "[$tok] is an altimeter setting.\n" if $self->{debug};
- next;
- }