aboutsummaryrefslogtreecommitdiff
path: root/astro/phoon
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-14 08:11:57 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-14 08:11:57 +0000
commit61dc2c2a2d5c053b1834f47776bde6b3be2b1eaa (patch)
tree146eb61effc5534b35abe283f6a012a7546df7c9 /astro/phoon
parent38582511cac0fe8b64e2461cdd501a17c6222a1c (diff)
downloadports-61dc2c2a2d5c053b1834f47776bde6b3be2b1eaa.tar.gz
ports-61dc2c2a2d5c053b1834f47776bde6b3be2b1eaa.zip
Notes
Diffstat (limited to 'astro/phoon')
-rw-r--r--astro/phoon/Makefile4
-rw-r--r--astro/phoon/files/patch-Makefile33
2 files changed, 4 insertions, 33 deletions
diff --git a/astro/phoon/Makefile b/astro/phoon/Makefile
index 111aa212bec8..602835c2a264 100644
--- a/astro/phoon/Makefile
+++ b/astro/phoon/Makefile
@@ -17,6 +17,10 @@ COMMENT= Displays the phase of the moon
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_REINPLACE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
+ BINDIR=${LOCALBASE}/bin \
+ MANDIR=${MANPREFIX}/man/man1
+
MAN1= phoon.1
PLIST_FILES= bin/phoon
diff --git a/astro/phoon/files/patch-Makefile b/astro/phoon/files/patch-Makefile
deleted file mode 100644
index 93a0a4c417d7..000000000000
--- a/astro/phoon/files/patch-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig Thu May 15 09:07:10 2003
-+++ Makefile Thu May 15 09:08:24 2003
-@@ -1,13 +1,13 @@
- # Makefile for phoon
-
--BINDIR = /usr/local/bin
--MANDIR = /usr/local/man/man1
-+BINDIR = ${PREFIX}/bin
-+MANDIR = ${MANPREFIX}/man/man1
-
- DEFINES = -DOS_BSD
- #DEFINES = -DOS_SYSV
-
--CC = gcc
--CFLAGS = -O $(DEFINES)
-+CC ?= gcc
-+CFLAGS ?= ${CFLAGS}
-
- LDFLAGS = -s
-
-@@ -15,10 +15,10 @@
- all: phoon
-
- phoon: phoon.o date_parse.o astro.o
-- $(CC) $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-+ ${CC} $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-+ ${CC} $(CFLAGS) -c $<
-
- date_parse.o: date_parse.h
- astro.o: astro.h