aboutsummaryrefslogtreecommitdiff
path: root/astro/py-aipy/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 22:04:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 22:04:27 +0000
commit2f7de215a9ce969c92d74608c112ccb243aba73e (patch)
tree2ee5d6638bbe761987eb7bc8fb50cc87cb440489 /astro/py-aipy/Makefile
parent2ba42c02d71279612c318d6e5ae6526e3d7759eb (diff)
downloadports-2f7de215a9ce969c92d74608c112ccb243aba73e.tar.gz
ports-2f7de215a9ce969c92d74608c112ccb243aba73e.zip
Notes
Diffstat (limited to 'astro/py-aipy/Makefile')
-rw-r--r--astro/py-aipy/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
new file mode 100644
index 000000000000..9a1bb2fb23c1
--- /dev/null
+++ b/astro/py-aipy/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-aipy
+# Date created: 2008-11-11
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aipy
+PORTVERSION= 0.8.3
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Astronomical Interferometry in PYthon
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_SITELIBDIR}/ephem/__init__.py:${PORTSDIR}/astro/pyephem \
+ ${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>