aboutsummaryrefslogtreecommitdiff
path: root/astro/py-astLib
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-16 14:07:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-16 14:07:55 +0000
commitc2313c244bd8dbfbd05d908dbc4d495159f8d284 (patch)
treea9eb910fc3daf9275b26b20a28deb1577ba07575 /astro/py-astLib
parent73889cad26d757604953e32c6f7a42feee819567 (diff)
downloadports-c2313c244bd8dbfbd05d908dbc4d495159f8d284.tar.gz
ports-c2313c244bd8dbfbd05d908dbc4d495159f8d284.zip
Notes
Diffstat (limited to 'astro/py-astLib')
-rw-r--r--astro/py-astLib/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index c5159347c459..fcdbb24faa71 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= astLib
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Astronomy modules for Python
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
${PKGNAMEPREFIX}scipy>=0.7.0:${PORTSDIR}/science/py-scipy \
@@ -24,4 +26,7 @@ PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
USES= python
USE_PYTHON= autoplist distutils
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyWCSTools/*.so
+
.include <bsd.port.mk>