aboutsummaryrefslogtreecommitdiff
path: root/astro/py-horoscopegenerator
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2016-08-05 07:55:33 +0000
committerKevin Lo <kevlo@FreeBSD.org>2016-08-05 07:55:33 +0000
commit0e4791739f6f756959938eaf963ced0d7e07eb7e (patch)
tree710e9821fc65ed1b24a7de2cf3a0c7d0fd660f98 /astro/py-horoscopegenerator
parent66dd5b05c711ffde564c47c90ff890e3ec7c4d3a (diff)
downloadports-0e4791739f6f756959938eaf963ced0d7e07eb7e.tar.gz
ports-0e4791739f6f756959938eaf963ced0d7e07eb7e.zip
Notes
Diffstat (limited to 'astro/py-horoscopegenerator')
-rw-r--r--astro/py-horoscopegenerator/Makefile22
-rw-r--r--astro/py-horoscopegenerator/distinfo3
-rw-r--r--astro/py-horoscopegenerator/pkg-descr4
3 files changed, 29 insertions, 0 deletions
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
new file mode 100644
index 000000000000..16c7ee1c8afe
--- /dev/null
+++ b/astro/py-horoscopegenerator/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= horoscopegenerator
+PORTVERSION= 0.1.8
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+DISTNAME= ${PORTNAME:S/h/H/:S/g/G/}-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Generate horoscopes using context-free grammar
+
+LICENSE= MIT
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk
+
+.include <bsd.port.mk>
diff --git a/astro/py-horoscopegenerator/distinfo b/astro/py-horoscopegenerator/distinfo
new file mode 100644
index 000000000000..a2db3877e91b
--- /dev/null
+++ b/astro/py-horoscopegenerator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470381700
+SHA256 (HoroscopeGenerator-0.1.8.tar.gz) = 96b9f577f7024d131bd3a080a2e177494fa41a36d803bd5f0ec21133bad90073
+SIZE (HoroscopeGenerator-0.1.8.tar.gz) = 6443
diff --git a/astro/py-horoscopegenerator/pkg-descr b/astro/py-horoscopegenerator/pkg-descr
new file mode 100644
index 000000000000..6a015eee6b5a
--- /dev/null
+++ b/astro/py-horoscopegenerator/pkg-descr
@@ -0,0 +1,4 @@
+The HoroscopeGenerator produces horoscopes on demand using context-free
+grammar.
+
+WWW: https://github.com/mouse-reeve/horoscope-generator