aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-06-10 09:40:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-06-10 09:40:12 +0000
commit4593f92124cfa1f6b359ee9a7e8fd8e60314b0eb (patch)
tree6a9ddcef761d216d74c233beed416f6a2af73c50 /astro/qmapshack
parentff77fee12ac47e6867934129fa7d6f2d79ffe5f4 (diff)
downloadports-4593f92124cfa1f6b359ee9a7e8fd8e60314b0eb.tar.gz
ports-4593f92124cfa1f6b359ee9a7e8fd8e60314b0eb.zip
Notes
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile14
-rw-r--r--astro/qmapshack/distinfo5
-rw-r--r--astro/qmapshack/files/patch-src_device_IDevice.cpp29
-rw-r--r--astro/qmapshack/files/patch-src_gis_CGisListWks.cpp20
-rw-r--r--astro/qmapshack/files/patch-src_setup_IAppSetup.cpp11
-rw-r--r--astro/qmapshack/pkg-plist4
6 files changed, 74 insertions, 9 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index add853a3df15..1d1806cecf58 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.3.1
+PORTVERSION= 1.6.1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -11,14 +11,14 @@ COMMENT= Ultimate outdoor aficionado's tool
LICENSE= GPLv3
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-LIB_DEPENDS= libgdal.so:graphics/gdal \
+LIB_DEPENDS= libQt5DBus.so:devel/dbus-qt5 \
+ libgdal.so:graphics/gdal \
+ libproj.so:graphics/proj \
libroutino.so:astro/routino
-USES= cmake desktop-file-utils
-USE_QT5= buildtools linguisttools qmake script sql webkit widgets xml
+USES= cmake compiler:c++11-lib desktop-file-utils
+USE_QT5= buildtools core gui linguisttools network printsupport \
+ qmake script sql sql-sqlite3 webkit widgets xml
.include <bsd.port.mk>
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index b2ac3493059f..038b64a186b8 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qmapshack-1.3.1.tar.gz) = 8f4bcb5454786d7f81681abe4f96cc8e3598f62219708d1efe4c94d19ab0dfea
-SIZE (qmapshack-1.3.1.tar.gz) = 3758785
+TIMESTAMP = 1465057676
+SHA256 (qmapshack-1.6.1.tar.gz) = e702482ef894ec3fdbc5a932dd220bbb34eef1580b1645a314e9a3fa99956c22
+SIZE (qmapshack-1.6.1.tar.gz) = 4538423
diff --git a/astro/qmapshack/files/patch-src_device_IDevice.cpp b/astro/qmapshack/files/patch-src_device_IDevice.cpp
new file mode 100644
index 000000000000..518ff5cc2600
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_device_IDevice.cpp
@@ -0,0 +1,29 @@
+--- src/device/IDevice.cpp.orig 2016-06-04 19:56:45 UTC
++++ src/device/IDevice.cpp
+@@ -22,7 +22,7 @@
+ #include "gis/prj/IGisProject.h"
+ #include "helpers/CSelectCopyAction.h"
+
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ #include <QtDBus>
+ #endif
+
+@@ -52,7 +52,7 @@ IDevice::~IDevice()
+
+ void IDevice::mount(const QString& path)
+ {
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ QDBusMessage message = QDBusMessage::createMethodCall("org.freedesktop.UDisks2",path,"org.freedesktop.UDisks2.Filesystem","Mount");
+ QVariantMap args;
+ args.insert("options", "sync");
+@@ -63,7 +63,7 @@ void IDevice::mount(const QString& path)
+
+ void IDevice::umount(const QString &path)
+ {
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ QDBusMessage message = QDBusMessage::createMethodCall("org.freedesktop.UDisks2",path,"org.freedesktop.UDisks2.Filesystem","Unmount");
+ QVariantMap args;
+ message << args;
diff --git a/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp b/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
new file mode 100644
index 000000000000..856f24840cd3
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
@@ -0,0 +1,20 @@
+--- src/gis/CGisListWks.cpp.orig 2016-06-04 19:56:53 UTC
++++ src/gis/CGisListWks.cpp
+@@ -18,7 +18,7 @@
+
+ #include "CMainWindow.h"
+ #include "canvas/CCanvas.h"
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ #include "device/CDeviceWatcherLinux.h"
+ #endif
+ #ifdef Q_OS_WIN
+@@ -196,7 +196,7 @@ CGisListWks::CGisListWks(QWidget *parent
+ QTimer::singleShot(saveEvery * 60000, this, SLOT(slotSaveWorkspace()));
+ }
+
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ deviceWatcher = new CDeviceWatcherLinux(this);
+ connect(deviceWatcher, &CDeviceWatcherLinux::sigChanged, this, &CGisListWks::sigChanged);
+ #endif
diff --git a/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp b/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp
new file mode 100644
index 000000000000..b1964feeeaa8
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp
@@ -0,0 +1,11 @@
+--- src/setup/IAppSetup.cpp.orig 2016-06-04 19:55:57 UTC
++++ src/setup/IAppSetup.cpp
+@@ -36,7 +36,7 @@ IAppSetup* IAppSetup::getPlatformInstanc
+ {
+ #if defined(Q_OS_MAC)
+ instance = new CAppSetupMac();
+-#elif defined(Q_OS_LINUX)
++#elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
+ instance = new CAppSetupLinux();
+ #elif defined (Q_OS_WIN32)
+ instance = new CAppSetupWin();
diff --git a/astro/qmapshack/pkg-plist b/astro/qmapshack/pkg-plist
index a476c1b72ac8..d5e99fa23f66 100644
--- a/astro/qmapshack/pkg-plist
+++ b/astro/qmapshack/pkg-plist
@@ -1,8 +1,12 @@
bin/qmapshack
man/man1/qmapshack.1.gz
share/applications/qmapshack.desktop
+share/icons/hicolor/32x32/apps/QMapShack.png
+share/icons/hicolor/48x48/apps/QMapShack.png
+share/icons/hicolor/scalable/apps/QMapShack.svg
share/pixmaps/QMapShack.png
%%DATADIR%%/translations/qmapshack_cs.qm
%%DATADIR%%/translations/qmapshack_de.qm
%%DATADIR%%/translations/qmapshack_es.qm
%%DATADIR%%/translations/qmapshack_fr.qm
+%%DATADIR%%/translations/qmapshack_nl.qm