aboutsummaryrefslogtreecommitdiff
path: root/astro/roadmap
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-03-01 08:47:40 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-03-01 08:47:40 +0000
commitf0a7ada89568e60bbd9db642e80b90b9c2fe4a5c (patch)
tree556f439e8a2ab77dd5d994ba2f01019ec6313924 /astro/roadmap
parenta6224dfdc19809e4e772d93c6f2bd24ebd7dff24 (diff)
downloadports-f0a7ada89568e60bbd9db642e80b90b9c2fe4a5c.tar.gz
ports-f0a7ada89568e60bbd9db642e80b90b9c2fe4a5c.zip
Notes
Diffstat (limited to 'astro/roadmap')
-rw-r--r--astro/roadmap/Makefile37
-rw-r--r--astro/roadmap/distinfo2
-rw-r--r--astro/roadmap/files/patch-Makefile35
-rw-r--r--astro/roadmap/pkg-message11
-rw-r--r--astro/roadmap/pkg-plist31
5 files changed, 54 insertions, 62 deletions
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index b3eeb78fae10..c810ae29b411 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= roadmap
-PORTVERSION= 0.6
+PORTVERSION= 0.13
CATEGORIES= astro
MASTER_SITES= http://www.geocities.com/pascal_f_martin/roadmap/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_0_6_src
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}_src
EXTRACT_SUFX= .tgz
MAINTAINER= nick@netdot.net
@@ -19,29 +19,40 @@ COMMENT= RoadMap is a displays US maps provided by the US Census Bureau
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
WRKSRC= ${WRKDIR}/${PORTNAME}
-BUILD_WRKSRC= ${WRKSRC}/src
+BUILD_WRKSRC= ${WRKSRC}/src/gtk
+INSTALL_WRKSRC= ${WRKSRC}/src
USE_GNOMENG= yes
USE_GNOME= gtk12
-BINARIES= buildmap buildus dumpmap roadmap roadgps
+BINS= buildmap buildus dumpmap
+GUI_BINS= gtkroadmap gtkroadgps
+SCRIPTS= rdmdownload rdmgetall rdmgenmaps rdmcompare
+DATA= sprites preferences schema
DOCS= AUTHORS BUGS COPYING README TODO
-DOCDIR= ${PREFIX}/share/doc/${PORTNAME}
do-install:
-.for bin in ${BINARIES}
- $(INSTALL_PROGRAM) ${BUILD_WRKSRC}/${bin} ${LOCALBASE}/bin
+.for _GUI_BIN in ${GUI_BINS}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/gtk/${_GUI_BIN} ${X11BASE}/bin/${_GUI_BIN}
+.endfor
+.for _BIN in ${BINS}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${_BIN} ${LOCALBASE}/bin/${_BIN}
+.endfor
+.for _SCRIPT in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${INSTALL_WRKSRC}/${_SCRIPT} ${LOCALBASE}/bin/${_BIN}
+.endfor
+ ${MKDIR} ${DATADIR}
+.for _DATA in ${DATA}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${_DATA} ${DATADIR}/${_DATA}
.endfor
- ${MKDIR} ${PREFIX}/share/roadmap
-
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCDIR}
-.for doc in ${DOCS}
- ${INSTALL_MAN} ${WRKSRC}/${doc} ${DOCDIR}
+ ${MKDIR} ${DOCSDIR}
+.for _DOC in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${_DOC} ${DOCSDIR}/${_DOC}
.endfor
.endif
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${SED} -e "s|%%DOCSDIR%%|${DOCSDIR}|" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/roadmap/distinfo b/astro/roadmap/distinfo
index be9d1260f8e5..bbd672e30f26 100644
--- a/astro/roadmap/distinfo
+++ b/astro/roadmap/distinfo
@@ -1 +1 @@
-MD5 (roadmap_0_6_src.tgz) = 910054bdfecb309c82a782504e3bc4e6
+MD5 (roadmap_0_13_src.tgz) = b0706023f7d9e2946e89cf8d8a0cacf9
diff --git a/astro/roadmap/files/patch-Makefile b/astro/roadmap/files/patch-Makefile
index b4fb82dd324c..e69de29bb2d1 100644
--- a/astro/roadmap/files/patch-Makefile
+++ b/astro/roadmap/files/patch-Makefile
@@ -1,35 +0,0 @@
---- src/Makefile.orig Thu Oct 31 22:53:28 2002
-+++ src/Makefile Mon Nov 4 14:40:36 2002
-@@ -1,12 +1,12 @@
-
--GUICFLAGS=-DROADMAP_GUI_USES_GTK `gtk-config --cflags`
--GUILDFLAGS=`gtk-config --libs`
-+GUICFLAGS=-DROADMAP_GUI_USES_GTK `${GTK_CONFIG} --cflags`
-+GUILDFLAGS=`${GTK_CONFIG} --libs`
-
--CFLAGS=-O2 -ffast-math -fomit-frame-pointer -Wall $(GUICFLAGS)
-+CFLAGS+=-O2 -ffast-math -fomit-frame-pointer -Wall $(GUICFLAGS)
- # CFLAGS=-g -Wall -DROADMAP_DEBUG_HEAP $(GUICFLAGS)
- # CFLAGS=-g -Wall -pg -fprofile-arcs -g $(GUICFLAGS)
-
--LDFLAGS=-lm
-+LDFLAGS=-lm -L$(LOCALBASE)/lib
- # LDFLAGS=-pg $(LDFLAGS)
-
-
-@@ -103,13 +103,13 @@
- install: uninstall all
- mkdir -p $(INSTALLDIR)/share/roadmap
- cp *.rdm $(INSTALLDIR)/share/roadmap
-- cp roadmap.menu /usr/lib/menu/roadmap
-+# cp roadmap.menu /usr/lib/menu/roadmap
- cp $(EXECUTABLES) $(INSTALLDIR)/bin
-
- uninstall:
- cd $(INSTALLDIR)/bin ; rm -f $(EXECUTABLES)
- rm -rf $(INSTALLDIR)/share/roadmap
-- rm -f /usr/lib/menu/roadmap
-+# rm -f /usr/lib/menu/roadmap
-
- # --- The real targets --------------------------------------------
-
diff --git a/astro/roadmap/pkg-message b/astro/roadmap/pkg-message
index 609f5e400602..d6c8c8be3c7e 100644
--- a/astro/roadmap/pkg-message
+++ b/astro/roadmap/pkg-message
@@ -1,5 +1,10 @@
+------------------------------------------------------------------
+RoadMap is at an early stage of development, and is not thoroughly
+documented. It would be very unwise to rely on RoadMap for real
+navigation.
-RoadMap is at an early stage of development, and is not thoroughly documented.
-See the README in /usr/local/share/doc/roadmap for instructions on obtaining
-and using the necessary data from the US Census Bureau.
+The instructions for downloading and installing the necessary
+TIGER data are located in:
+ %%DOCSDIR%%/README
+------------------------------------------------------------------
diff --git a/astro/roadmap/pkg-plist b/astro/roadmap/pkg-plist
index 9a154288748a..332857f19d03 100644
--- a/astro/roadmap/pkg-plist
+++ b/astro/roadmap/pkg-plist
@@ -1,13 +1,24 @@
+@cwd %%X11BASE%%
+bin/gtkroadmap
+bin/gtkroadgps
+@exec ln -sf %D/bin/gtkroadmap %D/bin/roadmap
+@exec ln -sf %D/bin/gtkroadgps %D/bin/roadgps
+@unexec rm -f %D/bin/roadmap %D/bin/roadgps
+@cwd %%LOCALBASE%%
bin/buildmap
bin/buildus
bin/dumpmap
-bin/roadmap
-bin/roadgps
-%%PORTDOCS%%share/doc/roadmap/AUTHORS
-%%PORTDOCS%%share/doc/roadmap/BUGS
-%%PORTDOCS%%share/doc/roadmap/COPYING
-%%PORTDOCS%%share/doc/roadmap/README
-%%PORTDOCS%%share/doc/roadmap/TODO
-%%PORTDOCS%%@dirrm share/doc/roadmap
-@exec mkdir -p %D/share/roadmap 2>/dev/null || true
-@unexec rmdir %D/share/roadmap 2>/dev/null || true
+bin/rdmdownload
+bin/rdmgetall
+bin/rdmgenmaps
+bin/rdmcompare
+%%DATADIR%%/preferences
+%%DATADIR%%/schema
+%%DATADIR%%/sprites
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%