aboutsummaryrefslogtreecommitdiff
path: root/astro/roadnav/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-11 01:34:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-11 01:34:03 +0000
commit2e48ccd270c7d7e513f373b26c1064f5af424537 (patch)
treec8dd49b34cbeeca3e1200d308f4d9618570052c1 /astro/roadnav/Makefile
parent12a874c6447da931922ce5fa560e4269ad4c1617 (diff)
Notes
Diffstat (limited to 'astro/roadnav/Makefile')
-rw-r--r--astro/roadnav/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/astro/roadnav/Makefile b/astro/roadnav/Makefile
new file mode 100644
index 000000000000..a7aa9b4281d8
--- /dev/null
+++ b/astro/roadnav/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# Ports collection makefile for: roadnav
+# Date created: 28 July 2008
+# Whom: stevef
+#
+# $FreeBSD$
+#
+
+PORTNAME= roadnav
+PORTVERSION= 0.19
+CATEGORIES= astro geography
+MASTER_SITES= SF
+
+MAINTAINER= stevefranks@ieee.org
+COMMENT= A 3D GPS Mapping program
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libroadnav.a:${PORTSDIR}/astro/libroadnav
+
+USE_WX= 2.6+
+WX_COMPS= wx contrib
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= *
+
+pre-install:
+ ${MKDIR} ${PREFIX}/share/applications
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/src/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-roadnavdocDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>