aboutsummaryrefslogtreecommitdiff
path: root/astro/saoimage/Makefile
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-04-17 21:27:32 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-04-17 21:27:32 +0000
commit90dca13aaafd21baee1e32af372c4573ba19d036 (patch)
tree59c7e54b06ddc5dd9e1fe3927417d2da97722f39 /astro/saoimage/Makefile
parentbf2b0f108a690d6c39c283f7bf601720b521556f (diff)
downloadports-90dca13aaafd21baee1e32af372c4573ba19d036.tar.gz
ports-90dca13aaafd21baee1e32af372c4573ba19d036.zip
Notes
Diffstat (limited to 'astro/saoimage/Makefile')
-rw-r--r--astro/saoimage/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/astro/saoimage/Makefile b/astro/saoimage/Makefile
new file mode 100644
index 000000000000..df13b54b4be0
--- /dev/null
+++ b/astro/saoimage/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: saoimage
+# Version required: 1.22
+# Date created: 21 Feb 1998
+# Whom: giffunip@asme.org
+#
+# $Id$
+#
+
+DISTNAME= saoimage-1.22
+CATEGORIES= astro
+MASTER_SITES= ftp://cfa-ftp.harvard.edu/pub/gsc/SAOimage/
+
+MAINTAINER= giffunip@asme.org
+
+MAKEFILE= makefile
+ALL_TARGET= FreeBSD
+INSTALL_TARGET= -f makefile.$(ALL_TARGET) install_saobin install_saoman
+
+MANL= saoimage.l
+USE_X11= yes
+
+pre-patch:
+ $(CP) $(WRKSRC)/makefile.sun $(WRKSRC)/makefile.$(ALL_TARGET)
+pre-build:
+ @(cd ${WRKSRC}; ${MAKE} ${MAKEFILE} clean )
+post-install:
+ strip $(PREFIX)/bin/saoimage
+
+.include <bsd.port.mk>