aboutsummaryrefslogtreecommitdiff
path: root/astro/seti_applet
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 15:09:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 15:09:40 +0000
commit73c10c084c912b474b6e61374ede046a0327993a (patch)
treedbcf0152e304c9b7a9ca07d85843f95be605350f /astro/seti_applet
parent316a6136d823c10515089b4a54306f3272166fed (diff)
downloadports-73c10c084c912b474b6e61374ede046a0327993a.tar.gz
ports-73c10c084c912b474b6e61374ede046a0327993a.zip
Notes
Diffstat (limited to 'astro/seti_applet')
-rw-r--r--astro/seti_applet/Makefile65
-rw-r--r--astro/seti_applet/distinfo1
-rw-r--r--astro/seti_applet/files/patch-aa28
-rw-r--r--astro/seti_applet/files/patch-ab11
-rw-r--r--astro/seti_applet/pkg-descr9
-rw-r--r--astro/seti_applet/pkg-message19
-rw-r--r--astro/seti_applet/pkg-plist20
7 files changed, 0 insertions, 153 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
deleted file mode 100644
index 1710be0a8719..000000000000
--- a/astro/seti_applet/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-# New ports collection makefile for: seti_applet
-# Date Created: 1 Jul 2000
-# Whom: HIYAMA Takeshi <th@cis.ibaraki.ac.jp>
-#
-# $FreeBSD$
-#
-
-PORTNAME= seti_applet
-PORTVERSION= 0.4.1
-PORTREVISION= 1
-CATEGORIES= astro gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
-
-MAINTAINER= cyrille.lefevre@laposte.net
-COMMENT= An applet that displays current status of seti@home client
-
-# Global variables
-#
-
-LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
-RUN_DEPENDS= ${LOCALBASE}/sbin/setiathome:${PORTSDIR}/astro/setiathome
-
-USE_REINPLACE= yes
-USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libpanel gnomecanvas
-USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-# Local variables
-#
-
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-FIND?= find
-XARGS?= xargs
-
-# Post-patch
-#
-
-post-patch: patch-configure patch-seti_applet \
- patch-pkgmessage
-
-patch-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g;\
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
-patch-seti_applet:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/src/seti_applet.c
-
-patch-pkgmessage:
- @${SED} 's|%%LOCALBASE%%|${LOCALBASE}|g' ${MSG_FILE} > ${PKGMESSAGE}
-
-# Post-install
-#
-
-post-install: display-message
-
-display-message:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/astro/seti_applet/distinfo b/astro/seti_applet/distinfo
deleted file mode 100644
index 0957438b20c9..000000000000
--- a/astro/seti_applet/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (seti_applet-0.4.1.tar.gz) = dbd7b73c857a39cf26e563e962050053
diff --git a/astro/seti_applet/files/patch-aa b/astro/seti_applet/files/patch-aa
deleted file mode 100644
index 62c27c11a22f..000000000000
--- a/astro/seti_applet/files/patch-aa
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/seti_applet.c.orig Thu Jun 28 05:00:48 2001
-+++ src/seti_applet.c Wed Aug 22 03:33:19 2001
-@@ -2046,7 +2046,7 @@
- }
- gnome_config_push_prefix (path);
- sa.seti_dir =
-- gnome_config_get_string ("setiapplet/setidir=/usr/local/seti");
-+ gnome_config_get_string ("setiapplet/setidir=/var/db/setiathome");
- sa.update_interval = gnome_config_get_int ("setiapplet/updateinterval=3");
- sa.file_update_interval =
- gnome_config_get_int ("setiapplet/fileupdateinterval=120");
-@@ -2075,14 +2075,14 @@
- g_free (sa.extra_params);
- }
- sa.extra_params = gnome_config_get_string ("setiapplet/extraparams=");
-- sa.separate_exe_dir = gnome_config_get_int ("setiapplet/separateexedir=0");
-+ sa.separate_exe_dir = gnome_config_get_int ("setiapplet/separateexedir=1");
- if (sa.separate_exe_dir != 0)
- {
- if (sa.seti_exe_dir != NULL)
- {
- g_free (sa.seti_exe_dir);
- }
-- sa.seti_exe_dir = gnome_config_get_string ("setiapplet/setiexedir");
-+ sa.seti_exe_dir = gnome_config_get_string ("setiapplet/setiexedir=%%LOCALBASE%%/sbin");
- }
- sa.launch_on_start = gnome_config_get_int ("setiapplet/launchonstart=0");
- gnome_config_pop_prefix ();
diff --git a/astro/seti_applet/files/patch-ab b/astro/seti_applet/files/patch-ab
deleted file mode 100644
index f58089eb8616..000000000000
--- a/astro/seti_applet/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Sat May 11 10:06:56 2002
-+++ configure Sat May 11 10:08:54 2002
-@@ -4543,7 +4543,7 @@
- < $srcdir/po/POTFILES.in > po/POTFILES
-
-
--CFLAGS="$CFLAGS `$GNOME_CONFIG --cflags gnome gtk glib applets`"
-+CFLAGS="$CFLAGS `$GNOME_CONFIG --cflags gnome gtk glib applets libgtop`"
- LDFLAGS="$LDFLAGS `$GNOME_CONFIG --libs gnome gtk glib applets`"
-
-
diff --git a/astro/seti_applet/pkg-descr b/astro/seti_applet/pkg-descr
deleted file mode 100644
index 763255f81c88..000000000000
--- a/astro/seti_applet/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-This applet displays the progress of the seti@home client in a
-panel applet. Currently can display the percentage complete, the
-best spike, best gaussian, units completed and total CPU time spent
-running the seti@home client.
-
-Once installed, this applet should appear under Monitors->Seti Applet
-in the 'Add Applet' menu on the panel.
-
-WWW: http://seti-applet.sourceforge.net/
diff --git a/astro/seti_applet/pkg-message b/astro/seti_applet/pkg-message
deleted file mode 100644
index 4b60d7ed00bf..000000000000
--- a/astro/seti_applet/pkg-message
+++ /dev/null
@@ -1,19 +0,0 @@
-**** To enable start/stop of the seti@home client, please run "setiathome"
- as your login name.
-
- If you installed "setiathome" by ports or package, add, change or
- uncomment the seti_user variable in %%LOCALBASE%%/etc/rc.setiathome.conf
- (or %%LOCALBASE%%/etc/setiathome.conf depending on the version currently
- installed on your computer)
-
- seti_user=nobody
- ^^^^^^
- to your login name before setting up working directory, such as :
-
- seti_user=<your_login_name>
-
- If you already done this as nobody, do
-
- %%LOCALBASE%%/etc/rc.d/setiathome.sh stop
- chown -Rh <your_login_name> /var/db/setiathome
- %%LOCALBASE%%/etc/rc.d/setiathome.sh start
diff --git a/astro/seti_applet/pkg-plist b/astro/seti_applet/pkg-plist
deleted file mode 100644
index e4a2df694937..000000000000
--- a/astro/seti_applet/pkg-plist
+++ /dev/null
@@ -1,20 +0,0 @@
-@comment $FreeBSD$
-bin/seti_applet
-etc/CORBA/servers/seti_applet.gnorba
-share/gnome/applets/Monitors/seti_applet.desktop
-share/gnome/help/seti_applet/C/configuration.html
-share/gnome/help/seti_applet/C/docbook.css
-share/gnome/help/seti_applet/C/images/adv_prop.gif
-share/gnome/help/seti_applet/C/images/basic_prop.gif
-share/gnome/help/seti_applet/C/images/new_user_details_large.gif
-share/gnome/help/seti_applet/C/images/new_user_details_small.gif
-share/gnome/help/seti_applet/C/images/new_user_detected.gif
-share/gnome/help/seti_applet/C/index.html
-share/gnome/help/seti_applet/C/operation.html
-share/gnome/help/seti_applet/C/startingsetiprocess.html
-share/gnome/help/seti_applet/C/topic.dat
-share/gnome/help/seti_applet/C/x42.html
-share/gnome/pixmaps/seti_applet-logo-green.png
-@dirrm share/gnome/help/seti_applet/C/images
-@dirrm share/gnome/help/seti_applet/C
-@dirrm share/gnome/help/seti_applet