aboutsummaryrefslogtreecommitdiff
path: root/astro/seti_applet
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-01-12 18:56:09 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-01-12 18:56:09 +0000
commitf7577bacf9db9c75776cbda37e9aadc5818c9e3b (patch)
tree7ad5bce04c0a3b70cfaa4e924658fee1203d5671 /astro/seti_applet
parent0f60f9a37a639f7e84a8e17f1f065d4b87d38d34 (diff)
downloadports-f7577bacf9db9c75776cbda37e9aadc5818c9e3b.tar.gz
ports-f7577bacf9db9c75776cbda37e9aadc5818c9e3b.zip
Notes
Diffstat (limited to 'astro/seti_applet')
-rw-r--r--astro/seti_applet/Makefile35
-rw-r--r--astro/seti_applet/files/patch-src::seti_applet.c10
-rw-r--r--astro/seti_applet/files/pkg-message.in (renamed from astro/seti_applet/pkg-message)0
-rw-r--r--astro/seti_applet/pkg-plist7
4 files changed, 18 insertions, 34 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
index 42374485718c..9bc2227b129c 100644
--- a/astro/seti_applet/Makefile
+++ b/astro/seti_applet/Makefile
@@ -17,42 +17,23 @@ COMMENT= An applet that displays current status of seti@home client
LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
RUN_DEPENDS= ${LOCALBASE}/sbin/setiathome:${PORTSDIR}/astro/setiathome
-USE_REINPLACE= yes
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomepanel gnomeprefix
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomepanel
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-# Local variables
-#
-
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-REINPLACE_SUB= LOCALBASE=${LOCALBASE}
-PKGMESSAGE_SUB= LOCALBASE=${LOCALBASE}
+GCONF_SCHEMAS= seti_applet.schemas
-# Post-patch
-#
+SUB_FILES= pkg-message
-post-patch: patch-seti_applet patch-pkgmessage
-
-patch-seti_applet:
- @${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+post-patch:
+ @${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/seti_applet.schemas
-patch-pkgmessage:
- @${SED} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${MSG_FILE} > ${PKGMESSAGE}
-
-# Post-install
-#
-
-post-install: display-message
-
-display-message:
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/seti_applet/files/patch-src::seti_applet.c b/astro/seti_applet/files/patch-src::seti_applet.c
new file mode 100644
index 000000000000..47571a0b5509
--- /dev/null
+++ b/astro/seti_applet/files/patch-src::seti_applet.c
@@ -0,0 +1,10 @@
+--- src/seti_applet.c.orig Thu Mar 6 15:03:55 2003
++++ src/seti_applet.c Wed Jan 12 22:47:00 2005
+@@ -177,6 +177,7 @@
+ static void setup_percent_canvas_item(setiapplet *);
+ static void setup_units_canvas_item(setiapplet *);
+ static void setup_cputime_canvas_item(setiapplet *);
++static void setup_cputime_current_canvas_item(setiapplet *);
+ static void applet_change_orient(PanelApplet *,
+ PanelAppletOrient,
+ gpointer);
diff --git a/astro/seti_applet/pkg-message b/astro/seti_applet/files/pkg-message.in
index 43c4368c1e24..43c4368c1e24 100644
--- a/astro/seti_applet/pkg-message
+++ b/astro/seti_applet/files/pkg-message.in
diff --git a/astro/seti_applet/pkg-plist b/astro/seti_applet/pkg-plist
index 6b3f7f6301b7..25381f8bce15 100644
--- a/astro/seti_applet/pkg-plist
+++ b/astro/seti_applet/pkg-plist
@@ -1,10 +1,5 @@
@comment $FreeBSD$
bin/seti-applet-2
-@comment etc/gconf/gconf.xml.defaults/apps/seti_applet/%gconf.xml
-@comment etc/gconf/gconf.xml.defaults/apps/seti_applet/prefs/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/prefs/%gconf.xml
-etc/gconf/schemas/seti_applet.schemas
libdata/bonobo/servers/GNOME_SetiApplet_Factory.server
share/gnome/gnome-2.0/ui/GNOME_SetiApplet.xml
share/gnome/help/seti_applet/C/configuration.html
@@ -35,5 +30,3 @@ share/locale/fr/LC_MESSAGES/seti-applet.mo
@dirrm share/gnome/help/seti_applet/C/images
@dirrm share/gnome/help/seti_applet/C
@dirrm share/gnome/help/seti_applet
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/prefs
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet