aboutsummaryrefslogtreecommitdiff
path: root/astro/sunclock
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2004-11-21 18:59:41 +0000
committerPatrick Li <pat@FreeBSD.org>2004-11-21 18:59:41 +0000
commit22a9353df4f4476f9f4220ca6c9304fc72541f80 (patch)
tree8cfc90c0cb4114fe1126330ce3fd3b56e4163c29 /astro/sunclock
parent1dff5937190661d6eb38bdc040abe94f60eb3274 (diff)
downloadports-22a9353df4f4476f9f4220ca6c9304fc72541f80.tar.gz
ports-22a9353df4f4476f9f4220ca6c9304fc72541f80.zip
Notes
Diffstat (limited to 'astro/sunclock')
-rw-r--r--astro/sunclock/Makefile7
-rw-r--r--astro/sunclock/distinfo4
-rw-r--r--astro/sunclock/files/patch-aa10
-rw-r--r--astro/sunclock/files/patch-sunclock.c31
-rw-r--r--astro/sunclock/pkg-plist1
5 files changed, 23 insertions, 30 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index 8941866a761f..13829eafea7a 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -7,17 +7,16 @@
#
PORTNAME= sunclock
-PORTVERSION= 3.50.p1
+PORTVERSION= 3.52
CATEGORIES= astro x11-clocks
-MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://frmas.free.fr/files/
MAINTAINER= pat@FreeBSD.org
COMMENT= Shows which portion of the Earth's surface is illuminated by the Sun
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_BZIP2= yes
USE_XPM= yes
USE_IMAKE= yes
diff --git a/astro/sunclock/distinfo b/astro/sunclock/distinfo
index 23facb304790..b2322d21925f 100644
--- a/astro/sunclock/distinfo
+++ b/astro/sunclock/distinfo
@@ -1,2 +1,2 @@
-MD5 (sunclock-3.50pre1.tgz) = 6e07964a99848018432825c5b3297cc6
-SIZE (sunclock-3.50pre1.tgz) = 714458
+MD5 (sunclock-3.52.tar.bz2) = 999ec5e0313d4761a05ef30c6a14ded5
+SIZE (sunclock-3.52.tar.bz2) = 550778
diff --git a/astro/sunclock/files/patch-aa b/astro/sunclock/files/patch-aa
index a4dc07c2fd1b..fe9c8c875451 100644
--- a/astro/sunclock/files/patch-aa
+++ b/astro/sunclock/files/patch-aa
@@ -1,5 +1,5 @@
---- Imakefile.orig Tue Aug 14 09:30:24 2001
-+++ Imakefile Sat Dec 8 19:39:45 2001
+--- Imakefile.orig Wed Aug 25 07:00:29 2004
++++ Imakefile Sun Nov 21 13:48:06 2004
@@ -1,15 +1,17 @@
XCOMM Should install to /usr or /usr/local ??
-DESTDIR=/usr
@@ -44,10 +44,10 @@
SRCS=sunclock.c astro.c widgets.c tildepath.c dirlist.c \
@@ -52,7 +54,7 @@
OBJS=sunclock.o astro.o widgets.o tildepath.o dirlist.o \
- readvmf.o readxpm.o readjpeg.o
+ readvmf.o readxpm.o readgif.o readjpeg.o readpng.o
LOCAL_LIBRARIES=$(XLIB) $(XPMLIBDIR) -lXpm $(ZLIBDIR) -lz \
-- $(JLIBDIR) -ljpeg -lm
-+ $(JLIBDIR) -ljpeg -lm -lcompat
+- $(JLIBDIR) -ljpeg -lpng -lm
++ $(JLIBDIR) -ljpeg -lpng -lm -lcompat
DEPLIBS= # I don't know what I'm doing, and I hate imake!
ComplexProgramTarget(sunclock)
diff --git a/astro/sunclock/files/patch-sunclock.c b/astro/sunclock/files/patch-sunclock.c
index 29640034f8dd..8bf572d0ebd4 100644
--- a/astro/sunclock/files/patch-sunclock.c
+++ b/astro/sunclock/files/patch-sunclock.c
@@ -1,5 +1,5 @@
---- sunclock.c.orig Wed Aug 8 07:53:14 2001
-+++ sunclock.c Sat Dec 8 21:24:46 2001
+--- sunclock.c.orig Fri Oct 8 17:11:44 2004
++++ sunclock.c Sun Nov 21 13:51:14 2004
@@ -125,7 +125,6 @@
* external routines
*/
@@ -8,7 +8,7 @@
#ifdef NEW_CTIME
extern char * timezone();
#endif
-@@ -2062,8 +2061,8 @@
+@@ -2164,8 +2163,8 @@
if (!Context->mark1.city) return;
@@ -19,7 +19,7 @@
/* Get local time at given location */
setTZ(Context->mark1.city);
-@@ -2212,8 +2211,8 @@
+@@ -2314,8 +2313,8 @@
if (!Context->flags.mapped) return;
@@ -30,7 +30,7 @@
if (!Context->wintype) {
char num[80];
-@@ -2542,7 +2541,7 @@
+@@ -2661,7 +2660,7 @@
Context->bits = 0;
Context->flags.update = 4;
@@ -39,7 +39,7 @@
Context->projtime = -1L;
Context->roottime = -1L;
Context->animtime = -1L;
-@@ -3708,7 +3707,7 @@
+@@ -3827,7 +3826,7 @@
if (button_pressed) return;
@@ -48,7 +48,7 @@
erase_obj = 1;
if (Context->flags.colorlevel == MONOCHROME ||
-@@ -3716,10 +3715,10 @@
+@@ -3835,10 +3834,10 @@
drawSunAndMoon(Context);
erase_obj = 0;
@@ -61,7 +61,7 @@
&Context->moondec, &Context->moonlon,
&junk, &junk, &junk, &junk, &junk, &junk );
Context->moonlon = fixangle(Context->moonlon+180.0) - 180.0;
-@@ -3736,10 +3735,10 @@
+@@ -3855,10 +3854,10 @@
update the illuminated area on the screen. */
if (Context->projtime < 0 ||
@@ -74,7 +74,7 @@
Context->noon = noon;
Context->fnoon = fnoon;
moveNightArea(Context);
-@@ -4341,8 +4340,8 @@
+@@ -4466,8 +4465,8 @@
hw = Context->geom.height;
if (do_root == 2) hw += Context->hstrip;
@@ -85,7 +85,7 @@
else
if (do_root == 2 && mode==0 && rootpix) update = 0;
-@@ -4353,7 +4352,7 @@
+@@ -4478,7 +4477,7 @@
XSetForeground(dpy, Context->gdata->wingc,
Context->gdata->pixel[ROOTCOLOR]);
XFillRectangle(dpy, rootpix, Context->gdata->wingc, 0, 0, wr, hr);
@@ -94,7 +94,7 @@
if (random_rootpos) {
rootdx = (double)(random() % 10001)/10000.0;
rootdy = (double)(random() % 10001)/10000.0;
-@@ -5299,13 +5298,13 @@
+@@ -5434,7 +5433,7 @@
Context->flags.update = 2;
break;
case XK_w:
@@ -103,14 +103,7 @@
if (do_menu) do_menu = -1;
if (do_filesel) do_filesel = -1;
if (do_zoom) do_zoom = -1;
- if (do_option) do_option = -1;
- buildMap(Context, 1, 1);
-- last_time = Context->time;
-+ last_time = Context->footime;
- keysym = ' ';
- break;
- case XK_r:
-@@ -5616,9 +5615,9 @@
+@@ -5825,9 +5824,9 @@
drawImageToRootWindow(Context, 0);
XFlush(dpy);
if (Context->flags.animate) {
diff --git a/astro/sunclock/pkg-plist b/astro/sunclock/pkg-plist
index b532c91d4f8c..825b976f348e 100644
--- a/astro/sunclock/pkg-plist
+++ b/astro/sunclock/pkg-plist
@@ -9,6 +9,7 @@ share/sunclock/i18n/Sunclock.fr
share/sunclock/i18n/Sunclock.it
share/sunclock/i18n/Sunclock.nl
share/sunclock/i18n/Sunclock.no
+share/sunclock/i18n/Sunclock.pl
share/sunclock/i18n/Sunclock.se
@dirrm share/sunclock/i18n
@dirrm share/sunclock/earthmaps/vmf