aboutsummaryrefslogtreecommitdiff
path: root/astro/tclgeomap
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 04:23:23 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 04:23:23 +0000
commite564519a7e6aa6c354c229c1d07a4d7b114480dd (patch)
tree46ca72a141a798b95de6b87f0b7270a27f27c72e /astro/tclgeomap
parentd338c0fc3913022873dcc2978616d24a8b661477 (diff)
downloadports-e564519a7e6aa6c354c229c1d07a4d7b114480dd.tar.gz
ports-e564519a7e6aa6c354c229c1d07a4d7b114480dd.zip
Notes
Diffstat (limited to 'astro/tclgeomap')
-rw-r--r--astro/tclgeomap/Makefile8
-rw-r--r--astro/tclgeomap/pkg-plist4
2 files changed, 7 insertions, 5 deletions
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index e415d9afbc98..0190ef3cd163 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -20,7 +20,7 @@ USE_TCL= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
PLIST_SUB= INC=include/${PORTNAME} \
- LIB=lib/${PORTNAME}
+ LIB=lib/${PORTNAME} VER=${PORTVERSION}
MAKE_ENV= MKLINKS_FLAGS=-s
USE_LDCONFIG= yes
@@ -180,8 +180,10 @@ MLINKS= \
tclgeomap_procs.n ocean_list.n
post-install:
- @${LN} -sf ${PREFIX}/lib/libtclgeomap2.9.so ${PREFIX}/lib/libtclgeomap2.9.so.0
- @${LN} -sf ${PREFIX}/lib/libtclgeomap2.9.so ${PREFIX}/lib/libtclgeomap.so.0
+ @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so \
+ ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so.0
+ @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so \
+ ${PREFIX}/lib/lib${PORTNAME}.so.0
post-patch:
@${REINPLACE_CMD} -e 's/@PACKAGE@@VERSION@/@PACKAGE@/g' ${WRKSRC}/Makefile.in ${WRKSRC}/pkgIndex.tcl.in
diff --git a/astro/tclgeomap/pkg-plist b/astro/tclgeomap/pkg-plist
index 848dc7e1aa80..cdccffac71f7 100644
--- a/astro/tclgeomap/pkg-plist
+++ b/astro/tclgeomap/pkg-plist
@@ -1,6 +1,6 @@
lib/libtclgeomap.so.0
-lib/libtclgeomap2.9.so
-lib/libtclgeomap2.9.so.0
+lib/libtclgeomap%%VER%%.so
+lib/libtclgeomap%%VER%%.so.0
%%INC%%/geoLines.h
%%INC%%/geoLnArrToMap.h
%%INC%%/geoProj.h