aboutsummaryrefslogtreecommitdiff
path: root/astro/tkgeomap
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-25 16:08:57 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-25 16:08:57 +0000
commitd4d22f8a15ed0005609eb68cd143d02e5b80c0c1 (patch)
tree1cd2073b94c30e22598a2952396ffdc21684af14 /astro/tkgeomap
parentbf4f1ac90d5e9eba148525ff799e66973a20612d (diff)
downloadports-d4d22f8a15ed0005609eb68cd143d02e5b80c0c1.tar.gz
ports-d4d22f8a15ed0005609eb68cd143d02e5b80c0c1.zip
Notes
Diffstat (limited to 'astro/tkgeomap')
-rw-r--r--astro/tkgeomap/Makefile46
-rw-r--r--astro/tkgeomap/distinfo3
-rw-r--r--astro/tkgeomap/pkg-descr16
-rw-r--r--astro/tkgeomap/pkg-plist8
4 files changed, 73 insertions, 0 deletions
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
new file mode 100644
index 000000000000..d2c87181d306
--- /dev/null
+++ b/astro/tkgeomap/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: tkgeomap
+# Date created: 25 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkgeomap
+PORTVERSION= 2.9
+CATEGORIES= astro tk84
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Read, manipulate and display geo data
+
+LIB_DEPENDS= tclgeomap${PORTVERSION}.0:${PORTSDIR}/astro/tclgeomap
+
+.ifndef WITHOUT_X11
+USE_XLIB= yes
+CONFIGURE_ARGS= --with-x
+.endif
+CONFIGURE_ARGS+= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap
+USE_TK= yes
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+PLIST_SUB= INC=include/${PORTNAME} \
+ LIB=lib/${PORTNAME}
+MAKE_ENV= MKLINKS_FLAGS=-s
+USE_LDCONFIG= yes
+
+MANN= igeomap.n tkgeomap.n tkgeomap_procs.n wdgeomap.n
+MLINKS= \
+ wdgeomap.n latlontoxy.n \
+ wdgeomap.n xytolatlon.n
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/libtkgeomap2.9.so ${PREFIX}/lib/libtkgeomap2.9.so.0
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/@PACKAGE@@VERSION@/@PACKAGE@/g' ${WRKSRC}/Makefile.in ${WRKSRC}/pkgIndex.tcl.in
+
+# Maintainer section
+MY_MLINKS:
+ @cd ${MANNPREFIX}/man/mann/ && ls -l `${FIND} . -type l` | ${GREP} -E '(igeo|tkgeo|wdgeo)' | ${SED} -Ee 's#^.*\./(.*) -> (.*)$$#\2 \1 \\#' | ${SORT} -u
+
+.include <bsd.port.mk>
diff --git a/astro/tkgeomap/distinfo b/astro/tkgeomap/distinfo
new file mode 100644
index 000000000000..85dd18e98f46
--- /dev/null
+++ b/astro/tkgeomap/distinfo
@@ -0,0 +1,3 @@
+MD5 (tkgeomap-2.9.tar.gz) = 69fd225c5b71f604bde5efa3f34e824f
+SHA256 (tkgeomap-2.9.tar.gz) = 1d0ffab3b93fea3017b7f89eca8c56e69b288eb706328297e12ad4c1c7c8c5fc
+SIZE (tkgeomap-2.9.tar.gz) = 179922
diff --git a/astro/tkgeomap/pkg-descr b/astro/tkgeomap/pkg-descr
new file mode 100644
index 000000000000..9513c7592149
--- /dev/null
+++ b/astro/tkgeomap/pkg-descr
@@ -0,0 +1,16 @@
+Tkgeomap is an open source set of extensions to the Tcl/Tk scripting
+language. It adds commands that read, manipulate, and display geographic
+data.
+
+It provides four packages:
+* tclgeomap - library written in C adds commands for basic geography
+ calculations and data access.
+* tclgeomap_procs - library written in Tcl adds procedures that
+ supplement tclgeomap.
+* tkgeomap - library written in C that adds the ability to draw maps
+* tkgeomap_procs - library written in Tcl adds procedures that
+ supplement tkgeomap.
+
+This port contains the Tk part.
+
+WWW: http://www.tkgeomap.org/
diff --git a/astro/tkgeomap/pkg-plist b/astro/tkgeomap/pkg-plist
new file mode 100644
index 000000000000..007f76745fec
--- /dev/null
+++ b/astro/tkgeomap/pkg-plist
@@ -0,0 +1,8 @@
+lib/libtkgeomap2.9.so
+lib/libtkgeomap2.9.so.0
+%%INC%%/tkgeomap.h
+%%LIB%%/pkgIndex.tcl
+%%LIB%%/tkgeomap_procs.tcl
+%%LIB%%/wdgeomap.tcl
+@dirrm %%INC%%
+@dirrm %%LIB%%