aboutsummaryrefslogtreecommitdiff
path: root/astro/tkgeomap
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-24 12:56:54 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-24 12:56:54 +0000
commit3468694f7ddf0b7480c5aca6422277263a66bf62 (patch)
tree918f1729c9eeef666ed690c06c819e6588d3eccf /astro/tkgeomap
parentced69d42216b5976367ff87117a6a76a179b042d (diff)
downloadports-3468694f7ddf0b7480c5aca6422277263a66bf62.tar.gz
ports-3468694f7ddf0b7480c5aca6422277263a66bf62.zip
- Update to 2.11.1
- After spending 4 hours on a trivial update, officially state that it was a broken down extension architecture that buried Tcl/Tk for good
Notes
Notes: svn path=/head/; revision=183167
Diffstat (limited to 'astro/tkgeomap')
-rw-r--r--astro/tkgeomap/Makefile28
-rw-r--r--astro/tkgeomap/distinfo6
-rw-r--r--astro/tkgeomap/pkg-plist4
3 files changed, 17 insertions, 21 deletions
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index 32e0c1a7cc50..183b0d0678bc 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tkgeomap
-PORTVERSION= 2.10.1
+PORTVERSION= 2.11.1
CATEGORIES= astro tk84
MASTER_SITES= SF
@@ -17,31 +17,27 @@ LIB_DEPENDS= tclgeomap.0:${PORTSDIR}/astro/tclgeomap \
tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
+ --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
+ --with-tk=${TK_LIBDIR} --with-tkinclude=${TK_INCLUDEDIR} \
+ --mandir=${MANPREFIX}/man \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
+CONFIGURE_ENV= TCLGEOMAP_LIB=${LOCALBASE}/lib/tclgeomap
USE_TK= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-PLIST_SUB= INC=include/${PORTNAME} \
- LIB=lib/${PORTNAME} VER=${PORTVERSION}
-MAKE_ENV= MKLINKS_FLAGS=-s
+TKPKG= ${PORTNAME}
+PLIST_SUB= INC=include/${TKPKG} LIB=lib/${TKPKG}
USE_LDCONFIG= yes
MANN= igeomap.n tkgeomap.n tkgeomap_procs.n wdgeomap.n
-MLINKS= \
- wdgeomap.n latlontoxy.n \
- wdgeomap.n xytolatlon.n
post-install:
- @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so \
- ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so.0
- @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}${PORTVERSION}.so \
- ${PREFIX}/lib/lib${PORTNAME}.so.0
+ @${LN} -sf ${PREFIX}/lib/lib${TKPKG}.so ${PREFIX}/lib/lib${PORTNAME}.so.0
post-patch:
- @${REINPLACE_CMD} -e 's/@PACKAGE@@VERSION@/@PACKAGE@/g' ${WRKSRC}/Makefile.in ${WRKSRC}/pkgIndex.tcl.in
-
-# Maintainer section
-MY_MLINKS:
- @cd ${MANNPREFIX}/man/mann/ && ls -l `${FIND} . -type l` | ${GREP} -E '(igeo|tkgeo|wdgeo)' | ${SED} -Ee 's#^.*\./(.*) -> (.*)$$#\2 \1 \\#' | ${SORT} -u
+ @${REINPLACE_CMD} -e '/=.*PACKAGE_VERSION/s|$${PACKAGE_VERSION}||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|@PACKAGE_VERSION@||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^package/!s|@PACKAGE_VERSION@||g' ${WRKSRC}/pkgIndex.tcl.in
+ @${REINPLACE_CMD} -e '2s|.*|exit 0|' ${WRKSRC}/mkLinks
.include <bsd.port.mk>
diff --git a/astro/tkgeomap/distinfo b/astro/tkgeomap/distinfo
index 684e9b4d7d55..3231ccfb6c1d 100644
--- a/astro/tkgeomap/distinfo
+++ b/astro/tkgeomap/distinfo
@@ -1,3 +1,3 @@
-MD5 (tkgeomap-2.10.1.tar.gz) = d876df5dd0f9ee813466577f17d0cec4
-SHA256 (tkgeomap-2.10.1.tar.gz) = 2f6c87a39166914774378cbe288093fbdce03a4e7a572b18e7a634338cefb783
-SIZE (tkgeomap-2.10.1.tar.gz) = 179986
+MD5 (tkgeomap-2.11.1.tar.gz) = ac9a25e0b926a5535efb35df74dfd247
+SHA256 (tkgeomap-2.11.1.tar.gz) = c6640119efb8576319fed0b6c626432c0a4f3d67ae2bf2cce5ebd97bc537e8e4
+SIZE (tkgeomap-2.11.1.tar.gz) = 239228
diff --git a/astro/tkgeomap/pkg-plist b/astro/tkgeomap/pkg-plist
index 0421ee758580..7dbf5af8c5a1 100644
--- a/astro/tkgeomap/pkg-plist
+++ b/astro/tkgeomap/pkg-plist
@@ -1,7 +1,7 @@
+lib/libtkgeomap.so
lib/libtkgeomap.so.0
-lib/libtkgeomap%%VER%%.so
-lib/libtkgeomap%%VER%%.so.0
%%INC%%/tkgeomap.h
+%%INC%%/tkgeomapInt.h
%%LIB%%/pkgIndex.tcl
%%LIB%%/tkgeomap_procs.tcl
%%LIB%%/wdgeomap.tcl