aboutsummaryrefslogtreecommitdiff
path: root/astro/tkseti
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 12:29:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 12:29:12 +0000
commite173331f93f45e73b3e024cf62dfc735741fc340 (patch)
tree86860920b85a1d5ea0c6def11f673c8d6595f1d8 /astro/tkseti
parent5e4a2c9d69a65a742f1a1a8222642ffcb4899c0a (diff)
downloadports-e173331f93f45e73b3e024cf62dfc735741fc340.tar.gz
ports-e173331f93f45e73b3e024cf62dfc735741fc340.zip
Notes
Diffstat (limited to 'astro/tkseti')
-rw-r--r--astro/tkseti/Makefile9
-rw-r--r--astro/tkseti/distinfo3
-rw-r--r--astro/tkseti/files/patch-aa42
-rw-r--r--astro/tkseti/pkg-descr13
-rw-r--r--astro/tkseti/pkg-message12
5 files changed, 65 insertions, 14 deletions
diff --git a/astro/tkseti/Makefile b/astro/tkseti/Makefile
index c8f4cf3b3ab1..e86362f775b1 100644
--- a/astro/tkseti/Makefile
+++ b/astro/tkseti/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= tkseti
-PORTVERSION= 3.06
-PORTREVISION= 2
+PORTVERSION= 3.07
CATEGORIES= astro tk84
-MASTER_SITES= http://www.cuug.ab.ca/~macdonal/tkseti/
+MASTER_SITES= http://phileimer.9online.fr/tkseti/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tk-based interface to SETI@Home
@@ -18,6 +17,7 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
${LOCALBASE}/sbin/setiathome:${PORTSDIR}/astro/setiathome
NO_BUILD= yes
+USE_BZIP2= yes
MAN1= tkseti.1
@@ -30,4 +30,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/tkseti/README
.endif
+post-install:
+ @${CAT} pkg-message
+
.include <bsd.port.mk>
diff --git a/astro/tkseti/distinfo b/astro/tkseti/distinfo
index 07f8973841bc..55088a41101e 100644
--- a/astro/tkseti/distinfo
+++ b/astro/tkseti/distinfo
@@ -1,2 +1 @@
-MD5 (tkseti-3.06.tar.gz) = 18022c248c55df03c9946a32875988d3
-SIZE (tkseti-3.06.tar.gz) = 171221
+MD5 (tkseti-3.07.tar.bz2) = 0851e5d1bab03b78ff756bc4779d0eee
diff --git a/astro/tkseti/files/patch-aa b/astro/tkseti/files/patch-aa
index c48f48587580..924c7fe5abfa 100644
--- a/astro/tkseti/files/patch-aa
+++ b/astro/tkseti/files/patch-aa
@@ -1,14 +1,14 @@
---- tkseti.orig Fri Jun 8 16:23:37 2001
-+++ tkseti Mon Jun 11 10:22:48 2001
+--- tkseti.orig Fri Jan 23 03:58:46 2004
++++ tkseti Sat Jan 31 21:55:01 2004
@@ -1,6 +1,6 @@
#!/bin/sh
# the next line restarts using wish \
-exec wish "$0" ${1+"$@"}
-+exec wish8.3 "$0" ${1+"$@"}
++exec wish8.4 "$0" ${1+"$@"}
#############################################################################
# Visual Tcl v1.20 Project
#
-@@ -189,11 +189,11 @@
+@@ -194,11 +194,11 @@
TkSETI can be started if the client is already running, or it can start
the client manually or automatically for you. This is explained in the
Setup section that follows.
@@ -25,7 +25,19 @@
tkseti ~/setiathome
-@@ -551,7 +551,7 @@
+@@ -368,6 +368,11 @@
+ KDE's kfm: kfmclient openURL $url
+ lynx: xterm -e lynx $url
+
++
++ The following command is used in this FreeBSD port:
++
++ mozilla (no wrapper): /bin/sh -c "mozilla -remote 'openurl($url,new-window)'||exec mozilla $url"
++
+ Proxy Host
+ ==========
+
+@@ -564,7 +569,7 @@
if {[catch {info nameofexecutable} nameofexecutable]} {
set nameofexecutable wish
}
@@ -34,7 +46,7 @@
if {[lsearch $argv "--help"] >= 0} {
puts \n$seti(usage)
-@@ -566,7 +566,7 @@
+@@ -579,7 +584,7 @@
option add *highlightBackground grey85 user
if {$argc == 0} {
@@ -43,3 +55,21 @@
} {
set seti(setidir) [lindex $argv 0]
if {[string index $seti(setidir) 0] != "/"} {
+@@ -4871,7 +4876,7 @@
+ update idletasks
+ Window show $widget(tkseti)
+
+- set seti(tksetiURL) "http://www.cuug.ab.ca/~macdonal/tkseti/tkseti.html"
++ set seti(tksetiURL) "http://phileimer.9online.fr/tkseti/CHANGES"
+
+ # set seti(statefile) $seti(setidir)/state.txt
+ # set seti(workfile) $seti(setidir)/work_unit.txt
+@@ -4951,7 +4956,7 @@
+ set seti(_howto_kill) {kill -KILL $pid}
+ set seti(_howto_pause) {kill -STOP $pid}
+ set seti(_howto_cont) {kill -CONT $pid}
+- set seti(_howto_browse) {/bin/csh -c "netscape -remote openURL\\\\($url,new-window\\\\) || exec netscape $url"}
++ set seti(_howto_browse) {/bin/sh -c "mozilla -remote 'openurl($url,new-window)'||exec mozilla $url"}
+ set seti(_howto_statnet) {}
+ set seti(_howto_startnet) {}
+ set seti(_howto_stopnet) {}
diff --git a/astro/tkseti/pkg-descr b/astro/tkseti/pkg-descr
index dbc904241a3d..ab5176e678e9 100644
--- a/astro/tkseti/pkg-descr
+++ b/astro/tkseti/pkg-descr
@@ -3,7 +3,14 @@ current best spikes and gaussians for the user and can be used in
multiple directories. It can also fetch the user's statistics from
the seti@home web site.
-WWW: http://www.cuug.ab.ca/~macdonal/tkseti/
+tkseti can be started if the client is already running, or it can
+start the client manually or automatically for you. It will look for
+the client files in the directory /var/db/setiathome . If you've run
+the client elsewhere, or run more than one client, just specify the
+setiathome client directory on the tkseti command line. For example:
-- Pete
-petef@databits.net
+ tkseti ~/setiathome
+
+Make sure the user has write access to the setiathome directory!
+
+WWW: http://phileimer.9online.fr/tkseti/CHANGES
diff --git a/astro/tkseti/pkg-message b/astro/tkseti/pkg-message
new file mode 100644
index 000000000000..4b5ec400f877
--- /dev/null
+++ b/astro/tkseti/pkg-message
@@ -0,0 +1,12 @@
+***************************************************************************
+
+Make sure the user has write access to the setiathome directory!
+
+tkseti will look for the client files in the directory /var/db/setiathome .
+If you've run the client elsewhere, or run more than one client, just
+specify the setiathome client directory on the tkseti command line. For
+example:
+
+ tkseti ~/setiathome
+
+***************************************************************************