aboutsummaryrefslogtreecommitdiff
path: root/astro/viking/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 06:57:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 06:57:16 +0000
commitfa8e7fc56e3710cf9058bd0f55bac1a8759f2de5 (patch)
tree196a01f73ca23735228b9062dc8386cb18c0ba09 /astro/viking/Makefile
parentf137a485dc1bf6a0351b5d8d063b9eacfefa15a8 (diff)
downloadports-fa8e7fc56e3710cf9058bd0f55bac1a8759f2de5.tar.gz
ports-fa8e7fc56e3710cf9058bd0f55bac1a8759f2de5.zip
Notes
Diffstat (limited to 'astro/viking/Makefile')
-rw-r--r--astro/viking/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 760393e61e25..146906c556c5 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -20,8 +20,10 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
-OPTIONS= GEOTAG "Enable Geotag support" on \
- GPSD "Enable realtime GPS tracking" off
+OPTIONS_DEFINE= GEOTAR GPSD
+OPTIONS_DEFAULT= GEOTAG
+GEOTAG_DESC= Enable Geotag support
+GPSD_DESC= Enable realtime GPS tracking
USE_GNOME= gnomedocutils gtk20
USE_PERL5_RUN= yes
@@ -37,13 +39,13 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
-.if defined(WITH_GEOTAG)
+.if ${PORT_OPTIONS:MGEOTAG}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.else
CONFIGURE_ARGS+= --disable-geotag
.endif
-.if defined(WITH_GPSD)
+.if ${PORT_OPTIONS:MGPSD}
LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
.else
CONFIGURE_ARGS+= --disable-realtime-gps-tracking