aboutsummaryrefslogtreecommitdiff
path: root/astro/viking/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 13:29:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 13:29:15 +0000
commit7f4572eae4327c4403d9ef714cb6de917650662a (patch)
treee5609c11a5cecf09649970cae33b72d3774969e3 /astro/viking/Makefile
parent630b8bcb8b62c77a87ea9d6bfa87a312a9d89555 (diff)
downloadports-7f4572eae4327c4403d9ef714cb6de917650662a.tar.gz
ports-7f4572eae4327c4403d9ef714cb6de917650662a.zip
Notes
Diffstat (limited to 'astro/viking/Makefile')
-rw-r--r--astro/viking/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 4d2a0364e55e..fa237db1c47e 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -12,15 +12,15 @@ COMMENT= Program to manage GPS data (tracks, waypoints, etc.)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libgexiv2.so:${PORTSDIR}/graphics/gexiv2 \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libpng.so:${PORTSDIR}/graphics/png \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
-RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgexiv2.so:graphics/gexiv2 \
+ libpcre.so:devel/pcre \
+ libpng.so:graphics/png \
+ libpthread-stubs.so:devel/libpthread-stubs
+RUN_DEPENDS= gpsbabel:astro/gpsbabel
USES= compiler:c++11-lib gmake iconv desktop-file-utils perl5 pkgconfig tar:bzip2
USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
@@ -57,20 +57,20 @@ GEOCACHES_SUB_FILES= pkg-message
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-GEOTAG_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif
+GEOTAG_LIB_DEPENDS= libexif.so:graphics/libexif
GEOTAG_CONFIGURE_ENABLE=geotag
-GPSD_LIB_DEPENDS= libgpsd.so:${PORTSDIR}/astro/gpsd
+GPSD_LIB_DEPENDS= libgpsd.so:astro/gpsd
GPSD_CONFIGURE_ENABLE= realtime-gps-tracking
-MAPNIK_LIB_DEPENDS= libmapnik.so:${PORTSDIR}/graphics/mapnik
+MAPNIK_LIB_DEPENDS= libmapnik.so:graphics/mapnik
MAPNIK_CONFIGURE_ENABLE= mapnik
MBTILES_USES= sqlite
MBTILES_CONFIGURE_ENABLE= mbtiles
-JOSM_RUN_DEPENDS= josm:${PORTSDIR}/astro/josm
-MERKAATOR_RUN_DEPENDS= merkaartor:${PORTSDIR}/astro/merkaartor
+JOSM_RUN_DEPENDS= josm:astro/josm
+MERKAATOR_RUN_DEPENDS= merkaartor:astro/merkaartor
post-patch:
@${REINPLACE_CMD} -e '/^AM_CFLAGS/s| -g | |' ${WRKSRC}/src/Makefile.in