aboutsummaryrefslogtreecommitdiff
path: root/astro/viking/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-21 03:09:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-21 03:09:59 +0000
commit99bae5eaf7599df3385b1a42cc3ed0701334271b (patch)
tree48128a9544d4a68fc0f5cb700cdf38c1b012cad6 /astro/viking/Makefile
parent3592d01f99469a27bba3fa56508cc38b11eb82d1 (diff)
downloadports-99bae5eaf7599df3385b1a42cc3ed0701334271b.tar.gz
ports-99bae5eaf7599df3385b1a42cc3ed0701334271b.zip
Notes
Diffstat (limited to 'astro/viking/Makefile')
-rw-r--r--astro/viking/Makefile36
1 files changed, 20 insertions, 16 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 783b81fe9859..3904f597b18c 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -6,45 +6,49 @@
#
PORTNAME= viking
-PORTVERSION= 1.2.2
+PORTVERSION= 1.3
CATEGORIES= astro
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to manage GPS data (tracks, waypoints, etc)
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
-OPTIONS= GPSD "Enable realtime GPS tracking" off
+OPTIONS= GEOTAG "Enable Geotag support" on \
+ GPSD "Enable realtime GPS tracking" off
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+USE_GNOME= gnomedocutils gtk20
+USE_PERL5_RUN= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-USE_GMAKE= yes
-USE_GNOME= gnomedocutils gtk20 libglade2
-USE_PERL5_RUN= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
-.if defined(WITH_GPSD)
-LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
+.if defined(WITH_GEOTAG)
+LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.else
-CONFIGURE_ARGS+= --disable-realtime-gps-tracking
+CONFIGURE_ARGS+= --disable-geotag
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+.if defined(WITH_GPSD)
+LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-realtime-gps-tracking
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|gps_poll|gps_read|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^AM_CFLAGS/s| -g | |' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>