aboutsummaryrefslogtreecommitdiff
path: root/astro/viking
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-28 17:30:20 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-28 17:30:20 +0000
commitf86c7188a3da3dd8ef1302d6b35eb96c6c1feec1 (patch)
tree78cce790d01ccc57ae4462baa90f87c8afb0c5bf /astro/viking
parent47547a0dde50defb9a91700e075c0396e0fb5c86 (diff)
downloadports-f86c7188a3da3dd8ef1302d6b35eb96c6c1feec1.tar.gz
ports-f86c7188a3da3dd8ef1302d6b35eb96c6c1feec1.zip
Notes
Diffstat (limited to 'astro/viking')
-rw-r--r--astro/viking/Makefile57
-rw-r--r--astro/viking/distinfo4
-rw-r--r--astro/viking/pkg-descr13
-rw-r--r--astro/viking/pkg-plist70
4 files changed, 86 insertions, 58 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 8b7d95a34af6..14977740cf8e 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -1,34 +1,34 @@
-# New ports collection makefile for: viking
-# Date created: 29 April 2008
-# Whom: David Le Brun <david@trucs.org>
-#
+# Created by: David Le Brun <david@trucs.org>
# $FreeBSD$
-#
PORTNAME= viking
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2.1
CATEGORIES= astro
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.3.2/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Program to manage GPS data (tracks, waypoints, etc)
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ curl:${PORTSDIR}/ftp/curl \
+ cairo:${PORTSDIR}/graphics/cairo \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
-OPTIONS_DEFINE= GEOTAR GPSD
-OPTIONS_DEFAULT= GEOTAG
-GEOTAG_DESC= Enable Geotag support
-GPSD_DESC= Enable realtime GPS tracking
-
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender
USE_GNOME= gnomedocutils gtk20
+USE_ICONV= yes
USE_PERL5_RUN= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
MAKE_JOBS_SAFE= yes
@@ -36,8 +36,23 @@ MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+OPTIONS_DEFINE= GEOTAG GPSD
+OPTIONS_DEFAULT= GEOTAG
+GEOTAG_DESC= Enable Geotag support
+GPSD_DESC= Enable realtime GPS tracking
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MGEOTAG}
LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
.else
@@ -53,4 +68,12 @@ CONFIGURE_ARGS+= --disable-realtime-gps-tracking
post-patch:
@${REINPLACE_CMD} -e '/^AM_CFLAGS/s| -g | |' ${WRKSRC}/src/Makefile.in
+post-install:
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/astro/viking/distinfo b/astro/viking/distinfo
index 6008e5a182e9..992a5d571c89 100644
--- a/astro/viking/distinfo
+++ b/astro/viking/distinfo
@@ -1,2 +1,2 @@
-SHA256 (viking-1.3.1.tar.gz) = d6511059eb554426dd6f5c76dd7d30913429a0445bddef63647fc9458c5c0920
-SIZE (viking-1.3.1.tar.gz) = 1094445
+SHA256 (viking-1.3.2.1.tar.gz) = ebd6f134a340a1b2ba582ea77bd97ddd9db16b476be7090a12649f6069fa1565
+SIZE (viking-1.3.2.1.tar.gz) = 1097274
diff --git a/astro/viking/pkg-descr b/astro/viking/pkg-descr
index ff0014b7a64a..439e7c45f8cb 100644
--- a/astro/viking/pkg-descr
+++ b/astro/viking/pkg-descr
@@ -1,10 +1,7 @@
-viking is a free/open source program to manage GPS data.
+Viking is a free/open source program to manage GPS data.
-You can import and plot tracks and waypoints, show Google maps and/or
-Terraserver maps under it, download geocaches for an area on the map, make new
-tracks and waypoints, see real-time GPS position, etc.
+You can import, plot and create tracks and waypoints, show OSM, Terraserver
+and other maps, see real-time GPS position, get geocaches, control items, etc.
+It is written in C & the GTK+2 toolkit.
-It is written in C with the GTK+ 2 toolkit, available for Linux, other POSIX
-operating systems, and Windows, and is licensed under the GNU GPL.
-
-WWW: http://viking.sourceforge.net/
+WWW: http://sourceforge.net/apps/mediawiki/viking/index.php
diff --git a/astro/viking/pkg-plist b/astro/viking/pkg-plist
index 6099371d0327..43227ca62c72 100644
--- a/astro/viking/pkg-plist
+++ b/astro/viking/pkg-plist
@@ -5,36 +5,44 @@ share/gnome/help/viking/C/figures/properties_units.png
share/gnome/help/viking/C/legal.xml
share/gnome/help/viking/C/viking.xml
share/icons/hicolor/48x48/apps/viking.png
-share/locale/cs/LC_MESSAGES/viking.mo
-share/locale/da/LC_MESSAGES/viking.mo
-share/locale/de/LC_MESSAGES/viking.mo
-share/locale/el/LC_MESSAGES/viking.mo
-share/locale/en_GB/LC_MESSAGES/viking.mo
-share/locale/es/LC_MESSAGES/viking.mo
-share/locale/fr/LC_MESSAGES/viking.mo
-share/locale/he/LC_MESSAGES/viking.mo
-share/locale/hu/LC_MESSAGES/viking.mo
-share/locale/id/LC_MESSAGES/viking.mo
-share/locale/it/LC_MESSAGES/viking.mo
-share/locale/ja/LC_MESSAGES/viking.mo
-share/locale/jv/LC_MESSAGES/viking.mo
-share/locale/lt/LC_MESSAGES/viking.mo
-share/locale/lv/LC_MESSAGES/viking.mo
-share/locale/nb/LC_MESSAGES/viking.mo
-share/locale/nl/LC_MESSAGES/viking.mo
-share/locale/pl/LC_MESSAGES/viking.mo
-share/locale/pt_BR/LC_MESSAGES/viking.mo
-share/locale/ru/LC_MESSAGES/viking.mo
-share/locale/sl/LC_MESSAGES/viking.mo
-share/locale/sv/LC_MESSAGES/viking.mo
-share/locale/uk/LC_MESSAGES/viking.mo
-share/locale/zh_CN/LC_MESSAGES/viking.mo
-share/locale/zh_TW/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/da/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/de/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/el/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/es/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/he/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/id/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/it/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/jv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/viking.mo
share/omf/viking/viking-C.omf
-@dirrm share/omf/viking
-@dirrmtry share/locale/jv/LC_MESSAGES
-@dirrmtry share/locale/jv
-@dirrm share/gnome/help/viking/C/figures
-@dirrm share/gnome/help/viking/C
-@dirrm share/gnome/help/viking
+share/pixmaps/viking.png
+@dirrmtry share/omf/viking
+@dirrmtry share/omf
+%%NLS%%@dirrmtry share/locale/jv/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/jv
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/gnome/help/viking/C/figures
+@dirrmtry share/gnome/help/viking/C
+@dirrmtry share/gnome/help/viking
+@dirrmtry share/gnome/help
+@dirrmtry share/gnome
@dirrmtry share/applications