aboutsummaryrefslogtreecommitdiff
path: root/astro/weather
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-27 09:03:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-27 09:03:57 +0000
commit5605c5a7cd2e4aed73c9f865703f20f2e02b148f (patch)
tree945a34b456b99f341b3f307c4401eb2fe7f04e56 /astro/weather
parent7c4c76c7918e6bade2e30ec780593c7de22526ef (diff)
downloadports-5605c5a7cd2e4aed73c9f865703f20f2e02b148f.tar.gz
ports-5605c5a7cd2e4aed73c9f865703f20f2e02b148f.zip
Notes
Diffstat (limited to 'astro/weather')
-rw-r--r--astro/weather/Makefile27
-rw-r--r--astro/weather/distinfo4
2 files changed, 17 insertions, 14 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 7c6d8057a431..2bf431e81bdf 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= weather
-PORTVERSION= 1.5
+PORTVERSION= 2.0
CATEGORIES= astro python
MASTER_SITES= http://fungi.yuggoth.org/weather/src/ \
LOCAL/sunpoet
@@ -14,24 +14,27 @@ MASTER_SITES= http://fungi.yuggoth.org/weather/src/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= An utility to provide current weather conditions and forecasts
-USE_PYTHON= -2.7
+USE_PYTHON= yes
+USE_XZ= yes
-MAN1= weather.1
-MAN5= weatherrc.5
-PLIST_FILES= bin/weather \
+MAN1= ${PORTNAME}.1
+MAN5= ${PORTNAME}rc.5
+PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
- %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyc
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyc \
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyo
post-patch:
- @${REINPLACE_CMD} -e '1 s/python/${PYTHON_VERSION}/' ${WRKSRC}/weather
+ @${REINPLACE_CMD} -e '1 s|/usr/bin/env python|${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
do-build:
- @${WRKSRC}/weather --version
+ @${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/weather ${PREFIX}/bin/
- @${INSTALL_DATA} ${WRKSRC}/weather.py ${WRKSRC}/weather.pyc ${PYTHON_SITELIBDIR}/
- @${INSTALL_MAN} ${WRKSRC}/weather.1 ${MANPREFIX}/man/man1/
- @${INSTALL_MAN} ${WRKSRC}/weatherrc.5 ${MANPREFIX}/man/man5/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTNAME}.py ${PORTNAME}.pyc ${PORTNAME}.pyo ${PYTHON_SITELIBDIR}/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}rc.5 ${MANPREFIX}/man/man5/${PORTNAME}rc.5
.include <bsd.port.mk>
diff --git a/astro/weather/distinfo b/astro/weather/distinfo
index 78b11ebc59d4..d18d1d47423d 100644
--- a/astro/weather/distinfo
+++ b/astro/weather/distinfo
@@ -1,2 +1,2 @@
-SHA256 (weather-1.5.tar.gz) = 4a88936ada82a7027d97e33edc9aea50222ee5a3092566bf82fc77952222711b
-SIZE (weather-1.5.tar.gz) = 16533
+SHA256 (weather-2.0.tar.xz) = 807aff002d31cd81aeaae096981c28900323c405b8f7d36625d9c7e48719347a
+SIZE (weather-2.0.tar.xz) = 8928144