aboutsummaryrefslogtreecommitdiff
path: root/astro/wmspaceweather
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-26 16:51:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-26 16:51:15 +0000
commit9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896 (patch)
tree9b071a8105704e992946dcd6b801e9fcb7635142 /astro/wmspaceweather
parent5a20e7990eb544509174d617d359bf0d4ac64737 (diff)
downloadports-9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896.tar.gz
ports-9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896.zip
Notes
Diffstat (limited to 'astro/wmspaceweather')
-rw-r--r--astro/wmspaceweather/files/patch-GetKp4
-rw-r--r--astro/wmspaceweather/files/patch-Makefile8
-rw-r--r--astro/wmspaceweather/files/patch-wmSpaceWeather.c20
3 files changed, 16 insertions, 16 deletions
diff --git a/astro/wmspaceweather/files/patch-GetKp b/astro/wmspaceweather/files/patch-GetKp
index 55c2633e1c05..e65e1700318d 100644
--- a/astro/wmspaceweather/files/patch-GetKp
+++ b/astro/wmspaceweather/files/patch-GetKp
@@ -1,5 +1,5 @@
---- ./GetKp.orig 1999-02-12 06:42:01.000000000 +0100
-+++ ./GetKp 2014-04-04 21:55:15.059689500 +0200
+--- GetKp.orig 1999-02-12 05:42:01 UTC
++++ GetKp
@@ -5,7 +5,7 @@
#
diff --git a/astro/wmspaceweather/files/patch-Makefile b/astro/wmspaceweather/files/patch-Makefile
index 67dd3990d14d..6a985e4f4eea 100644
--- a/astro/wmspaceweather/files/patch-Makefile
+++ b/astro/wmspaceweather/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 1999-01-04 22:20:45.000000000 +0100
-+++ ./Makefile 2014-04-04 21:55:35.196529518 +0200
+--- Makefile.orig 1999-01-04 21:20:45 UTC
++++ Makefile
@@ -1,8 +1,7 @@
-CC = gcc
-CFLAGS = -O2 -Wall
@@ -13,7 +13,7 @@
# for linux
LIBS = -lXpm -lX11 -lXext
# for Solaris
-@@ -12,14 +11,14 @@
+@@ -12,14 +11,14 @@ OBJS = wmSpaceWeather.o \
.c.o:
@@ -30,7 +30,7 @@
clean:
for i in $(OBJS) ; do \
-@@ -28,7 +27,7 @@
+@@ -28,7 +27,7 @@ clean:
rm -f wmSpaceWeather
install:: wmSpaceWeather
diff --git a/astro/wmspaceweather/files/patch-wmSpaceWeather.c b/astro/wmspaceweather/files/patch-wmSpaceWeather.c
index 5834dac43ff8..6f22d3ac4693 100644
--- a/astro/wmspaceweather/files/patch-wmSpaceWeather.c
+++ b/astro/wmspaceweather/files/patch-wmSpaceWeather.c
@@ -1,6 +1,6 @@
---- ./wmSpaceWeather.c.orig 1999-02-18 18:57:45.000000000 +0100
-+++ ./wmSpaceWeather.c 2014-04-04 21:55:15.061690087 +0200
-@@ -115,7 +115,7 @@
+--- wmSpaceWeather.c.orig 1999-02-18 17:57:45 UTC
++++ wmSpaceWeather.c
+@@ -115,7 +115,7 @@ XEvent event;
int i, n, s, k, m, dt1, dt2;
int Year, Month, Day, DayOfMonth, OldDayOfMonth;
int Hours, Mins, Secs, OldSecs, xoff, D[10], xsize;
@@ -9,7 +9,7 @@
int height, UpToDate, LEDOn;
double UT, TU, TU2, TU3, T0, gmst, hour24();
-@@ -126,6 +126,7 @@
+@@ -126,6 +126,7 @@ int Kp[8] = { -1, -1, -1, -1, -1, -1,
double E1, E2, P1, P2, P3;
char Xray[10], digit[2];
FILE *fp;
@@ -17,7 +17,7 @@
-@@ -249,13 +250,13 @@
+@@ -249,13 +250,13 @@ FILE *fp;
/*
@@ -33,7 +33,7 @@
dt2 = 0;
-@@ -272,13 +273,13 @@
+@@ -272,13 +273,13 @@ FILE *fp;
Secs = Time->tm_sec;
UT = (double)Hours + (double)Mins/60.0 + (double)Secs/3600.0;
CurrentJD = jd(Year, Month, Day, UT);
@@ -49,7 +49,7 @@
for (i=0; i<8; ++i){
fscanf(fp, "%ld %d", &TimeTag[i], &Kp[i]);
-@@ -289,7 +290,7 @@
+@@ -289,7 +290,7 @@ FILE *fp;
fscanf(fp, "%lf", &P3);
fscanf(fp, "%lf", &E1);
fscanf(fp, "%lf", &E2);
@@ -58,7 +58,7 @@
fclose(fp);
} else {
-@@ -318,7 +319,7 @@
+@@ -318,7 +319,7 @@ FILE *fp;
LatestAvailJD = jd(Year, Month, Day, UT);
DeltaT = (CurrentJD - LatestAvailJD)*24.0;
@@ -67,7 +67,7 @@
if (!UpToDate){
-@@ -560,7 +561,7 @@
+@@ -560,7 +561,7 @@ void ParseCMDLine(int argc, char *argv[]
} else if ((!strcmp(argv[i], "-url"))||(!strcmp(argv[i], "-u"))){
@@ -76,7 +76,7 @@
} else {
-@@ -651,7 +652,7 @@
+@@ -651,7 +652,7 @@ void pressEvent(XButtonEvent *xev){
if (GotDoubleClick1) {
GotFirstClick1 = 0;
GotDoubleClick1 = 0;