aboutsummaryrefslogtreecommitdiff
path: root/astro/wmsun
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-06 18:50:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-06 18:50:50 +0000
commitaacb465c79fee53aab256a093ed94b722c2d7e27 (patch)
tree45d11a24c18ffdb706e633f8e13dcfe0a0f28760 /astro/wmsun
parent39048027d5347fcd56a8e824d3585b1941ccd09d (diff)
downloadports-aacb465c79fee53aab256a093ed94b722c2d7e27.tar.gz
ports-aacb465c79fee53aab256a093ed94b722c2d7e27.zip
astro/wmsun: Update to version 1.12
Fix MASTER_SITES
Notes
Notes: svn path=/head/; revision=383467
Diffstat (limited to 'astro/wmsun')
-rw-r--r--astro/wmsun/Makefile12
-rw-r--r--astro/wmsun/distinfo4
-rw-r--r--astro/wmsun/files/patch-Makefile14
-rw-r--r--astro/wmsun/files/patch-wmSun.c6
-rw-r--r--astro/wmsun/pkg-descr2
5 files changed, 16 insertions, 22 deletions
diff --git a/astro/wmsun/Makefile b/astro/wmsun/Makefile
index 28c87f14f6d9..bae2f61ff79f 100644
--- a/astro/wmsun/Makefile
+++ b/astro/wmsun/Makefile
@@ -2,21 +2,17 @@
# $FreeBSD$
PORTNAME= wmsun
-PORTVERSION= 1.03
-PORTREVISION= 2
+PORTVERSION= 1.12
CATEGORIES= astro windowmaker
-MASTER_SITES= http://dockapps.windowmaker.org/download.php/id/23/
-DISTNAME= wmSun-1.03
+MASTER_SITES= http://linux-bsd-unix.strefa.pl/
+DISTNAME= wmSun-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Dockapp that displays the rise and set times of the Sun
-BROKEN= No public distfiles
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/wmSun
+WRKSRC_SUBDIR= wmSun
USE_XORG= xext xpm x11
-ALL_TARGET= clean all
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
INCDIR="-I${LOCALBASE}/include" LIBDIR="-L${LOCALBASE}/lib"
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/wmsun/distinfo b/astro/wmsun/distinfo
index 3c9892d42f47..49f21710372b 100644
--- a/astro/wmsun/distinfo
+++ b/astro/wmsun/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wmSun-1.03.tar.gz) = 53d81d1ac9541c153917c4d0bb9813308268a1d1b47ed0e5b685e4a17b36b193
-SIZE (wmSun-1.03.tar.gz) = 184320
+SHA256 (wmSun-1.12.tar.gz) = d05fb019dd835fc33b2c7c3fb7cf1b6a8cd7fe59b62c8d3fa00ddd0f776da15d
+SIZE (wmSun-1.12.tar.gz) = 147170
diff --git a/astro/wmsun/files/patch-Makefile b/astro/wmsun/files/patch-Makefile
index 3814e6d078a8..20562229be26 100644
--- a/astro/wmsun/files/patch-Makefile
+++ b/astro/wmsun/files/patch-Makefile
@@ -1,19 +1,17 @@
--- Makefile.orig Wed Jan 6 11:28:39 1999
+++ Makefile Thu Aug 3 21:28:34 2000
-@@ -22,14 +22,14 @@
-
+@@ -18,12 +18,12 @@
+ OBJS = wmSun.o SunRise.o ../wmgeneral/wmgeneral.o
.c.o:
- $(CC) $(COPTS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+ $(CC) $(CFLAGS) -D$(OPSYS) -c $< -o $@ $(INCDIR)
-
all: wmSun.o wmSun
- wmSun.o: wmSun_master.xpm wmSun_mask.xbm
- wmSun: $(OBJS)
-- $(CC) $(COPTS) $(SYSTEM) -lm -o wmSun $^ $(INCDIR) $(LIBDIR) $(LIBS)
-+ $(CC) $(CFLAGS) $(SYSTEM) -lm -o wmSun $(OBJS) $(LIBDIR) $(LIBS)
+ wmSun: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -o wmSun $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(SYSTEM) -o wmSun $(OBJS) $(LIBDIR) $(LIBS)
clean:
- for i in $(OBJS) ; do \
+ for i in $(OBJS) ; do rm -f $$i; done
diff --git a/astro/wmsun/files/patch-wmSun.c b/astro/wmsun/files/patch-wmSun.c
index a87af2c10a3d..15ca2738a13c 100644
--- a/astro/wmsun/files/patch-wmSun.c
+++ b/astro/wmsun/files/patch-wmSun.c
@@ -3,10 +3,10 @@ $FreeBSD$
--- wmSun.c.orig Thu Aug 15 18:04:04 2002
+++ wmSun.c Thu Aug 15 18:06:24 2002
-@@ -129,7 +129,8 @@
- int Year, Month, DayOfWeek, OldLocalDayOfMonth;
- int LocalDayOfMonth, DayOfMonth;
+@@ -76,7 +76,8 @@
+ int LocalDayOfMonth, DayOfMonth;
int Hours, Mins, Secs, OldSecs, digit, xoff, xsize;
+ int OldMins;
- long CurrentLocalTime, CurrentGMTTime, date;
+ time_t CurrentLocalTime, CurrentGMTTime;
+ long date;
diff --git a/astro/wmsun/pkg-descr b/astro/wmsun/pkg-descr
index 678b9a4ee9b7..d09c6b04635d 100644
--- a/astro/wmsun/pkg-descr
+++ b/astro/wmsun/pkg-descr
@@ -1,3 +1,3 @@
A dockapp that displays the rise and set time of the sun.
-WWW: http://dockapps.windowmaker.org/file.php/id/16/
+WWW: http://linux-bsd-unix.strefa.pl/