aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2014-03-13 04:30:49 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2014-03-13 04:30:49 +0000
commit792cb0ec797a673ea9d5d32a4978f807428e4ac8 (patch)
treea92ce05d132b3b394473548dc9291fb050e350e2 /astro
parent5d115a4dea2361693b358cc351aa9ceaea683a8f (diff)
downloadports-792cb0ec797a673ea9d5d32a4978f807428e4ac8.tar.gz
ports-792cb0ec797a673ea9d5d32a4978f807428e4ac8.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/xephem/Makefile43
-rw-r--r--astro/xephem/distinfo4
-rw-r--r--astro/xephem/files/patch-Makefile36
-rw-r--r--astro/xephem/pkg-plist129
4 files changed, 86 insertions, 126 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 38d37c3e1794..6ecf9e804d19 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xephem
-PORTVERSION= 3.7.5
-PORTREVISION= 1
+PORTVERSION= 3.7.6
CATEGORIES= astro
MASTER_SITES= # http://www.clearskyinstitute.com/xephem/
@@ -13,15 +12,13 @@ COMMENT= An interactive astronomical ephemeris program
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg
-NO_STAGE= yes
USES= gmake motif
+LDFLAGS+= -lfontconfig
USE_XORG= xp xt xext xmu x11 xft
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/GUI/xephem
-MAN1= xephem.1
-
RESTRICTED= Personal use only
# XXX needs to be the same as DISTFILES
@@ -31,9 +28,9 @@ XEPHEMSRC= ${PORTNAME}-${PORTVERSION}.tar.gz
.for file in ${XEPHEMSRC}
.if !exists(${DISTDIR}/${file})
-ECHO_MSG= ${PRINTF}
-IGNORE=\n\
-Because of licensing restrictions, you must manually fetch \n\ ${file} from http://www.clearskyinstitute.com/xephem/, \n\ place it in ${DISTDIR} and then run make again.\n\n
+IGNORE= because of licensing restrictions, you must manually fetch ${file}\
+ from http://www.clearskyinstitute.com/xephem/,\
+ place it in ${DISTDIR} and then run make again
.endif
.endfor
@@ -42,25 +39,29 @@ post-patch:
-e 's|/usr/X11R6|${LOCALBASE}|g' \
${WRKSRC}/Makefile
@${FIND} ${WRKSRC}/../.. -name Makefile -type f | \
- ${XARGS} ${REINPLACE_CMD} -e 's|CC =|CC?=|g ; \
- s|CFLAGS=|CFLAGS+=|g ; \
+ ${XARGS} ${REINPLACE_CMD} -e 's|CC = gcc|CC?= ${CC}|g ; \
+ s|CFLAGS =|CFLAGS+=|g ; \
+ s|LDFLAGS =|LDFLAGS+=|g ; \
s|-O2 ||g'
pre-build:
- @${ECHO_CMD} 'XEphem.ShareDir: ${PREFIX}/lib/X11/xephem' > ${WRKSRC}/XEphem.ad
+ @${ECHO_CMD} 'XEphem.ShareDir: ${STAGEDIR}${PREFIX}/lib/X11/xephem' \
+ > ${WRKSRC}/XEphem.ad
pre-install:
- @${FIND} ${WRKSRC}/../.. -name Makefile.bak -type f | ${XARGS} ${RM} -f
- @${CP} ${WRKSRC}/xephem.man ${WRKSRC}/xephem.1
+ @${FIND} ${WRKSRC}/../.. -name Makefile.bak -type f -delete
+ @${CP} ${WRKSRC}/xephem.man ${STAGEDIR}${PREFIX}/man/man1/xephem.1
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xephem ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xephem.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/XEphem.ad ${PREFIX}/lib/X11/app-defaults/XEphem
- @${MKDIR} ${PREFIX}/lib/X11/xephem
- ${TAR} -C ${WRKSRC} -cf - auxil catalogs fifos fits gallery help lo tools \
- | ${TAR} -C ${PREFIX}/lib/X11/xephem --unlink -xf -
- @${FIND} ${PREFIX}/lib/X11/xephem | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGROUP}
- @${FIND} ${PREFIX}/lib/X11/xephem -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/xephem ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/XEphem.ad ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/XEphem
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/xephem
+ ${TAR} -C ${WRKSRC} -cf - auxil catalogs fifos fits gallery help lo \
+ | ${TAR} -C ${STAGEDIR}${PREFIX}/lib/X11/xephem --unlink -xf -
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/X11/xephem \
+ | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGROUP}
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/X11/xephem -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.include <bsd.port.post.mk>
diff --git a/astro/xephem/distinfo b/astro/xephem/distinfo
index e5c444fd718d..a7853b8dce7d 100644
--- a/astro/xephem/distinfo
+++ b/astro/xephem/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xephem-3.7.5.tar.gz) = edda7975bb690f74b1853d2729de2b0f4ada69fb37a08117ace7a22c23ee7d1a
-SIZE (xephem-3.7.5.tar.gz) = 18908521
+SHA256 (xephem-3.7.6.tar.gz) = 2080b628d80d52d9ff7148787e3093eb56f21fef5fba404f123b6198b2d64d05
+SIZE (xephem-3.7.6.tar.gz) = 17975496
diff --git a/astro/xephem/files/patch-Makefile b/astro/xephem/files/patch-Makefile
index 5a80202f48c2..7e897653568a 100644
--- a/astro/xephem/files/patch-Makefile
+++ b/astro/xephem/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2009-01-05 23:55:59.000000000 +0300
-+++ Makefile 2011-04-13 20:07:51.559534154 +0400
+--- Makefile.orig 2013-01-20 04:42:02.000000000 +0100
++++ Makefile 2013-10-20 13:58:27.000000000 +0200
@@ -10,9 +10,9 @@
# one executable, xephem.
@@ -13,7 +13,7 @@
# MOTIFI is the directory containing the Xm directory of include files.
# MOTIFL is the directory containing the libXm.a library.
-@@ -24,18 +24,18 @@
+@@ -24,19 +24,19 @@
MOTIFL = $(MOTIF)
endif
ifndef MOTIFI
@@ -31,21 +31,33 @@
CLDFLAGS = -g
-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
--XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
--LIBS = $(XLIBS) $(LIBLIB) -lm
+-XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11
+CFLAGS = $(LIBINC) $(CLDFLAGS) -Wall -I$(MOTIFI) -I%%LOCALBASE%%/include
+LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L%%LOCALBASE%%/lib
-+XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11 -lXft
-+LIBS = $(XLIBS) $(LIBLIB) -lm -liconv
-
-@@ -189,10 +189,7 @@
++XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11 -lXft
+ LIBS = $(XLIBS) $(LIBLIB) -lm
+
+ # for ppc Apple OS X to make universal (i386 and ppc binary), requires
+@@ -181,18 +181,15 @@
+ all: libs xephem xephem.1
+
+ xephem: $(INCS) $(OBJS)
+- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ xephem.1: xephem.man
+ nroff -man $? > $@
+
libs:
- cd ../../libastro; make
- cd ../../libip; make
+- cd ../../libastro; make
+- cd ../../libip; make
- cd ../../libjpegd; make
- cd ../../liblilxml; make
+- cd ../../liblilxml; make
- cd ../../libpng; make
- cd ../../libz; make
++ cd ../../libastro; $(MAKE)
++ cd ../../libip; $(MAKE)
++ cd ../../liblilxml; $(MAKE)
clean:
rm -fr *.o ../../lib*/*.[ao]
diff --git a/astro/xephem/pkg-plist b/astro/xephem/pkg-plist
index a611a615d933..5dca498ca189 100644
--- a/astro/xephem/pkg-plist
+++ b/astro/xephem/pkg-plist
@@ -41,6 +41,41 @@ lib/X11/xephem/fifos/Makefile
lib/X11/xephem/fifos/README
lib/X11/xephem/fits/Abell426.fts
lib/X11/xephem/fits/horsehead.fts
+lib/X11/xephem/gallery/1999-41-a-web_print.jpg
+lib/X11/xephem/gallery/I0059-1.jpg
+lib/X11/xephem/gallery/I1613-1.jpg
+lib/X11/xephem/gallery/I1848-1.jpg
+lib/X11/xephem/gallery/I2118-2.jpg
+lib/X11/xephem/gallery/M013-2.jpg
+lib/X11/xephem/gallery/M034-1.jpg
+lib/X11/xephem/gallery/M053-1.jpg
+lib/X11/xephem/gallery/N2174-1.jpg
+lib/X11/xephem/gallery/N6633-1.jpg
+lib/X11/xephem/gallery/N6791-1.jpg
+lib/X11/xephem/gallery/N6820-2.jpg
+lib/X11/xephem/gallery/N6946-1.jpg
+lib/X11/xephem/gallery/N7023-2.jpg
+lib/X11/xephem/gallery/N7129-2.jpg
+lib/X11/xephem/gallery/S115-1.jpg
+lib/X11/xephem/gallery/abell1656-1.jpg
+lib/X11/xephem/gallery/abell2151-1.jpg
+lib/X11/xephem/gallery/arp295_kelly_c1.jpg
+lib/X11/xephem/gallery/gallery.gly
+lib/X11/xephem/gallery/hickson68-1.jpg
+lib/X11/xephem/gallery/ic5146-2002sep12-hall.jpg
+lib/X11/xephem/gallery/m103-2002sep13-lrgb.jpg
+lib/X11/xephem/gallery/m29-2002sep05.jpg
+lib/X11/xephem/gallery/m3-2003may07-ddp.jpg
+lib/X11/xephem/gallery/m35-11dec01-grgb.jpg
+lib/X11/xephem/gallery/m76-07dec01-lrgb-nr.jpg
+lib/X11/xephem/gallery/m82-03apr02-rgb.jpg
+lib/X11/xephem/gallery/m92-01jun02.jpg
+lib/X11/xephem/gallery/m97-03apr02-lrgb.jpg
+lib/X11/xephem/gallery/ngc457-2002sep13-lrgb.jpg
+lib/X11/xephem/gallery/ngc6819-25aug01-lrgb.jpg
+lib/X11/xephem/gallery/ngc6888-27jul02-ha.jpg
+lib/X11/xephem/gallery/ngc869-2002oct06-lrgb.jpg
+lib/X11/xephem/gallery/pui-17-virgo-anno1000.jpg
lib/X11/xephem/help/png/aavso.png
lib/X11/xephem/help/png/annotation.png
lib/X11/xephem/help/png/close-pairs.png
@@ -79,8 +114,8 @@ lib/X11/xephem/help/png/moon.png
lib/X11/xephem/help/png/movie.png
lib/X11/xephem/help/png/naag.png
lib/X11/xephem/help/png/network-setup.png
-lib/X11/xephem/help/png/obslog.png
lib/X11/xephem/help/png/obslog-list.png
+lib/X11/xephem/help/png/obslog.png
lib/X11/xephem/help/png/plot-sample.png
lib/X11/xephem/help/png/plot.png
lib/X11/xephem/help/png/print.png
@@ -130,100 +165,12 @@ lib/X11/xephem/help/png/uranus.png
lib/X11/xephem/help/png/valid-html401.png
lib/X11/xephem/help/png/wcssolver.png
lib/X11/xephem/help/xephem.html
-lib/X11/xephem/gallery/1999-41-a-web_print.jpg
-lib/X11/xephem/gallery/I0059-1.jpg
-lib/X11/xephem/gallery/I1613-1.jpg
-lib/X11/xephem/gallery/I1848-1.jpg
-lib/X11/xephem/gallery/I2118-2.jpg
-lib/X11/xephem/gallery/M013-2.jpg
-lib/X11/xephem/gallery/M034-1.jpg
-lib/X11/xephem/gallery/M053-1.jpg
-lib/X11/xephem/gallery/N2174-1.jpg
-lib/X11/xephem/gallery/N6633-1.jpg
-lib/X11/xephem/gallery/N6791-1.jpg
-lib/X11/xephem/gallery/N6820-2.jpg
-lib/X11/xephem/gallery/N6946-1.jpg
-lib/X11/xephem/gallery/N7023-2.jpg
-lib/X11/xephem/gallery/N7129-2.jpg
-lib/X11/xephem/gallery/S115-1.jpg
-lib/X11/xephem/gallery/abell1656-1.jpg
-lib/X11/xephem/gallery/abell2151-1.jpg
-lib/X11/xephem/gallery/arp295_kelly_c1.jpg
-lib/X11/xephem/gallery/gallery.gly
-lib/X11/xephem/gallery/hickson68-1.jpg
-lib/X11/xephem/gallery/ic5146-2002sep12-hall.jpg
-lib/X11/xephem/gallery/m103-2002sep13-lrgb.jpg
-lib/X11/xephem/gallery/m29-2002sep05.jpg
-lib/X11/xephem/gallery/m3-2003may07-ddp.jpg
-lib/X11/xephem/gallery/m35-11dec01-grgb.jpg
-lib/X11/xephem/gallery/m76-07dec01-lrgb-nr.jpg
-lib/X11/xephem/gallery/m82-03apr02-rgb.jpg
-lib/X11/xephem/gallery/m92-01jun02.jpg
-lib/X11/xephem/gallery/m97-03apr02-lrgb.jpg
-lib/X11/xephem/gallery/ngc457-2002sep13-lrgb.jpg
-lib/X11/xephem/gallery/ngc6819-25aug01-lrgb.jpg
-lib/X11/xephem/gallery/ngc6888-27jul02-ha.jpg
-lib/X11/xephem/gallery/ngc869-2002oct06-lrgb.jpg
-lib/X11/xephem/gallery/pui-17-virgo-anno1000.jpg
lib/X11/xephem/lo/lodb.xml
-lib/X11/xephem/tools/indi/Makefile
-lib/X11/xephem/tools/indi/README
-lib/X11/xephem/tools/indi/cam.c
-lib/X11/xephem/tools/indi/camtest.fts
-lib/X11/xephem/tools/indi/camtest2.fts
-lib/X11/xephem/tools/indi/compiler.c
-lib/X11/xephem/tools/indi/evalINDI.c
-lib/X11/xephem/tools/indi/evalINDI.man
-lib/X11/xephem/tools/indi/eventloop.c
-lib/X11/xephem/tools/indi/eventloop.h
-lib/X11/xephem/tools/indi/fq.c
-lib/X11/xephem/tools/indi/fq.h
-lib/X11/xephem/tools/indi/getINDI.c
-lib/X11/xephem/tools/indi/getINDI.man
-lib/X11/xephem/tools/indi/indiapi.h
-lib/X11/xephem/tools/indi/indidevapi.h
-lib/X11/xephem/tools/indi/indidevapi.man
-lib/X11/xephem/tools/indi/indidrivermain.c
-lib/X11/xephem/tools/indi/indiserver.c
-lib/X11/xephem/tools/indi/indiserver.man
-lib/X11/xephem/tools/indi/ota.c
-lib/X11/xephem/tools/indi/security.c
-lib/X11/xephem/tools/indi/setINDI.c
-lib/X11/xephem/tools/indi/setINDI.man
-lib/X11/xephem/tools/indi/tmount.c
-lib/X11/xephem/tools/indi/wx.c
-lib/X11/xephem/tools/lx200xed/LICENSE
-lib/X11/xephem/tools/lx200xed/Makefile
-lib/X11/xephem/tools/lx200xed/README
-lib/X11/xephem/tools/lx200xed/liblx200.c
-lib/X11/xephem/tools/lx200xed/liblx200.h
-lib/X11/xephem/tools/lx200xed/lx200xed.c
-lib/X11/xephem/tools/xedb/Makefile
-lib/X11/xephem/tools/xedb/README
-lib/X11/xephem/tools/xedb/print.c
-lib/X11/xephem/tools/xedb/sample.res
-lib/X11/xephem/tools/xedb/xedb.c
-lib/X11/xephem/tools/xephemdbd/INSTALL
-lib/X11/xephem/tools/xephemdbd/Makefile
-lib/X11/xephem/tools/xephemdbd/README
-lib/X11/xephem/tools/xephemdbd/cgi-lib.pl
-lib/X11/xephem/tools/xephemdbd/db.c
-lib/X11/xephem/tools/xephemdbd/fsfetch.c
-lib/X11/xephem/tools/xephemdbd/request.c
-lib/X11/xephem/tools/xephemdbd/start-xephemdbd.pl
-lib/X11/xephem/tools/xephemdbd/stubs.c
-lib/X11/xephem/tools/xephemdbd/xephemdbd.c
-lib/X11/xephem/tools/xephemdbd/xephemdbd.html
-lib/X11/xephem/tools/xephemdbd/xephemdbd.pl
-@dirrm lib/X11/xephem/tools/xephemdbd
-@dirrm lib/X11/xephem/tools/xedb
-@dirrm lib/X11/xephem/tools/lx200xed
-@dirrm lib/X11/xephem/tools/indi
-@dirrm lib/X11/xephem/tools
+man/man1/xephem.1.gz
+@dirrm lib/X11/xephem/lo
@dirrm lib/X11/xephem/help/png
@dirrm lib/X11/xephem/help
@dirrm lib/X11/xephem/gallery
-@dirrm lib/X11/xephem/lo
@dirrm lib/X11/xephem/fits
@dirrm lib/X11/xephem/fifos
@dirrm lib/X11/xephem/catalogs