aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /astro
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-Astro-ADS/Makefile4
-rw-r--r--astro/p5-Astro-App-Satpass2/Makefile4
-rw-r--r--astro/p5-Astro-Catalog/Makefile4
-rw-r--r--astro/p5-Astro-Coords/Makefile4
-rw-r--r--astro/p5-Astro-DSS/Makefile4
-rw-r--r--astro/p5-Astro-Flux/Makefile4
-rw-r--r--astro/p5-Astro-SIMBAD-Client/Makefile4
-rw-r--r--astro/p5-Astro-SIMBAD/Makefile4
-rw-r--r--astro/p5-Astro-Telescope/Makefile4
-rw-r--r--astro/p5-GPS-Babel/Makefile4
-rw-r--r--astro/p5-GPS/Makefile4
-rw-r--r--astro/p5-Starlink-AST/Makefile4
-rw-r--r--astro/p5-Weather-Underground/Makefile4
13 files changed, 26 insertions, 26 deletions
diff --git a/astro/p5-Astro-ADS/Makefile b/astro/p5-Astro-ADS/Makefile
index 733f8ece82e6..fb474108b074 100644
--- a/astro/p5-Astro-ADS/Makefile
+++ b/astro/p5-Astro-ADS/Makefile
@@ -13,8 +13,8 @@ COMMENT= OO Perl interface to the ADS abstract service
LICENSE= GPLv2+
-BUILD_DEPENDS= p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-libwww>=0:www/p5-libwww
NO_ARCH= yes
USES= perl5
diff --git a/astro/p5-Astro-App-Satpass2/Makefile b/astro/p5-Astro-App-Satpass2/Makefile
index 4c87f41e6dd1..d6a5e96c2347 100644
--- a/astro/p5-Astro-App-Satpass2/Makefile
+++ b/astro/p5-Astro-App-Satpass2/Makefile
@@ -13,13 +13,13 @@ COMMENT= Forecast satellite visibility
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Astro-SIMBAD-Client>=0:astro/p5-Astro-SIMBAD-Client \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-SIMBAD-Client>=0:astro/p5-Astro-SIMBAD-Client \
p5-Astro-satpass>=0.077:astro/p5-Astro-satpass \
p5-Clone>=0:devel/p5-Clone \
p5-File-HomeDir>=0.93:devel/p5-File-HomeDir \
p5-IPC-System-Simple>=0:devel/p5-IPC-System-Simple \
p5-Template-Toolkit>=2.21:www/p5-Template-Toolkit
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
index 2a9a8820cc0e..98475e33738c 100644
--- a/astro/p5-Astro-Catalog/Makefile
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -13,7 +13,8 @@ COMMENT= Generic stellar catalogue object
LICENSE= GPLv3
# p5-Astro-FITS-CFITSIO is a recommended dependency
-BUILD_DEPENDS= p5-Astro-Coords>=0.12:astro/p5-Astro-Coords \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-Coords>=0.12:astro/p5-Astro-Coords \
p5-Astro-FITS-CFITSIO>=1.03:astro/p5-Astro-FITS-CFITSIO \
p5-Astro-Flux>=0.01:astro/p5-Astro-Flux \
p5-Astro-Telescope>=0.50:astro/p5-Astro-Telescope \
@@ -23,7 +24,6 @@ BUILD_DEPENDS= p5-Astro-Coords>=0.12:astro/p5-Astro-Coords \
p5-Number-Uncertainty>=0.1:math/p5-Number-Uncertainty \
p5-SOAP-Lite>=0:net/p5-SOAP-Lite \
p5-libwww>=5.53:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= localbase perl5
diff --git a/astro/p5-Astro-Coords/Makefile b/astro/p5-Astro-Coords/Makefile
index 786c9cde7932..119e4387a2a9 100644
--- a/astro/p5-Astro-Coords/Makefile
+++ b/astro/p5-Astro-Coords/Makefile
@@ -12,10 +12,10 @@ COMMENT= Class for handling astronomical coordinates
LICENSE= GPLv2+
-BUILD_DEPENDS= p5-Astro-PAL>=0:astro/p5-Astro-PAL \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-PAL>=0:astro/p5-Astro-PAL \
p5-Astro-Telescope>=0.71:astro/p5-Astro-Telescope \
p5-DateTime>=0.76:devel/p5-DateTime
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Number-Delta>=0:devel/p5-Test-Number-Delta \
p5-Test-Pod>=1:devel/p5-Test-Pod
diff --git a/astro/p5-Astro-DSS/Makefile b/astro/p5-Astro-DSS/Makefile
index 6f532e47291c..28a38479304d 100644
--- a/astro/p5-Astro-DSS/Makefile
+++ b/astro/p5-Astro-DSS/Makefile
@@ -13,8 +13,8 @@ COMMENT= OO interface to the 1st and 2nd Digital Sky Surveys
LICENSE= GPLv2+
-BUILD_DEPENDS= p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-libwww>=0:www/p5-libwww
NO_ARCH= yes
USES= perl5
diff --git a/astro/p5-Astro-Flux/Makefile b/astro/p5-Astro-Flux/Makefile
index 34932a4f05b9..b45d9abe14a1 100644
--- a/astro/p5-Astro-Flux/Makefile
+++ b/astro/p5-Astro-Flux/Makefile
@@ -14,11 +14,11 @@ COMMENT= Class for handling astronomical flux quantities
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Astro-WaveBand>=0:astro/p5-Astro-WaveBand \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-WaveBand>=0:astro/p5-Astro-WaveBand \
p5-DateTime>=0:devel/p5-DateTime \
p5-Misc-Quality>=0:astro/p5-Misc-Quality \
p5-Number-Uncertainty>=0:math/p5-Number-Uncertainty
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USE_PERL5= configure
diff --git a/astro/p5-Astro-SIMBAD-Client/Makefile b/astro/p5-Astro-SIMBAD-Client/Makefile
index fb42323aadbf..1156b13e149d 100644
--- a/astro/p5-Astro-SIMBAD-Client/Makefile
+++ b/astro/p5-Astro-SIMBAD-Client/Makefile
@@ -13,12 +13,12 @@ COMMENT= OO interface to SIMBAD4
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTTP-Message>=0:www/p5-HTTP-Message \
p5-SOAP-Lite>=0:net/p5-SOAP-Lite \
p5-URI>=0:net/p5-URI \
p5-XML-DoubleEncodedEntities>=1:textproc/p5-XML-DoubleEncodedEntities \
p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-YAML>=0:textproc/p5-YAML
USES= perl5
diff --git a/astro/p5-Astro-SIMBAD/Makefile b/astro/p5-Astro-SIMBAD/Makefile
index 13c8844db059..38c9a28ce02f 100644
--- a/astro/p5-Astro-SIMBAD/Makefile
+++ b/astro/p5-Astro-SIMBAD/Makefile
@@ -13,10 +13,10 @@ COMMENT= OO Perl interface to the SIMBAD astronomical database
LICENSE= GPLv2+
-BUILD_DEPENDS= p5-HTML-Parser>=3.36:www/p5-HTML-Parser \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTML-Parser>=3.36:www/p5-HTML-Parser \
p5-HTML-Tree>=3.17:www/p5-HTML-Tree \
p5-libwww>=5.53:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/astro/p5-Astro-Telescope/Makefile b/astro/p5-Astro-Telescope/Makefile
index 25a36ce3b60e..0344621a34dc 100644
--- a/astro/p5-Astro-Telescope/Makefile
+++ b/astro/p5-Astro-Telescope/Makefile
@@ -14,8 +14,8 @@ COMMENT= Class for obtaining telescope information
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Astro-PAL>=0.99:astro/p5-Astro-PAL
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-PAL>=0.99:astro/p5-Astro-PAL
NO_ARCH= yes
USE_PERL5= modbuild
diff --git a/astro/p5-GPS-Babel/Makefile b/astro/p5-GPS-Babel/Makefile
index 7760839e2d22..6f609bd92788 100644
--- a/astro/p5-GPS-Babel/Makefile
+++ b/astro/p5-GPS-Babel/Makefile
@@ -14,9 +14,9 @@ COMMENT= Perl interface to gpsbabel
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-File-Which>=0.05:sysutils/p5-File-Which \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-File-Which>=0.05:sysutils/p5-File-Which \
p5-Geo-Gpx>=0.25:graphics/p5-Geo-Gpx
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/astro/p5-GPS/Makefile b/astro/p5-GPS/Makefile
index fb8b3ce953be..8d2a23a3982b 100644
--- a/astro/p5-GPS/Makefile
+++ b/astro/p5-GPS/Makefile
@@ -15,8 +15,8 @@ COMMENT= Perl interface to GPS receivers
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Device-SerialPort>=0.07:comms/p5-Device-SerialPort
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Device-SerialPort>=0.07:comms/p5-Device-SerialPort
USES= perl5
USE_PERL5= configure
diff --git a/astro/p5-Starlink-AST/Makefile b/astro/p5-Starlink-AST/Makefile
index aed3bfd9096d..43b2f3c03e64 100644
--- a/astro/p5-Starlink-AST/Makefile
+++ b/astro/p5-Starlink-AST/Makefile
@@ -14,9 +14,9 @@ COMMENT= Interface to the Starlink AST library
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Astro-FITS-CFITSIO>=0:astro/p5-Astro-FITS-CFITSIO \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Astro-FITS-CFITSIO>=0:astro/p5-Astro-FITS-CFITSIO \
p5-Astro-FITS-Header>=0:astro/p5-Astro-FITS-Header
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Number-Delta>=0:devel/p5-Test-Number-Delta
USES= perl5
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
index 2dad9872db31..2ce5406d06a3 100644
--- a/astro/p5-Weather-Underground/Makefile
+++ b/astro/p5-Weather-Underground/Makefile
@@ -14,9 +14,9 @@ COMMENT= Retrieve weather information from wunderground.com
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-HTML-Parser>=0:www/p5-HTML-Parser \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTML-Parser>=0:www/p5-HTML-Parser \
p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5