aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /astro
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479406
Diffstat (limited to 'astro')
-rw-r--r--astro/geographiclib/Makefile2
-rw-r--r--astro/libkgeomap/Makefile2
-rw-r--r--astro/marble/Makefile2
-rw-r--r--astro/opencpn/Makefile2
4 files changed, 6 insertions, 2 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index c07fc6077c4a..75048a5b7b32 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -26,7 +26,7 @@ CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
-DINSTALL_PYTHON_DIR:STRING=${PYTHON_SITELIBDIR:Q}\
-DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
-OPTIONS_DEFINE= DOXYGEN PERL
+OPTIONS_DEFINE= DOXYGEN PERL DOCS
OPTIONS_DEFAULT= DOXYGEN PERL\
GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84\
MAGNETIC_WMM2015 MAGNETIC_IGRF12
diff --git a/astro/libkgeomap/Makefile b/astro/libkgeomap/Makefile
index c1171db6ae05..a467a7cbf08c 100644
--- a/astro/libkgeomap/Makefile
+++ b/astro/libkgeomap/Makefile
@@ -20,4 +20,6 @@ USE_QT= concurrent core gui network webkit widgets xml \
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 0e59d83491a3..2a2c4522e255 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -27,7 +27,7 @@ MAKE_ENV= XDG_CONFIG_HOME=/dev/null
CMAKE_ARGS= -DMOBILE:BOOL=FALSE \
-DQT_IMPORTS_DIR:PATH=${QT_IMPORTDIR}
-OPTIONS_DEFINE= GPS
+OPTIONS_DEFINE= GPS DOCS
OPTIONS_DEFAULT=GPS
OPTIONS_SUB= yes
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index c2917704458e..6dcfe0cd165d 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -34,6 +34,8 @@ LDFLAGS+= -Wl,--as-needed # ICE, SM, Xext
BROKEN_aarch64= Fails to compile: use of undeclared identifier rand
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/src/mygdal/cpl_csv.cpp \