aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 07:18:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 07:18:23 +0000
commita94279b1a014968dcc42bf1336319dc36056a245 (patch)
treee8c80904ed921028ba37fd97d32402bb48922fdf /astro
parent7cdbec9cd65a97cbea0e0d719f920cf93341b206 (diff)
downloadports-a94279b1a014968dcc42bf1336319dc36056a245.tar.gz
ports-a94279b1a014968dcc42bf1336319dc36056a245.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-Catalog/Makefile31
-rw-r--r--astro/p5-Astro-Catalog/distinfo1
-rw-r--r--astro/p5-Astro-Catalog/pkg-comment1
-rw-r--r--astro/p5-Astro-Catalog/pkg-descr1
-rw-r--r--astro/p5-Astro-Catalog/pkg-plist11
6 files changed, 46 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 65dbd4f226a0..313f5e6288f6 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -23,6 +23,7 @@
SUBDIR += nightfall
SUBDIR += openuniverse
SUBDIR += p5-Astro-ADS
+ SUBDIR += p5-Astro-Catalog
SUBDIR += p5-Astro-DSS
SUBDIR += p5-Astro-MoonPhase
SUBDIR += p5-Astro-SIMBAD
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
new file mode 100644
index 000000000000..d9af90790d87
--- /dev/null
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: Astro-Catalog
+# Date created: Oct 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-Catalog
+PORTVERSION= 1.8.1
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.astro.ex.ac.uk/estar/software/
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Astro::Catalog.3 \
+ Astro::Catalog::GSC::Query.3 \
+ Astro::Catalog::Star.3 \
+ Astro::Catalog::USNOA2::Query.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-Catalog/distinfo b/astro/p5-Astro-Catalog/distinfo
new file mode 100644
index 000000000000..bf85278aedee
--- /dev/null
+++ b/astro/p5-Astro-Catalog/distinfo
@@ -0,0 +1 @@
+MD5 (Astro-Catalog-1.8.1.tar.gz) = 5a0fa1bae0d50993024863a05bf9418f
diff --git a/astro/p5-Astro-Catalog/pkg-comment b/astro/p5-Astro-Catalog/pkg-comment
new file mode 100644
index 000000000000..c8b30bd8e97b
--- /dev/null
+++ b/astro/p5-Astro-Catalog/pkg-comment
@@ -0,0 +1 @@
+A generic stellar catalogue object
diff --git a/astro/p5-Astro-Catalog/pkg-descr b/astro/p5-Astro-Catalog/pkg-descr
new file mode 100644
index 000000000000..6dfcffbc8946
--- /dev/null
+++ b/astro/p5-Astro-Catalog/pkg-descr
@@ -0,0 +1 @@
+A generic object orientated astronomical catalogue object.
diff --git a/astro/p5-Astro-Catalog/pkg-plist b/astro/p5-Astro-Catalog/pkg-plist
new file mode 100644
index 000000000000..74040b4b4a58
--- /dev/null
+++ b/astro/p5-Astro-Catalog/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog.pm
+lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog/GSC/Query.pm
+lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog/Star.pm
+lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog/USNOA2/Query.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/Catalog/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog/GSC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog/USNOA2
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Astro/Catalog
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro/Catalog
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Astro 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Astro 2>/dev/null || true