aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-03-10 08:26:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-03-10 08:26:20 +0000
commita9afa08eb6aeadada262bf96ffa88fc70f84860f (patch)
tree8cfa1972fc01c34e89540b039c244aba57f188f5 /astro
parenta3286022d81a367e0a12b309606227fe06f0d382 (diff)
downloadports-a9afa08eb6aeadada262bf96ffa88fc70f84860f.tar.gz
ports-a9afa08eb6aeadada262bf96ffa88fc70f84860f.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile55
-rw-r--r--astro/cfitsio/distinfo4
-rw-r--r--astro/cfitsio/pkg-plist4
3 files changed, 27 insertions, 36 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 7d424018052c..4a03a8aaee60 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -2,56 +2,51 @@
# $FreeBSD$
PORTNAME= cfitsio
-PORTVERSION= 3.310
+PORTVERSION= 3.330
CATEGORIES= astro
-MASTER_SITES= ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/%SUBDIR%/ \
- http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/%SUBDIR%/
-MASTER_SITE_SUBDIR= . oldvers
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
+ http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
+ ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/ \
+ ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/oldvers/ \
+ LOCAL/sunpoet
+DISTNAME= ${PORTNAME}${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library for reading and writing files in FITS data format
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/License.txt
LIB_DEPENDS= f2c:${PORTSDIR}/lang/f2c
OPTIONS_DEFINE= DOCS
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_PKGCONFIG= build
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
ALL_TARGET= shared
-USE_LDCONFIG= yes
+CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
+GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.options.mk>
+PORTDOCS= *
-post-extract:
- @cd ${WRKSRC} && ${MV} zlib.h zlib.h.dist
+.include <bsd.port.options.mk>
post-patch:
+ @${REINPLACE_CMD} -e 's|="\.so"|=".so.0"|g' ${WRKSRC}/configure
+ @${MV} ${WRKSRC}/zlib.h ${WRKSRC}/zlib.h.dist
@${GREP} -lR "<malloc.\h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
- @${REINPLACE_CMD} -e 's|="\.so"|=".so.0"|g' ${WRKSRC}/configure
do-install:
-.for file in drvrsmem.h fitsio.h fitsio2.h longnam.h
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include
-.endfor
-.for f in libcfitsio.so.0
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib
-.endfor
- @${LN} -sf libcfitsio.so.0 ${PREFIX}/lib/libcfitsio.so
-.for f in cfitsio.pc
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/libdata/pkgconfig
-.endfor
+ cd ${WRKSRC}/ && \
+ ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${PREFIX}/include/ && \
+ ${INSTALL_LIB} libcfitsio.so.0 ${PREFIX}/lib/ && \
+ ${INSTALL_DATA} cfitsio.pc ${PREFIX}/libdata/pkgconfig/
+ ${LN} -fs libcfitsio.so.0 ${PREFIX}/lib/libcfitsio.so
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/astro/cfitsio/distinfo b/astro/cfitsio/distinfo
index bf08ae1850b6..8078afa9e655 100644
--- a/astro/cfitsio/distinfo
+++ b/astro/cfitsio/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfitsio3310.tar.gz) = e8a70bca202caa4773c4a50288622ef5398752de5a5e8fcfc232859f928ff5d9
-SIZE (cfitsio3310.tar.gz) = 4664559
+SHA256 (cfitsio3330.tar.gz) = ed686cc776641d4352f8670d3dd9a4750bdb54f2fe04c8d81fb8eeb79c1d2b25
+SIZE (cfitsio3330.tar.gz) = 4481323
diff --git a/astro/cfitsio/pkg-plist b/astro/cfitsio/pkg-plist
index 826f3d86e72f..43d9277c2da5 100644
--- a/astro/cfitsio/pkg-plist
+++ b/astro/cfitsio/pkg-plist
@@ -5,7 +5,3 @@ include/longnam.h
lib/libcfitsio.so
lib/libcfitsio.so.0
libdata/pkgconfig/cfitsio.pc
-%%PORTDOCS%%%%DOCSDIR%%/cfitsio.doc
-%%PORTDOCS%%%%DOCSDIR%%/cfortran.doc
-%%PORTDOCS%%%%DOCSDIR%%/fitsio.doc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%