aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-12 06:03:58 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-12 06:03:58 +0000
commit5afe3af5800cef153c206dcf3ce2f56aa85ada42 (patch)
tree43a75d1113991650ff8764ee64732c9d181c0ce4 /astro
parente10369322220c0fa0a0ab68ed222621adf553709 (diff)
downloadports-5afe3af5800cef153c206dcf3ce2f56aa85ada42.tar.gz
ports-5afe3af5800cef153c206dcf3ce2f56aa85ada42.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-GPS/Makefile3
-rw-r--r--astro/p5-Weather-Underground/Makefile9
-rw-r--r--astro/p5-ZConf-Weather/Makefile9
-rw-r--r--astro/weatherspect/Makefile8
4 files changed, 10 insertions, 19 deletions
diff --git a/astro/p5-GPS/Makefile b/astro/p5-GPS/Makefile
index 9a787008dbdb..5fbe272e0f7c 100644
--- a/astro/p5-GPS/Makefile
+++ b/astro/p5-GPS/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl interface to GPS receivers
BUILD_DEPENDS= p5-Device-SerialPort>=0.07:${PORTSDIR}/comms/p5-Device-SerialPort
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GPS::Serial.3 \
GPS::NMEA.3 \
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
index 119c196c0310..ff88488f03ff 100644
--- a/astro/p5-Weather-Underground/Makefile
+++ b/astro/p5-Weather-Underground/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Weather-Underground
-# Date created: 2006-05-16
-# Whom: Simon Olofsson <simon@olofsson.de>
-#
+# Created by: Simon Olofsson <simon@olofsson.de>
# $FreeBSD$
-#
PORTNAME= Weather-Underground
PORTVERSION= 3.03
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Weather::Underground.3
diff --git a/astro/p5-ZConf-Weather/Makefile b/astro/p5-ZConf-Weather/Makefile
index 669350b176a4..f6f77c158567 100644
--- a/astro/p5-ZConf-Weather/Makefile
+++ b/astro/p5-ZConf-Weather/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-ZConf-Weather
-# Date created: 2009-09-27
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= ZConf-Weather
PORTVERSION= 1.0.0
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-ZConf>=6.1.0:${PORTSDIR}/net/p5-ZConf \
p5-Weather-Underground>=3.03:${PORTSDIR}/astro/p5-Weather-Underground
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::Weather.3
diff --git a/astro/weatherspect/Makefile b/astro/weatherspect/Makefile
index 525a801d4fd2..8657582677b0 100644
--- a/astro/weatherspect/Makefile
+++ b/astro/weatherspect/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: weatherspect
-# Date created: 2006-05-16
-# Whom: Simon Olofsson <simon@olofsson.de>
-#
+# Created by: Simon Olofsson <simon@olofsson.de>
# $FreeBSD$
-#
PORTNAME= weatherspect
PORTVERSION= 1.9
@@ -24,7 +20,7 @@ RUN_DEPENDS= p5-Term-Animation>=0:${PORTSDIR}/devel/p5-Term-Animation \
PORTSCOUT= skipv:1.31 # Wrong versioning upstream
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/weatherspect
do-install: