aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /astro
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/wmsolar/Makefile2
-rw-r--r--astro/wmsolar/files/patch-Makefile6
-rw-r--r--astro/wmsolar/files/patch-Vsop.h16
3 files changed, 12 insertions, 12 deletions
diff --git a/astro/wmsolar/Makefile b/astro/wmsolar/Makefile
index 4460d1c563be..51be13a22a89 100644
--- a/astro/wmsolar/Makefile
+++ b/astro/wmsolar/Makefile
@@ -15,7 +15,7 @@ GH_ACCOUNT= engerim42
PLIST_FILES= bin/wmSolar
USE_XORG= x11 xext xpm
-USES= gmake
+USES= dos2unix gmake
pre-patch:
@${REINPLACE_CMD} -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
diff --git a/astro/wmsolar/files/patch-Makefile b/astro/wmsolar/files/patch-Makefile
index 504e2575acda..4e76bbdfb27b 100644
--- a/astro/wmsolar/files/patch-Makefile
+++ b/astro/wmsolar/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jan 15 17:54:38 2002
-+++ Makefile Tue Jan 15 17:56:37 2002
+--- Makefile.orig 2016-06-20 12:40:27 UTC
++++ Makefile
@@ -1,8 +1,6 @@
-CC = g++
-CFLAGS = -O2 -Wall
@@ -11,7 +11,7 @@
# for linux
LIBS = -lXpm -lX11 -lXext -lm
# for Solaris
-@@ -19,14 +17,14 @@
+@@ -19,14 +17,14 @@ OBJS = wmSolar.o \
RiseSet.o \
Vsop.o
.c.o:
diff --git a/astro/wmsolar/files/patch-Vsop.h b/astro/wmsolar/files/patch-Vsop.h
index 517afb91984b..b43c3e292aa0 100644
--- a/astro/wmsolar/files/patch-Vsop.h
+++ b/astro/wmsolar/files/patch-Vsop.h
@@ -1,10 +1,10 @@
---- Vsop.h.orig Tue Nov 26 15:41:59 2002
-+++ Vsop.h Tue Nov 26 15:42:13 2002
+--- Vsop.h.orig 2016-06-20 12:40:27 UTC
++++ Vsop.h
@@ -12,6 +12,7 @@
- #define VSOP__H
-
- #include "PlanetData.h" // for enum Planet
+ #define VSOP__H
+
+ #include "PlanetData.h" // for enum Planet
+#include <math.h>
-
- // * * * * * simple support structs * * * * *
-
+
+ // * * * * * simple support structs * * * * *
+