aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
commit4819ca343bfee8a3b54e7ff3ac26d280d1c1696f (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /astro
parent49b7a7d4a4e27031eeb48b2c26d102a7f8527de9 (diff)
downloadports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.tar.gz
ports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-Astro-ADS/Makefile5
-rw-r--r--astro/p5-Astro-Catalog/Makefile3
-rw-r--r--astro/p5-Astro-Constants/Makefile9
-rw-r--r--astro/p5-Astro-DSS/Makefile5
-rw-r--r--astro/p5-Astro-FITS-Header/Makefile4
-rw-r--r--astro/p5-Astro-Hipparcos/Makefile3
-rw-r--r--astro/p5-Astro-MoonPhase/Makefile9
-rw-r--r--astro/p5-Astro-SIMBAD-Client/Makefile3
-rw-r--r--astro/p5-Astro-SIMBAD/Makefile5
-rw-r--r--astro/p5-Astro-SunTime/Makefile11
-rw-r--r--astro/p5-Astro-satpass/Makefile3
-rw-r--r--astro/p5-Astro/Makefile3
-rw-r--r--astro/p5-GPS-Babel/Makefile3
-rw-r--r--astro/p5-Geo-METAR/Makefile5
14 files changed, 31 insertions, 40 deletions
diff --git a/astro/p5-Astro-ADS/Makefile b/astro/p5-Astro-ADS/Makefile
index 4319f3883b76..cb77a80d63bf 100644
--- a/astro/p5-Astro-ADS/Makefile
+++ b/astro/p5-Astro-ADS/Makefile
@@ -14,9 +14,8 @@ COMMENT= OO Perl interface to the ADS abstract service
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= adsquery.1
MAN3= Astro::ADS.3 Astro::ADS::Query.3 Astro::ADS::Result.3 Astro::ADS::Result::Paper.3
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
index a5ea71b922b5..ff724d61239e 100644
--- a/astro/p5-Astro-Catalog/Makefile
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -28,7 +28,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Astro::Catalog.3 \
Astro::Catalog::IO::ASCII.3 \
diff --git a/astro/p5-Astro-Constants/Makefile b/astro/p5-Astro-Constants/Makefile
index 130a8d7db68d..6a323cf52288 100644
--- a/astro/p5-Astro-Constants/Makefile
+++ b/astro/p5-Astro-Constants/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: astro/p5-Astro-Constants
-# Date created: 04 April 2010
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Astro-Constants
PORTVERSION= 0.09
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Physical constants for use in astronomy
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::Constants.3
diff --git a/astro/p5-Astro-DSS/Makefile b/astro/p5-Astro-DSS/Makefile
index 39ae4849598a..9bdc9ffd2e7a 100644
--- a/astro/p5-Astro-DSS/Makefile
+++ b/astro/p5-Astro-DSS/Makefile
@@ -14,9 +14,8 @@ COMMENT= OO interface to the 1st and 2nd Digital Sky Surveys
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::DSS.3
diff --git a/astro/p5-Astro-FITS-Header/Makefile b/astro/p5-Astro-FITS-Header/Makefile
index bd3397be38ee..c93a3aec57d4 100644
--- a/astro/p5-Astro-FITS-Header/Makefile
+++ b/astro/p5-Astro-FITS-Header/Makefile
@@ -12,8 +12,8 @@ COMMENT= Object Orientated interface to FITS HDUs
LICENSE= GPLv3
-MAKE_JOBS_SAFE= yes
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Astro::FITS::Header.3 \
Astro::FITS::Header::AST.3 \
diff --git a/astro/p5-Astro-Hipparcos/Makefile b/astro/p5-Astro-Hipparcos/Makefile
index ca6d87a6abdf..c08bcc03c364 100644
--- a/astro/p5-Astro-Hipparcos/Makefile
+++ b/astro/p5-Astro-Hipparcos/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-ExtUtils-XSpp>=0.06:${PORTSDIR}/devel/p5-ExtUtils-XSpp \
p5-ExtUtils-ParseXS>=2.22:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
MAKE_ARGS+= "CC=g++"
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::Hipparcos::Record.3 \
Astro::Hipparcos.3
diff --git a/astro/p5-Astro-MoonPhase/Makefile b/astro/p5-Astro-MoonPhase/Makefile
index c600d5dffa2b..5120962635fb 100644
--- a/astro/p5-Astro-MoonPhase/Makefile
+++ b/astro/p5-Astro-MoonPhase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Astro-MoonPhase
-# Date created: Mon Jan 1 09:43:10 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Astro-MoonPhase
PORTVERSION= 0.60
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to calculate information about the phase of the moon
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::MoonPhase.3
diff --git a/astro/p5-Astro-SIMBAD-Client/Makefile b/astro/p5-Astro-SIMBAD-Client/Makefile
index 6ded82b0764f..81a4b8814d1b 100644
--- a/astro/p5-Astro-SIMBAD-Client/Makefile
+++ b/astro/p5-Astro-SIMBAD-Client/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= -y
MAN1= simbadc.1
diff --git a/astro/p5-Astro-SIMBAD/Makefile b/astro/p5-Astro-SIMBAD/Makefile
index d8a80ea82599..6065e4c4f001 100644
--- a/astro/p5-Astro-SIMBAD/Makefile
+++ b/astro/p5-Astro-SIMBAD/Makefile
@@ -14,9 +14,8 @@ COMMENT= OO Perl interface to the SIMBAD astronomical database
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::SIMBAD.3 \
Astro::SIMBAD::Query.3 \
diff --git a/astro/p5-Astro-SunTime/Makefile b/astro/p5-Astro-SunTime/Makefile
index 884ecb2c3d90..c13414bed806 100644
--- a/astro/p5-Astro-SunTime/Makefile
+++ b/astro/p5-Astro-SunTime/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Astro-SunTime
-# Date created: Mon Jan 1 10:06:12 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Astro-SunTime
PORTVERSION= 0.01
@@ -18,8 +14,7 @@ COMMENT= Perl interface to calculate sunrise/sunset times
BUILD_DEPENDS= p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/astro/p5-Astro-satpass/Makefile b/astro/p5-Astro-satpass/Makefile
index 1d18e0706962..9f123d23da66 100644
--- a/astro/p5-Astro-satpass/Makefile
+++ b/astro/p5-Astro-satpass/Makefile
@@ -27,7 +27,8 @@ SPACETRACK_DESC= Add support for Astro::SpaceTrack
USGS_DESC= Add support for Geo::WebService::Elevation::USGS
CONFIGURE_ARGS= -y
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= satpass.1
MAN3= Astro::Coord::ECI.3 \
diff --git a/astro/p5-Astro/Makefile b/astro/p5-Astro/Makefile
index af4780b72088..7cb40b568bb5 100644
--- a/astro/p5-Astro/Makefile
+++ b/astro/p5-Astro/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Collection of useful astronomical routines in Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::Time.3 \
Astro::Misc.3 \
diff --git a/astro/p5-GPS-Babel/Makefile b/astro/p5-GPS-Babel/Makefile
index 2554cc798db6..e167ee8a0b29 100644
--- a/astro/p5-GPS-Babel/Makefile
+++ b/astro/p5-GPS-Babel/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Geo-Gpx>=0.25:${PORTSDIR}/graphics/p5-Geo-Gpx \
RUN_DEPENDS= p5-Geo-Gpx>=0.25:${PORTSDIR}/graphics/p5-Geo-Gpx \
p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GPS::Babel.3
diff --git a/astro/p5-Geo-METAR/Makefile b/astro/p5-Geo-METAR/Makefile
index e7eec848e7e3..814ecdcb9a91 100644
--- a/astro/p5-Geo-METAR/Makefile
+++ b/astro/p5-Geo-METAR/Makefile
@@ -11,9 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module that processes METAR information from NOAA sources
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::METAR.3