aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-29 00:03:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-29 00:03:12 +0000
commitb228dc15e623482a97471ce24a1c1c5467316dbc (patch)
tree6fd47c7317e7d9587ee889beaf52bad979bb8cb7 /astro
parent2fb53a525c56db40b4b6544dbddf34d954ad6c37 (diff)
downloadports-b228dc15e623482a97471ce24a1c1c5467316dbc.tar.gz
ports-b228dc15e623482a97471ce24a1c1c5467316dbc.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-metpy/Makefile28
-rw-r--r--astro/py-metpy/distinfo3
-rw-r--r--astro/py-metpy/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 7ac84b700e24..891330279e09 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -87,6 +87,7 @@
SUBDIR += py-astLib
SUBDIR += py-astropy
SUBDIR += py-horoscopegenerator
+ SUBDIR += py-metpy
SUBDIR += py-pymetar
SUBDIR += py-pywapi
SUBDIR += pyephem
diff --git a/astro/py-metpy/Makefile b/astro/py-metpy/Makefile
new file mode 100644
index 000000000000..b9c1914b647d
--- /dev/null
+++ b/astro/py-metpy/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= metpy
+PORTVERSION= 0.7.0
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= MetPy-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Collection of tools for processing weather data
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${ENUM34} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.10.0:math/py-numpy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pint>=0.8:converters/py-pint@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyproj>=1.9.4:graphics/py-pyproj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.14:science/py-scipy@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/astro/py-metpy/distinfo b/astro/py-metpy/distinfo
new file mode 100644
index 000000000000..2448ede86ddf
--- /dev/null
+++ b/astro/py-metpy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521205923
+SHA256 (MetPy-0.7.0.tar.gz) = 1e3693e20b5e8c3e937024df6a83cc890a9bad222b14737fa67054b52b4cde19
+SIZE (MetPy-0.7.0.tar.gz) = 1675847
diff --git a/astro/py-metpy/pkg-descr b/astro/py-metpy/pkg-descr
new file mode 100644
index 000000000000..48c8bab5bb56
--- /dev/null
+++ b/astro/py-metpy/pkg-descr
@@ -0,0 +1,5 @@
+MetPy is a collection of tools in Python for reading, visualizing and performing
+calculations with weather data.
+
+WWW: https://pypi.org/project/metpy/
+WWW: https://github.com/Unidata/MetPy