aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-05 01:16:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-05 01:16:39 +0000
commitb446e9d2cac6da8991659dd2e44ce9872f582152 (patch)
tree1921f642364492045e7de663f30706a33dfc9426 /astro
parent0d0d56457bb54d930410a5b55092e1624f3012e5 (diff)
downloadports-b446e9d2cac6da8991659dd2e44ce9872f582152.tar.gz
ports-b446e9d2cac6da8991659dd2e44ce9872f582152.zip
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index c56cd8c4bdc7..7990a6fbeb67 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -21,17 +21,22 @@ RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
# The compiler flags below are copied from m4/optimizations.m4,
# leaving out the -march flag which is set by /usr/share/mk/bsd.cpu.mk
.if ${MACHINE_CPU:Msse3}
-CFLAGS+= -msse3 -mfpmath=sse
+CFLAGS+= -msse3
.elif ${MACHINE_CPU:Msse2}
-CFLAGS+= -msse2 -mfpmath=sse
+CFLAGS+= -msse2
.elif ${MACHINE_CPU:Msse}
-CFLAGS+= -msse -mfpmath=sse
+CFLAGS+= -msse
.endif
.if ${MACHINE_CPU:Mmmx}
-CFLAGS+= -mmmx -mfpmath=387
+CFLAGS+= -mmmx
.endif
.ifdef ${MACHINE_CPU:M3dnow}
-CFLAGS+= -m3dnow -mfpmath=387
+CFLAGS+= -m3dnow
+.endif
+.if ${MACHINE_CPU:Msse3} || ${MACHINE_CPU:Msse2} || ${MACHINE_CPU:Msse}
+CFLAGS+= -mfpmath=sse
+.else
+CFLAGS+= -mfpmath=387
.endif
# From http://www,lb.shuttle.de/apastron/boincDown.shtml :
# what about other 64 bit archs (especially S/390, see gcc.info.gz) ?