aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 22:59:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 22:59:14 +0000
commit69e7cda35d08a7ace4d69fb1b8cdce143203b811 (patch)
treeb63f75b107e35d8196af40dbab58eb5eb305e478 /astro
parentf75362a8fca88f7b166c34d223b155cc44d24967 (diff)
Notes
Diffstat (limited to 'astro')
-rw-r--r--astro/gpxloggerd/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/gpxloggerd/Makefile b/astro/gpxloggerd/Makefile
index c0c9e2369595..de6b1617e402 100644
--- a/astro/gpxloggerd/Makefile
+++ b/astro/gpxloggerd/Makefile
@@ -9,17 +9,16 @@ MASTER_SITES= LOCAL/glebius
MAINTAINER= glebius@FreeBSD.org
COMMENT= Daemon that connects to the GPSD daemon and logs GPS traces
-LIB_DEPENDS= gps:${PORTSDIR}/astro/gpsd
+LIB_DEPENDS= libgps.so:${PORTSDIR}/astro/gpsd
-NO_STAGE= yes
USE_RC_SUBR= ${PORTNAME}
-PLIST_FILES= sbin/${PORTNAME}
-MAN8= ${PORTNAME}.8
+PLIST_FILES= sbin/${PORTNAME} \
+ man/man8/${PORTNAME}.8.gz
LDFLAGS+= -lm
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8/
.include <bsd.port.mk>